Posts created by catluvr

 
 
 posted in Frankenstein: The Village on Mar 22, 16 8:41 AM
Im at the river and have the lantern, but when i go to the dark woods and place the lantern nothing happens. i can go no farther. Is this a glitch?
 
 
 posted in Rite of Passage: The Lost Tides Collector's Edition on May 4, 15 10:33 AM
I bought the game but can't past the demo. What's up with that? It keeps saying " thanks for playing the demo" but i can't get into the game. hate to spend money on stuff like this. Very disapointing!!
 
 
trying to get the correct stamps but when i stamp the images it says there must be a clue somewhere. i've tried all combinations but to bo avail.
 
 
 posted in Mystery Expedition: Prisoners of Ice on Feb 20, 14 7:58 AM
played the demo then bought the game. guess what...stuck at cabin playing hos. keeps taking me back there and ive already played it! i want a refund. tired of the games not playing.
 
 
Game locked up. I can't go anywhere. The direction arrow is not working anymore so there is nothing I can do!! Another waste of good money.

i closed the game and went back in. it is working fine now.
 
 
 posted in The World`s Legends: Kashchey the Immortal on Aug 7, 12 8:46 AM
I played just fine until I got a runtime error. Too bad. Looked to be a pretty good game. Guess I'll never know.
 
 
 posted in Severe Incident: Cargo Flight 821 on Jul 9, 12 9:54 AM
I've gotten to the train and the lab. I have ALL kinds of stuff in inventory but there is nothing to find or do. No HOS or places to use the stuff. Any help is appreciated.
 
 
 posted in Ghost Whisperer™ on Jul 9, 12 7:46 AM
I've already done those things and still nothing> Maybe I change profile and start over again. It has worked in the past with glitches. Hate to tho.
 
 
 posted in Ghost Whisperer™ on Jul 8, 12 1:34 PM
I too am having the same problem with package. There is no change in cursor showing you to interact so I can't go any further. The Museum is the only spot on map to go to. Sorry I bought it.
 
 
 posted in Tearstone on May 9, 12 10:43 AM
im having trouble with the flower on bottom right. it wont stick. tried for 30 min. guess i'll give up. getting tired of game glitches.
 
 
 posted in Tearstone on May 9, 12 10:32 AM
I too cannot place the last flower. been trying for 20 min. really frustrating!
 
 
updated video drivers to no avail. still no shovel. if it can't be fixed i would like a credit.
 
 
 posted in Vampire Saga: Break Out on Apr 22, 12 11:21 AM
code snippet shows up (Trying to add field "photo_closeup". thats already on screen.) Photo is of sheriff with trophy. I can not go any further with game. Would like to finish, but if not would like a credit for game.
 
 
near end and can't get shovel. can't finish game. It's getting to where every game I buy has a problem. I now have 2 games I can't finish! I am very disappointed and dissatisfied.
 
 
 posted in Vampire Saga: Break Out on Apr 11, 12 12:12 PM
just got out of jail and the photo close up will not close. error "try to add field "photo closeup" thats already on screen" I can go no further! anyone else having this prob?
 
 
 posted in Dark Strokes: Sins of the Fathers Collector's Edition on Mar 20, 12 12:00 PM
im on the ship and need to melt something to make bullets? all i have is chalk and ruby heart. cant find knife to get oars!! also where is the key to captains bed??help please! NEVER MIND I GOT IT!
 
 
 posted in Around the World in Eighty Days: The Challenge on Feb 21, 12 9:17 AM
thanks lemongrass!!! was about to quit but got it!
 
 
 posted in Around the World in Eighty Days: The Challenge on Feb 21, 12 8:57 AM
I too am stuck at the train in USA. Can't get the last crate. VERY frustrating. Wondering if BF is putting games TOO fast. ill play something else but don't know if I'll buy anymore. Second game I've had issues with.
 
 
 posted in Big City Adventure: London Story on Jan 29, 12 12:09 PM
where is the last puzzle piece to open the padlock on the boat?
 
 
 posted in Mystery Valley on Nov 2, 10 11:40 AM
place the dynamite up in the stalagtites.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator