Posts created by jaylake

 
 
Please be aware that there may be a tech prob with this game ie at the time you need to use the nailgun it is not in the inventory. Just make sure you have this in your inventory if you can before going to the storage area to meet the mannaquins. This will make sense when you get there (Chapt 3).
 
 
had to replay and realised i had not picked up the pistol lighter from the loft. Will make sense when you get there. Make sure you do not enter the crypt without the pistol lighter as you will have to experience the same as I
 
 
Stuck in the cemetry and cant take any further action as in the crypt no light and now cannot get out of the crypt. I hope this is not another glitch. Anyone having same problem or is it me. Help would be appreciated
 
 
HI

Same issue at the well on Windows 10.
 
 
Hi

I was playing on windows 10. Windows 8 seems to be ok. I found a fatal directX issue and have taken this up with BF who have referred to their techinical dept as this game is similar to others that I have purchased and whilst I do not profess to be in any way a computer expert, given you say this seems an older game then perhaps it supports an older direct X version. This is just a guess but as said older games on my purchase history have the same problem. Suggest you contact customer support who are most understanding and will give you a good listening ear
 
 
Thanks for the response. At least some can play the game but I have been having the same tech issues as others and glad I am not the only one
 
 
Please action Tech issues asap. I would love to see a review so I can see that someone can play this game.
 
 
Hi

Well I am glad (sorry at the expense of others) that I am not the only one with issues. I wish I had at least tried the trial. Just for info I have now got the error code 900 which is not covered and told to contact customer support which I have done. I am not a happy bunny not least because I cannot play the game which it seem is reviewed well
 
 
Hi

Playing on PC

I was a little silly in highsight as I purchased the game, and now cannot play. It shows a load and then nothing. I have left it as I thought it was just being slow but nothing. Wish i had tried first. Will keep trying but may need to go to customer support again. They are good but this situation is disappointing.
 
 
 posted in Dark Dimensions: Vengeful Beauty Collector's Edition on May 6, 17 6:10 AM
I have again become frustrated and hope someone will let me know that this is me. I am at the fountain, have placed the pipe altered it according to the solution but nothing happens so I cannot fill the glass. Hopefully this will make sense to someone. I am going to replay from the start to see if this changes the situation. Most disappointing if this is a glitch.
 
 
 posted in Vermillion Watch: Fleshbound Collector's Edition on Dec 31, 16 4:50 AM
I cannot collect the bandages. I looked at the strategy guide and have selected the blades as indicated for the slider puzzle but nothing happens. Second CE in a row that i have had an issue. Of course maybe I am missing something anyone assist me pls. Using PC Windows 10
 
 
Hi

Please dont hold me to this but I recall moving around the broken glass hole and something kicked in sorry to be vague I am sure someone else will explain far better than me but this may get you going quicker.
 
 
Got stuck as the castle token for the mini game has disappeared and I cannot pick it up. Another good game somewhat spoilt but will try reloading. It means have to start the game over, which is not ideal. Anyone else have the same problem or a solution for me.
 
 
 posted in Surface: Lost Tales Collector's Edition on Jun 16, 16 2:36 AM
My fault entirely though not clear from the shadow that you pick it up and place it as with other items during the scene. Sorry but glad it would seem I was not the only one and looking forward therefore to hopefully a challenging game
 
 
 posted in Surface: Lost Tales Collector's Edition on Jun 16, 16 2:18 AM
Please accept no offence but if i am not the only one is there any answer pls
 
 
 posted in Surface: Lost Tales Collector's Edition on Jun 16, 16 12:50 AM
Looking for the thirteen socks pointed to the first but it will not pick up. Using windows 10 if I am alone will try by reloading
 
 
HI

Getting a runtime error and told to contact supplier in error message - sadly not the first time i have had issues with redemption games a big pity because overall a good game

 
 
 posted in Demon Hunter 3: Revelation Collector's Edition on Apr 16, 16 1:33 AM
Hi

I cannot pick up the first collectible no matter where I click around the doll
 
 
 posted in New York Mysteries: High Voltage Collector's Edition on Jun 7, 15 2:25 AM
I too have the same problem in the kitchen HO. I am sure others will agree that this is disappointing for another good game.

I am rather reluctantly going to start the game again (not the same mind you) as I have found (and I dont know why) that sometimes works
 
 
 posted in Mythic Wonders: Child of Prophecy Collector's Edition on May 23, 15 6:12 AM
I cannot finish the game and therefore cannot get the bonus chapter because the game will not let me use the pieces to put on the throne. It simply freezes, most disappointing as not really getting the full value of the game.

A pity as spoils what was a good game
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator