Posts created by piano45

 
 
 posted in Love Chronicles: Salvation Collector's Edition on May 30, 13 8:43 AM
I played the demo & everything worked fine. I then bought the game. But now when I hit the play button, nothing happens. I tried un-installing & re-installing and changing profiles, but it still doesn't play.
 
 
 posted in Surface: The Soaring City Collector's Edition on Jan 25, 13 8:32 AM
I'm having the same problem with this game that I had with Ghost Library. The cursor is very sluggish & takes a long time to actually click on anything. I disabled the special effects as it was suggested then; didn't help. Also, uninstalled & reinstalled game several times before finally giving up on it. Same thing is happening with this game now. My drivers & software are fine & I just installed an Adobe update.

Any other suggestions?. Elephant games are the only ones I have this problem with & never used to. I love your games & would hate to have to stop playing them altogether. Please help.
 
 
 posted in Guardians of Magic: Amanda's Awakening on Sep 30, 12 4:28 PM
I finally googled Guardians of Magic Walkthrough on the Internet & found the walkthrough for the game. It's in the **** website. I already found several steps that I missed. Hope this helps, Tuvana 65.
 
 
 posted in Guardians of Magic: Amanda's Awakening on Sep 30, 12 9:46 AM
I'm having the same problem. For those of you have finished the game, please help us! Thanks!
 
 
 posted in Arizona Rose and the Pirates' Riddles on Jul 10, 12 8:31 AM
I'm having the same problem as Cindy 4412. Happened in the same place. I've tried restarting, starting a new game, uninstalling & reinstalling & the problem is still there.

Hope tech will fix this. I like the game.

piano 45
 
 
I know I need the birdcage on the balcony, but don't know how to get it down-I've tried everything in my inventory & nothing works. Is there another cage somewhere?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator