Posts created by vals2010

 
 
Can any of you fantastic people please help me, as I am just about ready to tear my hair out lol. No matter how many times I try to take the emblem out of the bowl of burning embers, it won't let me! So I look for something else all around the place, thinking I had missed something - nothing. Hint button just keeps taking me back to the embers. aaaaagghhhhhhhh



Desperate!!
 
 
 posted in Mystery Case Files: Key to Ravenhearst on Dec 27, 15 2:33 PM
Hello, can anyone help me please? I can't seem to find the code for the cabinet above the bed in the master bedroom. If anyone can help, I would really appreciate it.
Also, I hope you have all had a wonderful Christmas, and wish you a Happy New Year. xxx
 
 
 posted in Mystery Case Files: Key to Ravenhearst on Dec 27, 15 2:30 PM
Already found the answer, ty.
 
 
 posted in Mystery Case Files: Key to Ravenhearst on Dec 25, 15 2:36 PM
Can anyone help please. I have been using the automatic punching thingy on the well wall forever, in all directions and nothing is happening. Can anyone please tell me where I am going wrong. Much appreciated, Thank you, and a Happy Christmas to you. xxxx
 
 
Hello & a Happy New Year everyone.

I hope one of you can help me with the mirrors. I have tried them at every conceivable angle, and can't find what the 'clue' is that it is asking for. The strategy guide is no help at all with this.
Any help would be greatly appreciated, and thank you in anticipation of help x
 
 
 posted in Shadow Wolf Mysteries: Under the Crimson Moon on Sep 23, 14 10:46 AM
Can someone please help me? I have the piece of film, and the vinegar solution, but it won't let me put the film with the other film on top of cupboard, and it won't let me put vinegar into glass. It won't let me continue without doing these.
Any help would be really appreciated. Thank you. x
 
 
Can someone please help me. I have the piece of film and the solution, but can't do anything with them. It won't let me put the film on the top of the cupboard, and it won't let me put the vinegar solution into the glass. Until I can sort out this problem, it won't let me do anything else.
A helpful reply would be really appreciated. Thank you. x
 
 
 posted in Tales of Terror: House on the Hill Collector's Edition on May 19, 14 1:30 PM
Can anyone help me please, as I am stuck. I can't find the sheet music for the musical contraption. The hint button just keeps taking me back to the hallway, and then indicates for me to go back further still, but the hallway is as far back as I can go!
 
 
 posted in Christmas Stories: A Christmas Carol on Jan 4, 14 5:30 AM
Thank you so much - I kept forgetting about the little scrooge in the corner lol.
Happy New Year to you xx
 
 
 posted in Christmas Stories: A Christmas Carol on Jan 3, 14 10:26 AM
Can anyone please help. For the life of me, I can't figure out what I am supposed to do with the lumberjack who is on the table in the writers house. All I have in my inventory are the flint, needle & thread, special lamp and Christmas stocking.
 
 
Would anyone be able to help please, as I can't William Shakespeare to appear.
 
 
 posted in Dark Sisterhood: The Initiation on Sep 30, 13 4:27 AM
Thank you all for your messages. Firstly, I was logged, because I logged out then logged in again to see if it made a difference - it didn't. I have always been with IE, and yes I'm on IE10 now, on Windows 8, but at first this was fine. I then started getting problems, so started using chrome just for BFG, then recently, that started giving me problems as well, so this last week, have gone back to IE10. I have downloaded since then, without problems (so to speak), up until today.
However, I am having the same problems with Game Manager as elevenstardragon!

I suppose I will just have to keep checking.
 
 
 posted in Dark Sisterhood: The Initiation on Sep 30, 13 2:09 AM
Why have I not got a download button (either for free trial, or to buy) for Dark Sisterhood: The Initiation?
This is the first time this has happened to me, so not sure what is going on. Can anyone help please?
 
 
What an absolute let-down this game was for me. Having played all of the other MCF games, I couldn't wait for a new one to come out, so I thought Hey great - a new MCF game. The game itself was utter rubbish - more jumps and flashes than a Vegas show! The story-line well, the least said about that the better.
Come on BFG and MCF, gives us something to get our teeth into, but most of all, give us a quality game, that we can enjoy playing, instead of this rubbish grrrrrrrr!
 
 
 posted in The Curse of the Werewolves on Jan 5, 13 4:02 AM
Thanks for reply Dragonladyoz, the problem with your solution, is the fact that I haven't got a bathroom yet lol. I do have some doors, that I can't get into, so maybe it's one of those. For the life of me, I can't seem to move on anywhere in this game - I think my brain must be fuddled, 'cos I'm well and truly STUCK!
 
 
 posted in The Curse of the Werewolves on Jan 4, 13 12:50 PM
Can anyone tell me where I can find this dratted stone, so that I can knock down the crate above the tree, and hopefully move on grrrrrr.
 
 
 posted in Inception of Darkness: Exorcist 3 on Nov 24, 12 6:35 AM
Lady8star wrote:Where is the walkthrough for this game.??? I can't get the snake to get under the stalagmite. I think it is supposed to go after toy rabbit but nothing is happening
 
 
 posted in 1 Moment of Time: Silentville on Aug 27, 12 1:13 PM
HELP! I'm a way behind everyone else with playing this game, as I have just started it today, even though I have had it installed for a while now. The problem I have, is where you have to put the flower powder into the machine, and turn the knobs to get the liquid into the flasks. The problem is, that although I have actually checked with the walkthrough, to make sure I am doing it correctly, the knobs on the front of the machine, won't work. Just the ones at the sides and top centre seem to be working. A thousand thanks you's for any help. xxxxxxx
 
 
 posted in Nightfall Mysteries: Black Heart Collector's Edition on Feb 6, 12 1:35 PM
HELP! Have played the demo without any problems, but having downloaded the full version today, there seems to be some problems. Firstly, after picking up the masks in the nursery, there should be a HOS which gives me a drawer handle so that I can get the last spider pin. There is no HOS and I have come out of the game and gone back in but still no HOS - can't continue without last spider pin.
Also, it won't allow me to put the tapes into the recorder (again, had no problem with this during the demo).
What gives BFG??
 
 
Having finally finished this game (with a lot of help), I was also disappointed that there was no bonus game - that's the only reason I buy CE's. As for the SG - call that a Strategy Guide - it was absolutely rubbish. What a total waste of money. The game itself was not enoyable and some of the tasks were, well, beyond the ridiculous. As for the quality of the game - all the way through, it was jumping and flickering which was really bad for the eyes. If the Ravenhearst story is now over, all I can say is "Thank Goodness". Out of the three games, the only one that I found to be any good and enoyable was "Return to Ravenhearst".
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator