Posts created by peelsee

I exited the game three times. On the third attempt, it opened.
I have the same problem. Tried everything. Nothing changes.
 posted in Mysteries of the Past: Shadow of the Daemon on Feb 17, 16 9:07 AM
I've tried every spot on the screen and I cannot attach the antlers to the rope.
 posted in The Cursed Island: Mask of Baragus on Nov 29, 14 4:26 AM
Exit the game and go back in. It should be there.
 posted in Beyond the Unknown: A Matter of Time on Aug 11, 14 5:19 AM
I feel your pain. You don't have to reset. Get NS to pick up the "bullet" from the door bolt. Press the arrows until you can get the "bullet" into the Claw. I must have tried 20 times before I figured it out. The puzzles in this game are really hard.
I have to find a cup to put the milk in for the panther. Where is it?
 posted in Phantasmat Collector's Edition on Jan 16, 11 11:02 AM
I did not get a Hidden Object scene and therefore, cannot find the engagement ring. I have tried everything. The scene is also very blurry. I can't leave the tower. What next?
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator