Posts created by viteacher

 
 
 posted in Redemption Cemetery: Bitter Frost on Jan 1, 15 10:16 AM
I have the same problem. I cannot get them joined.
 
 
 posted in Christmas Eve: Midnight's Call on Dec 28, 14 7:13 PM
I cannot get the key on the right side of the hourglass to connect. I tried positioning all around the key hole but no luck. i play on my Macbook Air with OS X Yosemite. VI Teacher
 
 
 posted in Christmas Eve: Midnight's Call on Dec 28, 14 7:06 PM
I cannot get the key on the right side of the hour glass to connect no matter where I position it. Help please VI Teacher
 
 
 posted in Witch Hunters: Stolen Beauty Collector`s Edition on Jan 1, 13 11:09 AM
I did not play the game in the order of the walkthrough. When I get a piece I go to the area and place it there. In the foyer, I did the HOS, but did not get a second map piece and I cannot get the bear medallion. All the hint button tells me to look elsewhere. This is very frustrating. There must be an error in the game. I do not want to read the walkthrough so that I do stuff in order or I cannot get a part. I want to figure out what to do without looking at the hints constantly.
So now what do I do? Start all over again? Not happy, VI Teacher
 
 
 posted in Fantastic Creations: House of Brass on Apr 8, 12 3:42 PM
I looked through the walkthrough and it says to put the bent cover on the sun and then put in the fireflies. It tells me I cannot use that item there. I changed my resolution. That did not help. I also tried the resolution change with the Phenomena of Cyan game. No go. I usually get me games on my Mac. These two games are on my new PC and I have had more problems then ever. Help!
 
 
 posted in Phenomenon: City of Cyan on Apr 1, 12 4:20 PM
I was enjoying the game with its different mini games and I just love the graphics. It is the most beautiful game I have ever played. I need to figure out how to take a picture of the Japanese garden so I can use it as wall paper. This is the one time I want wall paper and it is not a CE game. The journal is not useful. I was using the hint button if I got stuck and did not know what direction to go. I only used the strategy guide twice. It was nice having a strategy guide on a SE game. I know from the other posts that the game ends abruptly. I hope for a sequel. The game had some bugs though. I quite several times and I had to re-open it. The cursor does not have good control, but I managed ok with it. I got stuck in the library and could not get the hint button to work. I was unable to get the medallion or look under the table. Over all I would give it a 5 star for graphics, puzzles a 4 star, story 3-4 stars, general fun a 4.5 and quirky problems, a 2 star. I want to finish the game even if it ends abruptly.
VI Teacher
 
 
OK When do we see the Mac version come out? I am patiently waiting. I played the other games and want to see how this new one turns out.
Biting my fins in anticipation.
VIteacher
 
 
 posted in Magic Farm on Sep 12, 11 5:03 PM
I very much enjoyed playing Magic Farm 1. Now I am waiting for Magic Farm 2. It is not fair, the PCs got their version first. They should have released it for both the Macs and the PCs at the same time. Not so patiently waiting for the Mac version.
Does anyone know when it will be released. I will save my credits for it.
VI Teacher
 
 
 posted in CreaVures on Jun 2, 11 8:57 AM
Help! I cannot figure out how to get Bitey to cross 4 pink fruit to get to the tree and bipass the thorny bushes. I can get him on the bug to ride back and forth and jump to either fruit 1-2 from the left but no further. I know that Pokey can swing from Bitey but not enough to grab the quills on the tree. I am not a very good hand/eye coordination player. I do better with HOGs. But this game is cute, colorful and I like that they have to help each other. It is simple enough for my poor skills.
Help anyone!
VITeacher
 
 
 posted in Elixir of Immortality on Mar 26, 11 3:33 PM
Dear Fishes,

I read the forums and everyone seems to like this game. So I tried it. It has a story line. Characters in it. You put pieces together to make a part needed. You go from area to area to locate items. The HOG area are well light and enough of a challenge for me. Dark piles of junk are hard to see. I rarely used the hint button. I used the walkthrough a couple of times when my logic ran out. Great scenery! What other games does that developer make. If they are as good as this one, I will buy them.
Thanks fellow fishes,
VITeacher
 
 
Dear Fellow Fish,

I have finally finished Dire Grove. The hardest thing was finding the Kerosine to light the lamp. I never was able to hit that rabbit's head enough or in the right place to make it break off. I never got the potato chips or used the snow shoes. I never found any of the morphing objects even though I have the CE. Good game but very hard to find things or know what to do next. I like the scenes. The special effects are ok. The forum was helpful by saying that you have to find the final student in order to get the Hidden Object game in the store to get the kerosine. It is hard to know what you have possibly missed to trigger to the HOGs or move on to the next task. I am wondering if the other Mystery Case Files are as difficult as this one was for me. I am relatively new to the games. I played years ago with Myst.
Thanks fellow flounders,
VI teacher
 
 
 posted in Mystery Case Files®: Dire Grove™ on Feb 10, 11 2:19 PM
I cannot find the kerosine in the store so I can fill the lamp to see the cell phone in the farmhouse. I got the generator going, I got the ashes from the fireplace. I cannot get the hidden object scene in the store basement. There are no sparkles show a hidden object game there. I cannot get the glue which I need to finish fixing the torch that I will need on the bridge. The hammer does nothing on the bunny's head no matter where I hit it. I read the walkthrough and it says the kerosine should be on the shelf in the store. Where is it? Does this game have to be played in exact order for things to show up or happen? Good game but to many problems. Somebody help me!!!
vi teacher
 
 
 posted in Phantasmat on Feb 9, 11 3:17 PM
I just finished it the other night. Great! It kept me moving around and trying to find everything I needed. I played some of the bonus games to since I have the collector's edition. Later I may go back and try to beat my time. I like a game with a story and character's especially spooky ones. Many kuddos to the developer. Now back to my other game.
viteacher
 
 
 posted in Mystery of Mortlake Mansion on Feb 3, 11 11:43 AM
I love the game. Especially the shadowy rooms. Just spooky enough. I have to get some hints but not many. I had to stop myself to get some sleep. I did not want to stop playing. The game pauses for a few seconds when it goes through the portal but seems to work ok.
Is there another one like this one?
VI teacher
 
 
 posted in Death at Fairing Point: A Dana Knightstone Novel on Feb 3, 11 11:39 AM
I finished the game last night. It was fun doing a game in chapters. I rarely looked for help. I hope to see another like it. I would purchase it for sure.
Vi teacher
 
 
I find the game challenging enough. I have to look at the strategy guide or walkthrough more often than with other games. I still have not had a reply about the morphing items. I click on them and nothing happens. I do not get them in my inventory or anything. Please help!. I have stopped playing and went on to a different game because of my frustration.
I will try again later.
Anyone have any suggestions?
Vi teacher
 
 
 posted in Mystery Case Files®: Dire Grove™ on Jan 26, 11 3:54 PM
I am having problems obtaining the morphing objects. I only look at the walkthrough when I get really stuck. But even knowing where one is I cannot get it. I click on it but nothing happens.
Help please.
viteacher
 
 
 posted in Awakening: Moonfell Wood on Jan 25, 11 2:34 PM
I also enjoyed the game and want to see what happens in the land of the goblins where she flew with the griffin. Still had the cursor problem in the beginning though. Otherwise it works on my Macbook Air no other problems.
viteacher
 
 
 posted in Awakening: Moonfell Wood on Jan 25, 11 2:24 PM
The cursor that comes up when the game starts fades out and it is difficult to get to the menu to use the other cursor. The game is great otherwise. Some of the puzzles are still a challenge for me.
viteacher
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator