Posts created by sewandsew

 
 
 posted in PuppetShow: Her Cruel Collection Collector's Edition on Sep 16, 16 11:23 AM
As soon as I put the fire out my mouse went wonky and jerky and I was only able to get to the menu button after much fiddling around. Running Win7 64 bit, tried Win10 and didn't like it so went back. So there are problems with other Window versions too.
 
 
Win 7/64 Downloaded fine, first part of game was fine. As soon as I got back from getting the Ice Crystal and entered the Fire door my mouse started glitching, the screen froze momentarily and then corrected - happened many times. Finally my mouse just froze, finally freed, and I hit main menu and exited before my computer locked up. I hate doing a manual shut down, which I've had to do a few times with BFG games in the last 3-4 months. I wonder if the recent problems with games are connected to developers having to deal little software problems with different Window apps. because there are little bugs in every version that need to be worked around for programs to run correctly. Adding 10, which I detested and went back to 7, just multiplied the issues with games as far as I'm concerned. Love the games though I do understand everyone's frustration. At least if it won't open right then you didn't buy it and find problems half way through the game.
 
 
 posted in Midnight Calling: Jeronimo Collector's Edition on Jun 13, 16 12:18 PM
Finished game and bonus. Went to Secret Room and my computer totally locked. Ctrl-Alt-Del wouldn't close it, so had to shut my computer off by hand. What's up with this, using all the extra items are part of the reason I buy Collectors games.
 
 
 posted in Spirit of Revenge: Gem Fury Collector's Edition on Dec 13, 15 7:23 AM
Game crashed and froze during DEMO. No way to get out of game, C A D didn't work, had to physically shut down my PC. Windows 7 64 bit. I think I'm almost ready to quit BFG, too many problems with too many games the last year. What is going on with you guys anyway?
 
 
 posted in Spirit of Revenge: Elizabeth's Secret on Sep 21, 15 7:20 AM
I have been waiting for over a MONTH for a fix for this game. If they aren't going to fix it I want a game credit, tired of waiting. Really disappointed in BFG lately.
 
 
 posted in Nevertales: Legends Collector's Edition on Sep 13, 15 10:21 AM
Micha1234 wrote:I don't know if this is a glitch......I'm in the bonus game, trying to get the green crystal. I can't click on anything to work. no hint, no SG, no menu. All I get is more flames. Had to CAD out of the game. what gives?

Edit: went back in and tried again, same problem. Done with this.


I have the same problem, almost to the end of the game then GLITCH!
 
 
 posted in Dracula's Legacy on Aug 10, 15 9:38 AM
Got to the mansion, got the hammer and 2 nails and fixed the ladder. As soon as I entered the mansion again the hint quit working, Need something to dust away the cobweb in the window but don't have a tool to use. No place to use the ladder that I can find. Melted the silver spoon, the cheese block is sparkling but I have nothing to try and use on it. I have the hammer, crossbow and ladder in inventory. The left fork in the road by the scarecrow should be open but it won't let me go that way any more. Game also won't let me go back past the vegetable cart partially blocking the road either. Have installed and uninstalled game several times, nothing helps. Running Windows 7, 64 bit. I hope it's not a glitch and that I've just missed something.
 
 
As many different tech issues there are with trying to download and play this game I don't believe it was even Beta tested! Ran into the first problem choosing game difficulty and that wouldn't work until I didn't change the game cursor. Then the game locked and even Task Manager wouldn't run so I had to force shut down. When I opened up the game again it let me play but the mouse didn't work right . The hint button wouldn't work most of the time. The glints didn't work except on the HOPs. I can't believe I actually played it until the demo ended, except that I'm stubborn and I was really interested in this particular game.

Shame on BFG - the game glitches are getting worse each new game that comes out. You do realize that you're going to lose your buying public if you don't TEST these games before you put them up for sale??!! We're not your guinea pigs, we are loyal customers who spend our money at your site. I no longer purchase any game from you until I check the game blog to see if there are any issues first. Pretty pathetic. Although BFG is good about giving out game credits if you have problems, that doesn't make up for the problems we're all having with your games. There are other websites to purchase from, and they have good games too.
 
 
 posted in Surface: Alone in the Mist Collector's Edition on Jun 4, 15 7:59 AM
Bonus screens, saw the flowers OK, but went to see the secret room and got stuck. Ctl Alt Del didn't work so had to restart my computer manually. Yes I agree with some of the screens being grainy looking, but not all of them.
 
 
Same problem as all the others, gem puzzle frozen, can't continue game. Closed and opened game again, game saved in gem puzzle and can't do anything else now.
 
 
 posted in Phantasmat: The Endless Night Collector's Edition on Jan 12, 15 4:04 PM
silverfairy31 wrote:
marciabb wrote:
TAZZ1965 wrote:I HAVE FOUND ALL SOUVENIRS WITH THE EXCEPTION OF THE ANCHOR. EVEN IF I HIT THE HINT BUTTON IT TELLS ME I SHOULD GO SOMEWHERE ELSE. WHAT THE HECK?


I have the same problem with the green traffic light...


Me too! Can't find the green traffic light!


Me too, but the gold framed green light is stuck on the pole, so I can't play the Bonus HOP..
 
 
 posted in The Cursed Island: Mask of Baragus on Nov 10, 14 11:16 AM
Same problem with newspaper, Windows 7. Won't buy until glitch fixed.
 
 
 posted in Witch Hunters: Full Moon Ceremony on Sep 1, 14 6:58 AM
I can't get to any other screen, only the soccer game screen. Game is locked on that page, so if I am missing other items I can't get out of there. If I close the game it opens to the soccer game period, end of game for me I guess. Thanks anyway!
 
 
 posted in Witch Hunters: Full Moon Ceremony on Aug 31, 14 1:21 PM
Screen locks in boys bedroom once you finish the soccer game puzzle. You then need to attach the cord to the game controller that pops out on the left side of the screen. The bar won't let you get anything out of the tool box, Hint is locked. The only button that works is the Menu button. Am I missing something here, or is this a glitch? Thanks for any help.
 
 
 posted in Ominous Objects: Family Portrait Collector's Edition on Jul 19, 14 6:53 PM
Having same issues as bigblue64. Froze up the computer, wouldn't let do anything. Please fix the bugs!
 
 
 posted in Haunted Hotel: Ancient Bane Collector's Edition on May 29, 14 1:35 PM
Same problem as Penny1942. Hint quit working, map doesn't work any more. Running Windows 7 with 64bit OS. This is the 4th game in 3-4 mos. that quit working properly for me, what is going on with the quality control on the games? Am really surprised because I never had problems the last 4 years and have been so happy with BFG. Hope there's a fix soon, I was enjoying the game!
 
 
Yes, you do need to start from the beginning again, and with a new profile, sorry. The following worked for me (after checking everything including my mouse driver, etc.)

1. Take the nail pullers and put on the left nail of the top board. Let go of them and they will remove that nail and the right one, and then the nail puller will drop down into your inventory.

2. Get them out again and go to the left nail on the second board. Attach to the nail on the left and let go, it will automatically remove the right nail and drop down into your inventory.

3. Same on the third board, left side nail and let go of the nail puller, after the board comes loose the nail pullers will disappear.

The problem seems to be something to do with the mouse and clicking too soon before you see how that particular action will be working. While finishing the last chapter of the main game and then playing the bonus game I had mouse problems. Usually I go in Options and change the cursor to system cursor. On this and some other games I've played (and had problems with) the system cursor still shows up as the game cursor only smaller. This is not good. Next time I play a trial and it won't change to my system cursor completely I definitely won't be purchasing it!! It is a good game, but almost finishing and having to start all over is a PAIN!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator