Posts created by Dominick_Fontana

 
 
 posted in Mystery of Neuschwanstein on May 6, 15 1:57 AM
I had the same problem, too, but it appears you solved it. I'll try it as soon as I get home. Thanks.
 
 
 posted in Evil Pumpkin: The Lost Halloween on Nov 5, 14 12:00 AM
Hi, Rumbit.

I painted the torches already with the colors. Plus, if I missed a torch, it should show it as an Objective on the Map and the HInt should guide me there, but neither of them work. I'll go back and see if I missed a torch and I'll let you know what happens.

Thanks.
 
 
 posted in Blue Tear on Nov 3, 14 2:16 AM
(Part 2)

5) Maddening Mislabeling: I wasted over 1/2 hour because of this stupidity. Towards the end of the game, the only Objective on the map is in the Nanny's Room. The clown is there that you're supposed to draw a black circle around and then burn it. I clicked Hint and it said to use the Black Chalk to draw a circle around the clown, but I didn't have the black chalk. There were other things I could still do in the game, but it did not indicate it on the Map and the Hint never mentioned them. For instance, I had all the stained glass pieces so I was able to fix the window. After having to figure out where to go and what to do on my own, there was nothing left to do. I spent about 1/2 hour trying to find the Black Chalk because that's the only thing the Hint kept saying to use. I finally figured it out that you use, I believe, Black Hair to draw the black circle around the clown and then burn it; but the Hint kept saying Black Chalk.

6) Garbage Map: To add insult to injury the Map was all messed up towards the end of the game. I finally got to the Attic, but when I looked at the Map, it said I was by the Fountain. During the game, all the unexplored territories had a lock on them, except for the final room next to the Attic, which was a black box, Then when I finally got to that room, the Map shows I am someplace else and there is still a black box on the Map in the room I am in. I perform the final ritual in the room and I just have the Voodo Doll in Inventory and nothing is happening. So I figure it's a trick or something, so I go to the Map and click to move to the Fountain, where the Red X says I am. Just as I am transporting there, I can see a woman (girl) appear in the Attic as I go to the Fountain. Well there is nothing to do at the Fountain, so I go back to the stairway next to the Attic (I can't go to the Attic directly because it is still a black box on the Map) and then go to the Attic and the girl is not there; but it says Next in the upper right corner. I click it and nothing happens. I try to place the Voodo Doll in the Attic, but I am not able to. I move around and it says Next on every screen. I click Hint and it uses up the Hint but doesn't tell me anything. I quit the game and start it again and the same thing happens. I waste another 1/2 hour tyring to figure out what to do, but I can't. The bottom line is that I couldn't finish the game, there were no Objectives on the Map, and the Hint didn't work.

I rate it 3 out of 10.
 
 
 posted in Blue Tear on Nov 3, 14 2:12 AM
(Part 1)

I am not going to give my usual review with all the details because others have done that. I just want to write what the numerous problems with the game were. Before I start, in my opinion, the game is NOT more like a point- and-click adventure as someone else mentioned. The game is loaded with tons of obnoxious HOPs, so it is a HOP adventure.

The game was very sluggish at my standard 1600x800 resolution. I couldn't even use the game cursor. The game plays much better (faster) at 800x600 Resolution, but it doesn't look any better. It's unplayable at 1600x800 because the cursor and game work at a snail's pace.

Bugs in the game:

1) First Time - I played to the House part and then quit. The next time I played, the Hint said to use Mallet in cellar to knock out the taps, but I had no Mallet. So I played with a new Profile because I could have sworn I had the Mallet when I quit the game.

2) Second Time - This time there was a bug that I didn't have the first time. When you have to shoot the ball and rotate the knights to get the ball into the hole, I missed the hole and the ball went into the gutter, but never came back. So I had to skip the game. But this time I got the Mallet in a HOP and was able to use it in the cellar.

3) In the Lady of the House's Room, when I got the picture fragments to restore the picture, I restored everything, but there was no picture scrap for the Umbrella, so I had to skip the game.

4)Periodically, in the Inventory when you hover over some items, it doesn't have a label to tell you what it is.

(See Part 2)
 
 
 posted in Evil Pumpkin: The Lost Halloween on Nov 3, 14 1:55 AM
What a nightmare this game was. You'll read about it in my review, but for now, here is my problem.

I don't know what to do in the Throne Room with the 4 Elements at the end of the game. There are no objectives on the map and the hint doesn't work. I believe I am at the very end of the game, but I can't complete it. When I click in the Throne Room, there is a close-up of the 4 Elements, but I have nothing in Inventory to use on them. Did anyone else have this problem and did they find a solution?

Thanks for any help.
 
 
It seems that most people are using a Mac or iMac, but I am using a PC. I had the same problem. I install the game, but it won't start. It installs fine, but after I double-click to start the game, the screen comes up for a few seconds and then disappears and the game does not start.

I am using a PC with Windows 7 Ultimate - 32 bit and 4 GB RAM.

Thanks for advising when the problem has been fixed.
 
 
 posted in Evil Pumpkin: The Lost Halloween on Oct 31, 14 1:52 AM
Hi, Wendy.

If I remember correctly, if you select the Medium or Hard modes of Difficulty, there are no HOS. That's what it says in the description of those modes before you select them. I selected Easy and it says there are HOS. So, I believe the Medium and Hard Modes don't have HOS, which doesn't make any sense to me. Good luck!
 
 
 posted in Evil Pumpkin: The Lost Halloween on Oct 31, 14 1:49 AM
If I remember correctly, with the code on the phone box, 1 has no letters after it. ABC comes after 2, then DEF after 3, etc.

I'm not certain, but I think bankie wants to know what the code is that you need to dial and unfortunately, I don't remember. I believe the code was in the Journal.
 
 
 posted in Evil Pumpkin: The Lost Halloween on Oct 31, 14 1:42 AM
I'm sorry but this game was a nightmare, both figuratively and literally. Please start a review thread, so I can review the game. Thanks.
 
 
 posted in Fear for Sale: The 13 Keys Collector's Edition on Oct 28, 14 11:40 PM
As I posted in an earlier message, I also couldn't select the Glass Box to open it with the Box Cutter. I finally got it to work by doing the following: From the room where you have to place the Demon Sign, I went to the room on the right Then, I just started clicking on the inventory items in order. This time, the Glass Box did appear on the screen and I could open it with the Glass Cutter. I was also able to select the Locket from inventory. At that point, I was able to complete the game and the Bonus Chapter (which was very long.)

So try the above and hopefully it will work for you. Good luck, everybody.
 
 
 posted in Fear for Sale: The 13 Keys Collector's Edition on Oct 27, 14 12:51 AM
I have the same very frustrating bug that others have reported. In the very last chapter, I have the Glass Box with the Plus Sign and the Glass-Cutter. The bug is that I cannot select the Glass Box from Inventory to open it with the Glass-cutter to get the Demon Symbol. I checked the SG and that's what you are supposed to do. Plus I clicked the Hint and it pointed to the Glass Box in my Inventory. The bottom line is when you click the Glass Box in inventory, nothing happens, so you can't open it. Very frustrating because I was just about to complete the game and then I was not able to.

I also saw the glitch in the opening scene where you go in and out of the house and sometimes the girl is sitting in the taxi and sometimes she's not there, but that was no big deal.

Please let us know when you fix the Glass Box bug.

(Using Windows 7 Ultimate - 32 bit with 4 GB of RAM.)

Thanks.
 
 
 posted in Mystery Castle: The Mirror's Secret on Oct 16, 14 11:24 PM
I have a similar problem. When I tried to pick up the grate, you have to place the transistors. Every time I picked up a transistor, the game froze, hung, and then crashed. I retried it numeous times and got the same result.

Please advise when the game is updated without the bugs.

Thanks.
 
 
 posted in Dark Realm: Queen of Flames Collector's Edition on Oct 12, 14 11:04 PM
(Part 2)

(Rope Story): For me, cutting the ropes should take 2 seconds. The way they did it, it took 12-15 seconds to go through all this nonsense to pick up the item.

Next, I don't like HOGs to start with, but these were some of the worse ones I have played. Very difficult. Most scenes were dark and many items were miniscule. Also, I didn't like most of the mini-games. In one, you have to move blocks around to be able to move the block with the key to the other side with the lock. I love those types of games, but they even messed this up. First, you had to move the key from right to left. That's backwards. You should move from left to right because that's how we read and that's how our minds work. Second, you could not move the key around. You had to move all the other blocks to create a path and then the key moved by itself to the lock. I didn't like that. Even with a good game, it messed it up. There's a card game where you have to get 3 Dragons to win. Throughout the game, the opponent keeps talking and it was so annoying.

One of the biggest annoyances was the black bar at the top of the screen with messages in it. The bar was misplaced and kept blocking the Close Window Icon or the items at the top of HOGs. It was bad programming to put the black bar there and the bar was overused,

Finally, virtually every time I entered a new scene, I wanted to click on something or check the Strategy Guide, or do whatever I wanted to do. I'm the one playing the game and I should control it. Invariably, no matter where I clicked or what I tried to do, nothing would happen. That's because you had to click on a character or something else in the scene, and have a conversation or watch a cutscene before you regained control of the cursor and could do what you wanted.

The bottom line for me was that the devs were more concerned with justifying their own existence and having a ball creating all the cutscenes and animations that were fun for them, but irriating for the player. At least they were for me.

I do NOT recommend this game and I give it 2 Thumbs Down.

I rate this game a 4 out of 10.

(End of Review)
 
 
 posted in Dark Realm: Queen of Flames Collector's Edition on Oct 12, 14 11:00 PM
(Part 1)

[First, Happy Columbus Day everybody!]

I'm in the minority again and I will not give a full detailed review, as I usually do. The excellent reviews before mine have given all the details of gameplay. I will just focus on why I hated this game.

The bottom line is that I did not feel like I was playing the game. I felt as if the game was playing me. That is, I want to be in full control when I play a game; but this game was way too controlling for my tastes. The game was very slow. Even when you first start the game, it makes a big production out of showing an animation before it displays all the links. Then, when you click Play, it seems to take forever for the game to start.

Next, there was an unforgivable sin in this game. It has the nerve to have a random-click penalty in the HOPs. That's unforgivable in my book. And to add insult to injury, the game even has a Custom Difficulty mode, which I used. But when I saw there was no option to turn off the random-click penalty (RCP), I knew there would be one in the game, and I was right. This infuriated me. How on earth can you have a Custom Difficulty and not allow a person to turn of the RCP. Then, when you invoked the penalty, it had the nerve to reprimand you. "Don't click so fast. It's better if you take the time to think." How dare the developers lecture me and tell me how to play a game, when I have been playing video games since 1977 on the Atari 2600 VCS. Don't tell me how to have fun.

Next, the cutscenes were too numerous, too long, and too boring, so I wanted to Skip them. Many times, the Skip button did not work. Even when it did, it didn't skip everything. It would play the animation for about 5 seconds, before Skip appeared. Then when you click on it, it stops the main animation, but continues with the ending animation. So even though you want to Skip the cutscenes, you still have to watch about 10-12 seconds of them.

Next, the game had mini-animations for most of the things you clicked and I couldn't stand that. In one example you zoom in on an area with 3 ropes and you have to cut them. You click on your Knife and then you click on one rope and have to watch in anguish, as it cuts the rope THREE times. Then it also cuts Ropes 2 and 3, THREE times for a total of NINE cuts you have to painfully watch. Then, you pick up the object. In my book, I want to click once with the knife, have all 3 ropes cut, then click again to pick up the item.

(See Part 2)
 
 
 posted in Pirate's Solitaire 2 on Oct 8, 14 1:21 AM
(Part 2 of 2)

As you play and remove cards, you receive money and your bank is displayed at the top. At any time, you can click on the Store and buy Bonus items with your money. Also, periodically during the game, you will earn Bonus items. There are 3 Bonus items: Mulligan ($2,500), which is like an Undo and lets you take back your last move; Joker ($5,000), which lets you make any card a Joker that can be removed by any other card; and Reshuffle ($8,000), which allows you to reshuffle the deck and try again. Your primary goal is to get ALL the Special cards in each hand for a perfect score. However, you don't have to get them all and as long as you complete a hand, you can proceed to the next hand. At any time, you can go back to any hand in any level that you have completed, in order to play again. You usually do this if you didn't get all the Special cards in that hand. There is also an Options screen, with basic things like volume and cursor type, plus an Achievements screen,

I thoroughly enjoyed the Junior mode, but was disappointed with Sea Wolf mode. With that mode, you can't go back and replay any hand in a level. The first time around, it proceeds like Junior mode. However, if you continue to another hand, you CANNOT go back and replay prior hands, if you didn't get all the Special cards the first time. Whenever you go back to a level in Sea Wolf mode, all the hands are locked again, except for the 1st hand. For example, if you want to replay hand 7 in a level, you have to start with hand 1 and complete hands 1 through 6 again, to get to level 7. I did not like that. But the big thing is that I originally thought that Sea Wolf mode would have 120 different hands from Junior mode; meaning there would be 240 different hands in the entire game. Sadly, that is not the case. For some strange reason, all the levels and hands in Sea Wolf mode are exactly the same as in Junior mode. So, I don't really understand its purpose. There are the exact same 120 hands in both modes, the only difference being that with Sea Wolf, you have to replay everything to get back to a prior hand in a level. For this reason, I have lowered my rating slightly.

All in all, this was a great game and I highly recommend it. I give this game 2 thumbs up and I rate it 8.5 Stars out of 10.

(End of Review)
 
 
 posted in Pirate's Solitaire 2 on Oct 6, 14 2:51 AM
(Part 1 of 2)

I know I am in the minority here, but I thought it was a great game. I didn't think I would like it that much, but I gave it a try and I got hooked. The game is good for both adults and children.

There are 2 modes: Junior and Sea Wolf. Each mode has 12 levels and there are 10 hands in each level. I started on Junior and you have to complete all 10 hands of level 1 to advance to level 2. Then complete all 10 hands of level 2 to advance to level 3, etc. So with 12 levels and 10 hands per level, there are 120 hands for each mode.

The premise is simple. Each hand has a different layout of cards and each pile of cards is face down, except for the top card in each pile, which is face up. You also have a deck at the bottom. You click on any 2 face up cards that are the same rank, regardless of suit. So for instance, you can click on any two 3s, 7s, jacks, or aces to remove them. Then, the cards underneath the removed cards become face up. When you click on your deck, it turns over 2 cards at a time. You can remove cards from the playing field by clicking on 2 cards from the field or a card from the field and a card from your deck. You can also click on 2 matching cards from your deck to remove them, if you want to use the cards beneath them. There are Special Cards in each hand that have a silver frame. Your goal in each hand is to remove all the Special Cards. When you remove all the Special Cards in a hand, it is completed and you can proceed to the next hand.

(See Part 2)


 
 
 posted in Forgotten Kingdoms: Dream of Ruin Collector's Edition on Sep 24, 14 1:06 AM
Sorry Mod.

Hi, Tiger. Sure, I'm still around. Nice to "see" you, too.

The Mod said not to post messages here, so let's PM each other.
 
 
 posted in Forgotten Kingdoms: Dream of Ruin Collector's Edition on Sep 24, 14 12:15 AM
[Part 2]

So I would look in the Strategy Guide (SG) to determine what to do and it would show to use an item that I had already tried to use 3-4 times. I would finally place the item in the correct spot. The whole episode would take about 5 minutes, instead of 2 seconds, if the Hint did what a Hint is supposed to do. This happened throughout the game. Looking at the SG is a nuisance. With this game, I would just keep clicking on Hint after Hint to figure out what to do, which is bad enough. But at least if the Hint recharged in 5-10 seconds, it wouldn't be as bad as this game, where you have to wait a minute between Hints.

A few of the puzzle/mini-games were good, but the large majority of them were horrible. Most of them were very difficult and tedious. I tried not to Skip too many of them, but a few of them that I completed took 20-25 minutes to complete. But that's not a good thing because the puzzles weren't fun. They were very tedious, difficult, and time-consuming.

Then the Map was annoying because you can't see if you had any Objectives in the scene that you were in. I like to stay in a scene until there are no more Objectives. But with this game, I had to go to another scene, then click on the map again, and if I saw there will still Objectives in the scene I just left, I would go back to it. You should be able to see if there are Objectives on the map in the scene that you occupy. Also, the Map won't let you click on the scene you are already in to return to it. You have to look for and click on the Close icon. Plus, there was no Map in the Bonus chapter, which infuriated me.

Then, throughout the game, periodically during a scene the music and sound effects would stop and the game would be silent. Then after the big dramatic scene, the sound would return.

In summary, games are supposed to be fun. If a game is boring, that is bad enough. But this game was worse than boring. It was tedious and ridiculous and that infuriated me. I would rather be a bit bored in a game than play a game that makes me angry.

All in all, this was a horrible game and I unequivocally do not recommend it. I give this game 2 thumbs down and I rate this game a 3 out of 10.

[End of Part 2 and End of Review]
 
 
 posted in Forgotten Kingdoms: Dream of Ruin Collector's Edition on Sep 24, 14 12:13 AM
I haven't posted a review in awhile, but I had to post one about this game. Much of the criticisms have already been stated, but I wanted to put in my 2 cents. This is definitely one of the worst, if not THE worst HOG/Adventure game, I have ever played. As most people have stated, there is virtually no Help Text; yet I selected the Easy Mode, and it specifically says there is Help Text. You click on about 50 things and for the first 49 there is no text, then for the 50th, there is a little Help Text. What made it so bad was that the game is very abstract. If you click on a drawer with a lock, all the other games will say you need a key. However, even without help text, you can figure that out. But with this game, you didn't have simple things like that. You would have to put a strand of dragon hair into a crack in a stone wall. You click and there are gears, but it doesn't say anything. Now, how on earth would I know to put a strand of dragon hair into a crack in the wall? The majority of the game was like that. Also, as others stated, in every scene you click and a magnifying glass or gears appear, but there is nothing to do there.

Next, the HOPs were a nightmare! Miniscule items that you can't see. Then, even though I played on Easy Mode, the Hint took a minute to recharge. Unacceptable. Many of the games today have a Custom Difficulty and I always set the Hint and Skip buttons to 5 or 10 seconds to recharge. This game needed the Hint button and it was a living hell on earth to click a Hint and then have to wait a minute to use it again. Plus, when you click Hint, the game is supposed to circle the Inventory item you need to use and draw a line to the area you need to use it on. So it takes about 2 seconds to use the Inventory item in the scene. This game, almost all the time, just circled the area in the scene, but doesn't tell you which inventory item to use there and it uses up the Hint. Then when you zoom in on the area you have to try to figure out which item to use there. For most of the game, I had to keep on clicking on every inventory item to see if it would work in the scene, and it usually wouldn't. Then I would click on one of the 4 powers (Fire, Water, Earth, Air) to see if they worked. Then, when the Hint recharged, it would have the nerve to just point to an area in the scene, but it still wouldn't tell you what inventory item to use there. It turns out that it was very, very particular where you placed the item.

[End of Part 1]
 
 
 posted in Shrouded Tales: The Spellbound Land Collector's Edition on Sep 18, 14 10:11 PM
A small point, but at one point in the game, they used the wrong word. With a mortar and pestle, the mortar is the bowl and the pestle is the stirring item. In the game they refer to the bowl as a pestle, but it's not a pestle, it's a mortar.

And that's it. haha
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator