Posts created by Jurinne

 posted in Banana Bugs on Aug 24, 17 11:33 AM
I have played the same level three times. Each time I get 100% coverage and nothing happens. I don't get any points, I don't get any bananas. The game just sits there. The screen is not frozen but I can't advance.

Other times the pea shooters have not shot anything. Sometimes I have four pea shooters and only one or two bugs get shot.

And, most of the time I have to double click to do anything. On three separate computers.

I love this game. But to have to start over AGAIN is unacceptable. I understand that games have glitches. But this one is riddled with them.
 posted in Maze: Nightmare Realm Collector's Edition on Aug 14, 17 11:47 AM
I'm not happy at all with this game, for two reasons:

1. One of my pet peeves is when I get the "Hmm, what can I do here?" (or something similar) almost every time I click on something. Frankly, it makes me want to break my PC with a baseball bat.

2. When I want a hint, I want a hint. Not pointing to the same place or object over and over and over. That's not a hint. That's just obnoxious.

I like the darker games and I seek them out, not that this one's very dark. But I'm just not sold on it.

Disappointed here.

 posted in Mystery Case Files: The Black Veil on Jul 26, 17 7:19 PM
What an annoying game. Very poor graphics, which is strike one. Strike two is when I set the skip at 10 seconds and it didn't work. Strike three is all the questions I am asked when I want to do anything. Are you sure you want to do this? YES!! I AM SURE!! That's why I clicked on it!!

It's a no-buy for me.

No puzzle reset, no buy.

The end.
 posted in Jewel Match Royale Collector's Edition on Dec 1, 16 7:47 PM
I played this game with no problem on my old computer with Windows 7. I just got a new computer with Windows 10 and the music is all jumbled together and it's gotten to the point where I can't stand it and have to mute it.

The game also freezes for four or so seconds every once in awhile. I don't mind that so much. But I do mind the music problem.
 posted in Jewel Match Royale Collector's Edition on Nov 27, 16 8:04 AM
SynthpopAddict wrote:
Jurinne wrote:
What I can't figure out is what I'm supposed to do with an extra life. I clicked on it in the store and I guess I bought it but I have no idea what it's for.

If you're playing in relaxed there is no need for extra lives, but in the other modes you can trade a life for more time or moves.

Ah. That makes sense. I am playing in relaxed mode.

 posted in Jewel Match Royale Collector's Edition on Nov 26, 16 11:35 PM
Re the butterfly: It drove me crazy for awhile. Just look to see where it goes and you will find a pattern. You have to make matches right up against it and it will turn in the direction of the match. Only one space. You don't have to take it down to the bottom of the board; any edge will do. It was hard for me at first but now I'm managing to capture it in every garden level.

What I can't figure out is what I'm supposed to do with an extra life. I clicked on it in the store and I guess I bought it but I have no idea what it's for.
 posted in Jewel Match Royale Collector's Edition on Nov 26, 16 6:38 PM
I love Jewel Match games. I had just finished the Halloween game when I saw this one and bought it without a trial. I'm up to level 29 and it's perfect, just like the other ones.

There are usually three boards to each level and they are interactive, so this is a very long game.

The scenes are beautiful and the music is even better. This is a very high quality game and I couldn't be happier with it.

Even the screen savers are beautiful!

 posted in Dark Romance: The Swan Sonata on Nov 13, 16 9:51 AM
This looks like a beautiful game but the skip button doesn't work.

 posted in Bubble Shooter Adventures on Nov 2, 16 8:45 PM
mimi42 wrote:Help! I can't find an "EXIT" button to get out of this game. I wanted to exit and delete it, but now it's got my game manager unable to do anything else because the game is still running.

I'm running windows 8.1.

Click on your Esc button and you can get out that way.
The game froze eight seconds into play and I had to reboot. It worked fine for quite awhile after that. But now I'm in the laboratory and the Hint button does not work there. It works if I leave the laboratory but not in the laboratory. Of course I need a hint in the laboratory.


OK, this is bad. I can't get the hook because I can't access the scene. Without the hook, I can't progress. Do I have to start over again, when I'm so close to the end?? No hints and no hook. I am STUCK.

On Windows 7 on a PC.

"Cannot connect rope to hook. Cannot find hook. Hint does not work in scene. This is the third problem I have had with glitches in games in a month. Playing on a Mac 10.9.5."

Same problem!!
 posted in Mortimer Beckett and the Secrets of Spooky Manor on Jun 12, 16 5:17 PM
Lynne0305 wrote:Ah solved it! The Indian room was a different room to the one I thought and have now got the battery therefore can access the machine room. Not very clear but kept the old brain cells working. Please ignore previous post. Game now completed.

I am lost. Could you please tell me how to access the Indian Room?

Oh, geez. I found it. Now I feel so stupid!!

Just want to add that I really love this game and I'm going to get the others.
This is NOT MCF. I was so afraid of this. I'm going to end my years-long membership over this. I was pretty sure this was coming after the same dev took control of Dark Parables, ruining my favorite series. It appears they are gaining a monopoly.

The graphics are very poor compared to the earlier MCFs. The gameplay is typical from this dev - need something, find something, move on. It's like a funhouse maze I was suckered into once at a county fair. You couldn't go wrong because there was just one path. I felt ripped off.

This is supposed to be the cream of the crop, the absolute best. Compare it to Madame Fate. Well, there is no comparison.

Some of the puzzles are so easy they made me cringe.

I didn't finish Key to Ravenhearst because it was just so annoying. I doubt I will buy this game.
 posted in Beyond: Light Advent Collector's Edition on Aug 23, 15 7:14 PM
Pwoot wrote:I had the same problem, but finally saw it laying down and to the left of the chest, between the flowers, pretty hard to see.

Thank you! That was driving me crazy. My vision isn't that good and I couldn't find it and I was good and stuck.
 posted in Beyond: Light Advent Collector's Edition on Aug 15, 15 9:00 PM
I like this game although there are things about it I hate. The thing I hate the most is that sometimes the hints repeatedly tell me I need to do something that I already know I need to do but I can't find the item I need to do it. I already know I need to open the chest. Where's the KEY?? My vision is not that good anymore!

Also, the wallpapers don't work.

I haven't completed the game because I got disgusted with not being able to find the key to open the chest and decided to quit for awhile.

The graphics are excellent, story line is excellent, mini games are excellent.

Well, maybe I'll finally give up and check the guide to see if it will tell me where that pesky key is hiding.

Happy gaming!
 posted in Beyond: Light Advent Collector's Edition on Aug 14, 15 11:02 AM
I can't get the wallpaper to work. I've never had problems with any other game. I realize this is a minor problem compared to the major problems I have seen here.
I didn't disable the special effects, I shut the game down, and went back. And now I'm not having any problems at all. No screen freezing, no lag, nothing.

I'm using Windows 7.
Black screen that just sits there? I bought this game without trying it first as I love all the others. The black screen was there so long before anything showed up that I had my finger on the button to shut down my computer and reboot. Then it got stuck on the first loading and I did have to reboot. I haven't even been able to play the game yet.

I'm supposed to delete special effects? Why? I paid full price for this game!


I'm using Windows 7 so this is not only a Windows 10 problem.
 posted in Maze: Subject 360 Collector's Edition on Aug 2, 15 7:15 PM
I played the demo, liked it, and bought it. It's been stuck at 100% installation for half an hour. No error message, just STUCK.

PLEASE FIX THIS!! I submitted an email and I wonder if I'll even get a response.

I wanted to play this game tonight. I feel sick.

Playing on a PC, Windows 7, that's all I know as it's been a long time since I've had any problems with games.

Edit: I closed the GM and reopened it. Now it's stuck at 0% installation with no error message.

Edit: This game installed at least three times and finally activated when I shut down every other window. I have no idea what's going on but it seems to be working now.
 posted in Phantasmat: The Dread of Oakville Collector's Edition on Jul 25, 15 5:21 PM
What did I just play? It was nothing like the first Phantasmat, which is one of my all-time favorite games. This games is nothing but a big MESS. What was all that stuff at the end? I didn't even know what I was supposed to do.

And, as has become the norm, we go around and pick up items which we will mostly use almost right away. Find an item, pick it up, deposit it somewhere else.

The storyline is confusing at best. There is a noticeable lag all through the game.

I spent most of my time saying, "Huh??"

I am not happy.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator