Posts created by MomEdie

 
 
 posted in Hidden Expedition: Amazon ™ on Oct 11, 12 3:27 PM
Look back at the other map scenes; silhouettes of those figures will be found somewhere in prior scenes, near a blank box. When you click on the figure, the box will automatically click through a series of geometric figures. To play the game go back and forth scrolling through the box figures to match the 'right' one in the game circle; when you have the right one, that piece of the pie will turn gold. When all pieces of the pie are gold, if nothing happens by itself just keep clicking the hint button; the pie will spread open and you can continue.
SPOILER: all the right box choices are triangles, matching the piece of the pie that critter is in;.keep the configuration of the triangle matching the shape of the piece of the pie, with all triangles pointing to the center of the pie circle. For example, the firefly is at the top center; its triangle is straight across the top, pointing down; the bird, next right, has a straight bottom triangle with a diagonal side going up from lower left to upper right, etc.
 
 
 posted in Grim Tales: The Bride on Jan 9, 12 6:34 AM
For those of you who get irritated with all the 'back and forth' scenes when a map isn't provided, especially if you are frequently interrupted in game play as I am and lose track of your travel routes, here's how I keep my cool. I use scrap paper (backs of junk mail envelopes are good recycling candidates) and as I progress from place to place, I quickly chart them in simple shorthand. For example, you might write "Courtyard" with an arrow down to "front door," an arrow left to "back yard," an arrow right to "garage," and similar arrows at each of those locations that lead to somewhere else. Then when you need to go to say, "master bedroom" or "library" you just have to check your arrows from your current location to find the shortest route.

Another hint: I also keep a quick list of what leftover chores need to be taken care of in which location, so later when I find that "handle" or "shovel" or whatever in my inventory I know right where to go to use it. Something simple like "back yard - up/tree/L" reminds me that I need to get up into a tree on the left side of the back yard scene, and that ladder I just found might work; then, when I've completed that job I cross it off. I'm sure we all have our own little ploys and don't intend to offend anyone with this, -- I just thought it might ease the way for some beginner to enjoy these games.
 
 
 posted in Elementals: The Magic Key on Jan 8, 12 5:02 PM
You guys have GOT to be kidding!!
How can anyone over the age of thirteen enjoy such idiocy?
The battle game is just plain dumb, the 'magic spell' tracing game is well-suited to a kindergartener, and the rest of the play is boring, flashing-light irritating, nonsensical story line, etc., etc. etc..............There should be a rating system, maybe; this one would fit in 'Non-Adult, admit under juvenile guidance only,'
OK, I'll stop. To each his own, but be forewarned!

ADDED LATER -- My apologies to the 'older' responder who was apparently offended by my comments; they were not meant as a criticism of players, more as a criticism of the genre. In point of fact, I'll go on record: I am now an octogenarian with my first computer in my mid-60s. So my reaction to the game was certainly not ageist, and we are all entitled to share our opinion (even when you don't agree with me, lol).
 
 
 posted in Mystery of the Earl on Jan 3, 12 3:20 PM
Usually I'm reluctant to 'pan' a game because I realize someone must have put a lot of thought and effort into creating it, and it seems mean to run their work down. But don't consider this one even at a bargain price, it's just not worth your time. Although it was a delight to finally find one that was not totally weird, dark, and spooky, it was too slow loading (and you do have to navigate between locations), the curser actually couldn't be positioned to pick up one of the inventory items no matter what I tried, and when I wanted to exit for a break the only way I could get out was with the Windows control/alternate/delete feature. Forget it, there are too many enjoyable games available to bother with a frustrating time-waster that's a struggle to play.
 
 
Despite the 'likes' incredibly posted by other reviewers, I must say this is a big fat NO BUY -- in one word, irritating. Irritating voice-over (ugh! cringe!), irritating fairy flitting around, irritating light flashes, irritating run-around, irritatingly easy games and all-too-obvious **** scenes, just not worth the money. Unless all you want from a game is time killing length, skip this one.
 
 
Of all the free trial games I've previewed in the past few months, there is no question that this has to be about the worst. Can't even see the items to look for (never mind finding them: tiny/dark/hiding), dialogue is a pitiful translation, navigation has discouraging problems, etc. Not worth the trial. I enjoy a certain amount of challenge, but this one is pure frustration.
 
 
 posted in Lost City of Z: Special Edition on Mar 16, 11 12:47 PM
It's true, as other have said, that the vines need to be cleared away from the helicopter cockpit before you can get to those items. But don't try cutting the vines by clicking the machete accross them, it may not work; it seems you have to touch them with the TIP of the pointer. [The same thing is true when you try to apply antidote to snake bites later in the game; touch the bites with the TIP of the swab pointer -- and try doing only one bite at a time.] This game has a super-sensitive pointer that will ignore anything not exactly on target.
 
 
 posted in Jewel Quest: The Sleepless Star on Mar 6, 11 9:27 AM
Right: yes, it is board 4 that was giving me so much trouble (can't blame an old Math teacher for messing up numbers, can you???) -- I'd tried it at least 2 dozen times and was not at all happy. So THANK YOU, THANK YOU for the strategy hint, which of course worked just fine. I suppose I had some kind of mental block, even though I'd tried various strategies. I really do appreciate your kind help!!
[/i]And thank you BFG for this forum, too.........
 
 
 posted in Jewel Quest: The Sleepless Star on Mar 5, 11 5:53 AM
Ch 5, board 6 is a square board with a few empty 'dead' spaces at top and bottom. The challenge is 4 teal-colored gobblers that rise from the bottom; when they reach the top, the game is forfeited. There are grey tiles descending; matching 3 gives you a 'special' to disarm the gobblers; by disarming the gobbler, it falls back to the bottom to rise again. The real problems are: slow response to match-3s because none can be made until the board is finished dropping new tiles, those dead columns across which no matches can be made, the luck (or lack of it) in falling grey tiles, and no way to bypass that particular board. How much better it would be if there were a 'detour' by playing those side games along the path, perhaps adding more time and effort but skipping the worst (somewhat like the optional 'SKIP' button in many HOG puzzle scenes). Congratulations on completing this dreadful game board. Any words of wisdom you can give would be most welcome! I play these games for entertainment and relaxation, not for excessive stress, thank you.
 
 
 posted in Jewel Quest: The Sleepless Star on Mar 4, 11 4:03 PM
The fishies that think this game is too easy and boring must not have gone beyond the first, possibly second, chapter. The games definitely get harder as you continue. In Chapter 5, the 6th game has me absolutely stumped; I wonder if it is even possible to do. Has anyone completed it, have words of advice, so I keep trying (or simply give up and junk it)? I do like the story, graphics, etc., and I'd much prefer to go on but even in the untimed mode that 6th board in Ch 5 is ridiculous!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator