Posts created by KariRocksTheBay

 
 
 posted in The Revenge on Mar 26, 11 9:44 PM
I don't even know where to start with this game. I have to say it is without a doubt THE WORST GAME I'VE EVER PLAYED!!!! Let's forget for a moment the horrible grammar. Every other hidden object scene I had to completely exit the game and then play it again to allow me to pick up items that I NEEDED to progress. For example, The Soul of Trees level required me to pick up x amount of chains. I get to the final chain and it will NOT let me pick it up. So I exit the game, start it up again and then I was able to pick it up. Then, it was like the 4th or 5th **** scene and it did it again with Snakes. Ugh!!! So I exited and then re-entered and was able to move forward. So then it happens again the very next **** scene I played and, well....are we seeing a pattern here??? Ok so aside from that annoying and I'm quite sure unintentional obstacle, lets talk about that grammar. Earlier posts talked about calling a basic foot stool a "goutstool", which most have explained away by saying that the developers were possibly just using the "language of the time". Ok, let's give them that one, but then one item list had me looking for "dices" to find one die. Even if I was supposed to find 2 die, you still wouldn't call the pair "dices". The absolute worst had to be when I get to the second item on the list which was "actubus". Well alright, no clue what that is so I proceed to find the other items on the list intending to use the hint button for this "actubus". Next clue was "eight". Having not seen one immediately, I do however see an octopus. So I click on it...guess what gets crossed off of my list? You guessed it..."actubus". REALLY????? Bottom line, I wouldn't buy this game ever. Or anything else by these developers. I do, however, recommend applying to be a beta tester as it's quite obvious they are shorthanded.
 
 
 posted in The Revenge on Mar 26, 11 9:05 PM
Where do I begin? Ran into my first issue with the game playing the Tree of Souls portion of the game. I posted that earlier. The issue was that no matter what I did, I was unable to pick up the final chain and progress. Well after I posted that issue, I tried the game again and this time I was able to pick it up and complete the task. So far, so good right? Wrong, while playing a scene in the next segment, the same thing happened. I needed to find an eight and snakes. Both of which I found very easily but like the chain before them, I could NOT pick them up. So I came here to post THAT issue. I suspect that when I try to play again after exiting the game, I'll be able to pick those items up and move on. This game is by far, the glitchiest game I've ever played. Oh and I've noticed a LOT of posts regarding the grammar or more specifically the absence of it. People have taken issue with the goutstool and other's. While others explained it away attributing the "language of the time", I REALLY have to take issue with not so much the names of the items but the description. For example, in one scene I was supposed to be looking for a die...the singular term for dice. The item list instructed me to find "dices". The most recent screw-up and my vote getter for worst friggen description ever was "actubus"....any guesses as to what that actually turned out to be? Octopus! REALLY????? I don't know who is responsible for this, but they should STOP!!
 
 
 posted in The Revenge on Mar 26, 11 7:47 PM
DIKIDI wrote:Huge problem when I got to the "Soul Tree". In two successive **** scenes there was one object that absolutely could not be picked up. In the first (the Owl Gate) it was a feather. Even though I clicked on every pixel of the feather it just would not release, but I was able to move on and solve the puzzle anyway. However in the "Second Gate", one piece of the chain could not be picked up and you absolutely cannot move on until it is. Boooooooo!
The EXACT same thing happened to me. Exactly the way you've described. In fact, it's what brought me to this forum. You absolutely cannot move on if you can't pick up the chain and it WILL NOT allow you to. I've tried exiting the game and then going back in and the same thing is happening so I don't know where the hell to go from here.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator