Posts created by nelliebj

 
 
 posted in Murder, She Wrote on Jan 13, 17 3:00 PM
So, I buy what I think is going to be a good game but can't get out of Book 3 because of a missing footprint How many times do you have to do the same puzzle (I did it 3 times and then just waited for the skip button) and when you click on the ONLY footprint on the page, it takes you back to the same puzzle. Again, and again, and again. So, you can't proceed any further. So, Big Fish, you owe me for a game that doesn't work. I'm complaining.
 
 
 posted in Cursed House 3 on May 24, 16 2:01 PM
I love it. I think it's better than the second and certainly better than the first. I only played about 10 minutes of the demo and bought it. Yes, it's a little confusing at first but once you figure out the strategy, it works well. Try reading the instructions (LOL... isn't that usually the last thing you do?) before you start and it'll become clear what is expected.
 
 
 posted in Jewel Match: Twilight on Oct 28, 15 1:31 PM
Love it!! After the Jewel Match problems I had with JM IV, this is great. I love this series. Clear graphics, music is ok (but I have the option to turn it off). Timed or untimed. Moving boards which I think is great. Building pieces to buy and make a new landscape. Lots of little extras and power-ups. Played it for 10 minutes and bought it. Thanks BFG!!
 
 
 posted in Avalon Legends Solitaire 2 on May 8, 15 10:49 AM
You're not alone.... I must be a bit dense too. I could not exit the game without using Ctl. Alt. Del. I'll go try again.

 
 
 posted in Legend of Egypt: Jewels of the Gods on Apr 29, 15 2:28 PM
I think I finished a whole 10 minutes of the demo and thought... come on BFG... this is a dud game. It was really slow, I clicked on one match about 4 times before it finally went and it was tedious and boring. I like building things during an M3 but not in this one. Oh, and untimed (relaxed) still told me how much time I had left. That's not exactly untimed!!

Trashed it after the 10 minutes.

 
 
 posted in 100% Hidden Objects on Apr 19, 15 4:05 PM
May have made a mistake buying this. I thought it was just straight HOG but it's not. It's "untimed" except for the timers!! You don't need to do anything? Yes you do. You can't move on to the next level if you don't reach certain "achievements" in the previous level so you end up playing the same scenes over and over until you get those achievements. My old eyes can't always see the items easily and then being told you have 5 seconds to find a specific (small) item, just doesn't work for me. I have yet to reach the "expert" level.

If you are going to offer a straight HOG, then don't put all those burdens on the player to make them achieve certain things to move on! I hate that. It's worse than a timer. And, the timer on this one.... well, you'd better be able to see the items and get them all within that so called untimed time or you can't move on. Not fair!!!

I'm sorry I bought this even on a DD.

 
 
 posted in Hello Venice 2: New York Adventure on Mar 28, 15 1:10 PM
I bought this game after playing it for the demo hour. At that point, it seemed like a pretty good game and a lot like the 4 Elements games. Boy, was I wrong.

I just trashed this game on my BFG site. It is the most frustrating, slow and badly developed M3 I've ever run into. I have played only the first 25 levels. It took a long time to get through level 24 because the board had moved and I couldn't see the bottom of the board where I actually needed to be in order to continue. There was no way I could get the board to move down. Finally, I did it and moved on to level 25. There the frustration got to the point where I just said forget it, I'm taking this off my computer. Again, I was in a section which is just a "corridor" but the board didn't move down far enough for me to see if there was anything I could move. So I went into another section that I could see but it wouldn't move!! In the end, the only way I could complete that level was to restart it. The whole thing is bad enough without having to restart a level because you can't see the board!!

I honestly think BFG should go back to the developer and get them to make the necessary changes to make this a good game. Too many bugs in it for anyone to enjoy.

Don't buy this game. It's garbage.

 
 
 posted in Hello Venice 2: New York Adventure on Mar 26, 15 1:16 PM
OK.... got it. Still wish I hadn't bought the game.

Apparently, I was supposed to find the path a little further over to the left but in order to do so, had to be at the bottom of the board which wasn't visible!!!!!!!! And there is no way to get a hint or some help or manually move the board. I ended up having to play the same board about 6 times before I finally got it. There is a plant at the bottom, left that you have to water and it opens the way.

As in the Jewel Match games, I think you should be able to move the board manually so you can see more of it.

Rant over.
 
 
 posted in Hello Venice 2: New York Adventure on Mar 25, 15 4:12 PM
I'm stuck. There are cement blocks in the way and the whirly things that break them are on the other side. I can't get the water past the cement blocks and there is no way to break them.

This is a really slow, really dumb game and I am so sorry I bought it.
 
 
 posted in Jewel Match IV on Mar 25, 15 3:23 PM
You would think that with all the technical problems with this game that BFG would have done something by now; at least contacted the developer to say... we have a problem! I have tried everything to get past the crystal room but it is impossible. I have replayed the level time and again. I have completely trashed the game, reloaded it and it still stops exactly there.

Please, BFG.... Jewel Match games are terrific but this one has some big problems that need fixing. I hate that I paid for this game and can't play it out to the end. It's not just me.... we're all having problems.

BFG... please get this fixed or have a recall on the game. Such a waste of money.
 
 
 posted in Jewel Match IV on Mar 17, 15 3:37 PM
I can't get out of the crystal room. I need keys to complete the m3 levels but I have no keys, I need one more rope and can't get at that because I have no more keys and no more levels that I can play. I have tried restarting the level to no avail. I simply can't complete this level..... what a frustration!!!!!
 
 
 posted in Strike Solitaire 2: Seaside Season on Mar 6, 15 8:07 AM
Why does Level 10 in each game not register??? I have played the same game about 10 times, gotten 8 strikes and it still shows that I didn't play that level. Ridiculous!! It's hard to get off a level without the required number of points and that makes it impossible to achieve. I can't even get off Junior level because of it.

Big Fish.... Please help with this.

 
 
 posted in Jewel Match: Snowscapes on Feb 14, 15 3:21 PM
I have been playing this since New Year`s. Still going.... I only play one or two levels a day and each takes some time. I love this game. By the time I`m finished, it`ll be next Christmas! Love that it has 100 levels. Buying the items for the snow scapes is by the way.... it`s playing multiple boards in a single level and finding the necessary keys and amulets to keep going.

Thank you developers. You`ve done it again!! An awesome game.
 
 
 posted in Imperial Island 2: The Search for New Land on Oct 26, 14 10:49 AM
OK... you can replay levels but it seems only while the game is still in progress. If you finish the game, you can't replay the levels. Does not make any sense at all and hopefully, the developers will fix that.

 
 
 posted in Imperial Island 2: The Search for New Land on Oct 25, 14 1:46 PM
PLEASE.... fix the replay! I finished all 100 levels but can't replay the levels I didn't as well on.
 
 
 posted in Manor Memoirs Collector's Edition on Sep 17, 14 2:39 PM
Add me to the list of those that get the blanks beside the name of the character. No idea what I'm supposed to be looking for and I have to use a hint at the end (and lose points, of course). Not fair!!
 
 
 posted in Mystika 2: The Sanctuary on May 25, 14 3:41 PM
Level 40....I had to restart twice. It said I had no moves left and yet I could see at least 4 but, I had to start it again. Not nice.
 
 
 posted in Tales of the Orient: The Rising Sun on May 10, 14 3:22 PM
Game froze at level 44. Lost the whole level. Bummer. This was the first time it froze. I had a bit of a problem earlier but somehow it started going again after I did a "Ctl.Alt.Del" for my taskmaster. Then I just went back in and it worked again. Not this time. Lost the whole thing.

 
 
 posted in Tales of the Orient: The Rising Sun on Apr 19, 14 5:52 PM
I really like the game. I think it's because there are different ways of playing (chain, swap or group) and you can rotate the board. That and build a town. Love doing that though it is pretty mindless. I have had a couple of little tech problems...freezing board and not clearing items even if there are three together but it's not a biggie.

I bought the game after playing about 30 minutes of the demo because it's a fun game that doesn't require a lot of concentration on my part. You can play timed or untimed, which I love.

 
 
 posted in Tales of the Orient: The Rising Sun on Apr 19, 14 5:48 PM
The game is frozen at Level 50. I tried everything to restore it to no avail. Lost that level and a load of moves. I had to go out of the game completely and then back into it but I lost level 50 and I was about 2 moves from finishing it. Bummer. I'm back in now. The other thing was that I often had 3 objects together but it wouldn't clear them until I rotated the board. No reason I could see or think of, it just wouldn't clear them.

Just a couple of things that need tweaking by the developers. Otherwise, great game.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator