Posts created by gagirl45

 
 
 posted in Treasure Island: The Golden Bug on Sep 4, 13 8:16 AM
how do I draw the bug and what do I draw it with or why can't I skip it
 
 
Definetly GAME OF THE YEAR!!! Many thanks to Artifex Mundi! Can't wait for the sequel.
 
 
 posted in The Secret of Hildegards on May 2, 11 4:04 PM
played demo, kinda liked puzzles. bought the game got inside house.I've played one side of upstairs and cannot leave this area. No arrows, nothing else to do.. I really don't want to start over, any suggestion s?
 
 
 posted in The Treasures of Mystery Island: The Ghost Ship on Apr 2, 11 10:58 AM
bfgArnoStyx wrote:Hello folks,

Just wanted to let you know that we're working on getting that link to the walkthrough fixed. We will be posting an announcement in the Game Forum as soon as it's available. Thank you for your patience!

-bfgArnoStyx
My patience is wearing mighty thin. Seems like every 2nd or 3rd game has some problem
 
 
 posted in The Treasures of Mystery Island: The Ghost Ship on Apr 2, 11 10:56 AM
hannah57 wrote:THE HINT BUTTON IS JUST AS GOOD AS A WALKTHROUGH, YOU JUST HAVE TO WAIT FOR IT TO RELOAD.
not if hint is not working
 
 
 posted in The Treasures of Mystery Island: The Ghost Ship on Apr 2, 11 6:36 AM
help! I tried to find the walkthrough. No luck, sent me in circles.
 
 
 posted in Once Upon a Farm on Jan 2, 11 11:50 AM
how do I light this lantern and get to the side of the house?
 
 
 posted in Atlantis: Mysteries of Ancient Inventors on Nov 2, 10 9:53 AM
I am supposed to do something with the sunglasses in the snow!!!!!! What????
Could someone please help.
 
 
 posted in Escape from Frankenstein's Castle on Sep 21, 10 7:31 PM
walkthrough says click on gear to release. I've tried clicking all over and nothing happens
 
 
 posted in Victorian Mysteries: Woman in White on Sep 17, 10 10:22 AM
When BF says "Tomorrow's Game Today" , that means that maybe by tomorrow you'll be able to play this game.
ok, so if I can't get back to the lake, where do I go from here?
 
 
 posted in Victorian Mysteries: Woman in White on Sep 17, 10 9:01 AM
Great game!!!,,,, if I could play. I played the demo, no problems. I was at the chest I had fished out of water when demo ended. I thought finally a game with no problems, so I purchased the game. When I opened game again could not get back to finish gazebo section. Very frustrating. This is getting to be a habit with BF games. I have been a member for several years and have spen t a lot of money with BF, but I am seriously considering cancelling my membership.
 
 
 posted in Immortal Lovers on Jul 24, 10 7:16 AM
The creators of these games really should provide a magnifying glass. The hidden objects in the last few HOG are nearly impossible to find. If I didn't already have bifocals, this would surely cause me to need them.
 
 
How do I get the cylinder to stay in the music box? It keeps going back to inventory
 
 
I have the same problem and have not been able to get an answer.
 
 
I have tried everywhere and it will not go in. Help
 
 
 posted in The Sultan's Labyrinth: A Royal Sacrifice on Jan 26, 10 7:58 PM
I have played to this point with no problems, cannot access anything on the 9th realm. I have uninstalled and downloaded again with the same problem.
 
 
 posted in Between the Worlds on Apr 7, 09 10:07 AM
I also had the problem with the game not saving on exit. If you go to the map and exit thru it ,, it will save.
 
 
 posted in The Serpent of Isis ™ on Mar 25, 09 7:08 PM
I have found all the items and have the numbers but when i click on the safe, it just says that the tickets are in the safe. please help
 
 
 posted in Adventure Chronicles: The Search for Lost Treasure on Dec 23, 08 1:39 PM
I am having the same problem with all my Big Fish games. HELP!!!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator