Posts created by myeeyore59

 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Nov 25, 14 12:54 PM
Figured it out!
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Nov 25, 14 11:16 AM
I am in the 6th Chapter. There is a swirly sign that is supposed to be on the proper book to choose. I've scrolled down to the lower portion of the bookcase and I can see the Book I need with the swirly sign on it. It is "The Book of Passage." When I click on it, I get only the message, "I'm not sure which book I should take." How do I get the correct book?
 
 
I'm in the grotto working on the super-puzzle. I just placed 3 pieces of picture into the top left corner. Then I am supposed to align 6 gold knobs so another picture of a man appears. Then I'm supposed to click on a button between the partial picture and the gold knobs. I am following the strategy guide in the CE and have rearranged the gold knobs numerous times then pushed the button. Nothing happens. What am I missing? Help!
 
 
Never mind. Luckily I figured it out. And the fun continues!
 
 
Yes, the game is very long and difficult. I cannot imagine trying to do it without a walk through, But, I love these games and I feel that I've gotten my money's worth each time I play. Big Fish, keep the long, hard ones coming.because I am a Master Detective nut!!!
 
 
I am nearly done with the game. I'm working on the large puzzle in the middle. The one with the book. I am supposed to move the raven's head from the middle down to the lower left corner. But there is no raven head to move. What am I doing wrong?
 
 
 posted in Living Legends: Ice Rose on Apr 6, 14 7:25 AM
I played both Living Legends games. I too, had no voice-overs in Living Legends: Ice Rose. Living Legends: Frozen Beauty did have voice-overs. I just thought that Ice Rose was made prior to Frozen Beauty. I've found this sort of thing in other collections. If not, then there was something wrong with my Living Legends: Ice Rose too.
 
 
 posted in Otherworld: Omens of Summer on Mar 4, 14 4:58 PM
I am in the chapter titled "Swamp of Secrets."i just finished the HOP in the trunk of the car. I received the spare tire. Now I'm supposed to change the front tire and apparently I should have a "Jack". I don't have one. Where did I miss it? Could someone help me please?
 
 
Responding to SeverineSnape, I tried what you suggested, moving both parts of the arm with the present, but I also had to move the upper arm of the of the other arm and it went right in. Thank you so much!
 
 
Thanks for your help. It is working perfectly now and I've completed the Juke Box.
 
 
I am at the Juke Box where you put 3 records together. Then you are supposed to click on any one of the 3 records to get a scene behind the curtain. And next, you group all country, jazz, and classic room items together. I have clicked on all 3 different records and the red curtain does not open. What am I missing? I know that there has to be something simple that I have missed. Help!!!!!
 
 
Thanks so much for your help. I had to reset it a couple of times but then it worked. Ganonsbane, you're my hero!
 
 
I have been doing the puzzle on the automaton's body. There is a section near the end of the puzzle, where the strategy guide says to click on the tools icon to bring out the human body to "arrange the circles on the human figure completely." Earlier in the game the tools icon was located on the group of 3 pictures, which include a picture of a map and one of some colored runes. I cannot find the tools icon to bring out the body and I can't progress until I do. I even hit the "reset button" to see if there was a change, there was not! HELP
 
 
I just did it so I fixed my own question. Once I figured it out it was real easy. However thanks to "ganonsbane" for your help. I appreciate your rapid answer to my dilemma.
 
 
In Chapter 4, Outside Trailer there are 3 batteries that are supposed to be changed from + + - to - + -. I need to know how to change one of the + batteries to a - battery. It just needs to be turned upside down to make the change but no matter what I do I always come up with 2 + , and 1 - battery. I'm stuck here. I need to turn the flashlight on but it is impossible to get 2 negative batteries. HELP!!!!!

So far I'm really enjoying the game, however I'm using the strategy guide a lot. I really enjoy all of the MCF games except the last one, Shadow Lake. The subject matter was too dark for me.
 
 
 posted in Otherworld: Omens of Summer on Apr 4, 13 6:12 PM
At about mid-point through the game, following the walk through, I have come to a point where I am directed to plant a 2nd magic seed. I dug into the dirt with the spade, planted the seed. Then I am supposed to pour a dish of water over the seedling, climb the beanstalk, and play a mini game. However, when I put the magic seed into the dirt, it immediately grew into the beanstalk, leaving no time to water the seedling. The beanstalk doesn't go up, but slightly forward and stops. There is no arrow to indicate going up the beanstalk, only the arrow to go to the next scene. There is no mini game to play either. I've tried climbing the first beanstalk but the mini game is not there either. I can't advance until I figure out what is needed and play the mini game. HELP!!!!
 
 
 posted in Mystery Trackers: Black Isle on Mar 17, 13 3:05 PM
Never mind. I found it. lol
 
 
 posted in Mystery Trackers: Black Isle on Mar 17, 13 1:14 PM
The hint button instructs : "In the hotel corridor is a locked grate. You should be able to open it using the valve." I am unable to locate the locked grate. Where is it? I have the valve to open it, just can't find it.
 
 
 posted in The Lake House: Children of Silence on Feb 24, 13 8:41 PM
Shortly after posting my question above, I discovered that all I needed to do was tap the front of the bowl, it tipped and poured the melted metal into the key mold. Oh happy day! Now I'm continuing on, As I said before, I am really enjoying this game. Its not too easy and mildly frustrating at times, However, I am convinced that I'll finish it.
 
 
 posted in The Lake House: Children of Silence on Feb 24, 13 7:37 PM
I've been going through this game and I'm enjoying it very much. However I am stuck here. In the basement of the store there is a large furnace. On the top of it is a metal bowl to melt tin into liquid. I have the tongs, the key mold, and the melted metal. Whenever I try to touch the bowl of metal the game says, "HOT!". I assume there should be a glove or a pot holder to touch the bowl with when pouring into the mold. There is nothing at the site or in my inventory that gives me anything to touch the bowl with. I've tried the tongs at the site and the pliers in my inventory. I've tried the HINT button and it always directs me back to the bowl. What do I do here to continue progressing through the game?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator