Posts created by Tevele

 
 
608
 posted in Fishdom 3 on Sep 15, 17 2:07 PM
A three diamond level; two are easy, third seems impossible; it drops down to a corner which doesn't let it out and nothing EVER will line up to move it over. Is there a trick I'm missing?
 
 
 posted in Adelantado Trilogy: Book Two on Mar 18, 17 5:25 PM
I can find only two -- one in another area, one I actually have forgotten already. Wish there were a walkthrough for this....

NEVER MIND. Am leaving this for anyone who has the same question -- once you get enough to bribe one of the characters, you get the key to the chest, which has the others in it.
 
 
 posted in Island Tribe 4 on Oct 5, 15 2:44 PM
Here and there I just can't seem to find the darned things -- not the sand pieces, which I eventually get, but things like helmets which are there for only a short while. Do they change where they are each time, or is my memory just really horrible?
 
 
 posted in Living Legends: Wrath of the Beast on Jul 23, 15 4:48 PM
I have the CE, but it and the Strategy Guide say exactly the same thing, and neither of them help me. Can someone PLEASE say clearly, step by step, what is supposed to happen? Do I tap all five places and then hit go, or tap each place and hit go each time? I have tried both ways and neither works.I'm completely stuck and now very cranky.I wish they'd divide reviews by "only played the first hour" and "did complete thing" so glitches like this could be identified in reviews.
 
 
 posted in Mystery Case Files ®: 13th Skull ™ on May 22, 15 9:13 PM
Thank you! I've been bothering the help folks too much lately and this was such a minor problem I just thought I'd ask if other people had had the same trouble and fixed it. I'll know to go to the tech forums next time.

Wouldn't you know -- my two biggest tech problems this month were for a game too old and a game too new for my 'outer!

Thanks again for your time.

 
 
 posted in Mystery Case Files ®: 13th Skull ™ on May 21, 15 7:44 PM
The audio works fine, but my screen remains black, no matter how long I wait. I've done all the usual things . This is an older game that I don't recall playing -- I just noticed it on purchase history and decided to play, since I'm trying to clean out my less-played ones. I have fine memory and video. I've got a Mac with Yosemite OS; until a couple of weeks ago it was 10.6. Does anyone know what's going on, and have any suggestions for bringing the video in?
 
 
 posted in Dark Parables: The Little Mermaid and the Purple Tide on Jan 7, 15 10:11 AM
Just wondering if the beta testers included Imac users, since there's more than one problem with Macs running the game (ie they freeze and stop).

Recommend that if not, you acquire Mac beta testers. I have a PC laptop and an IMac, and this isn't the only game which has problems on Mac and is fine in the pc version -- just the most extreme tech problems. In certain others, I've gotten used to the version crashing on opening and having to restart.
 
 
 posted in Sparkle on Jul 2, 13 9:20 PM
I don't quite get the amulets, but googling got me places where they list how to get some secrets. I found at least two that weren't on the list of 8, though, so I suspect there are plenty waiting. They're designed to be fun distractions. In one, click on the map to go to the tower with an eye, once you're past it, and IMMEDIATELY click on the eye. To my surprise, that turned out to be one of the secrets. (I click a lot just out of lack of focus.)

I have a Mac, so not sure about I-phones and such, but I'm sure PC has these secrets too.
 
 
 posted in Dream Chronicles ™ 2: The Eternal Maze on Sep 25, 11 5:51 PM
I totally agree. The first I played I didn't like all of, because it was wayyyyyy too hard in certain places (like copying certain designs precisely, not just one but four of them!) and without either hints or a walkthrough, I'm now stuck in the eternal maze's 2nd scene. I mean, stuck. I can't do it. Problems which get in the way of following the story make me forget the story and therefore abandon the game, unless the game pieces themselves are fun.

I think they'll probably be selling a walkthrough in awhile. Have you noticed more and more games have a subsequent walkthrough, costing $$$? I'm wondering if they make it so hard sometimes so they'll have a market for the walkthrough. Otherwise, why not include it, or at least well-developed help advice, with the game?
 
 
 posted in Empress of the Deep 2: Song of the Blue Whale on Jul 23, 11 6:16 PM
It was just sneakier than I was. Thanks. SPOILER




if anyone wants to know, the keys actually fit the mysterious game in the middle of the lobby, and open the helper animal's prison from there.
 
 
 posted in Empress of the Deep 2: Song of the Blue Whale on Jul 23, 11 6:12 PM
I can't get the four keys onto/into the four red bulbs on the observation room in the secret lounge. How do they fit??? When I asked for a hint, it assumed that I'd already got the keys in and gave a hint for the next step.
 
 
 posted in Plant Tycoon on Jun 1, 11 7:34 PM
I've just started, so my question is related -- why do important seeds matter? I noticed today that three of the four "extinct" seeds are ones I have already through crossbreeding, unless later on you start getting the same shape and colour seeds for different things. They're definitely ones the fleabeetles (what I call the little pests) won't let live for any reason.

Should I save my seeds in the hopes it'll get better? Buy them later?
 
 
 posted in Plant Tycoon on Jun 1, 11 7:29 PM
In response to "Dim Innovative", I'm asking. I love the Village games, but I wish they came with more instructions -- better yet, a "look up" for explanations on such things as the infestations.

I finally figured out that some plants get infested more quickly, depending on how cool they are. I apparently found my first magic plant (Rose of Joy) after two days, but couldn't figure out how I found it! One problem I have is that I lose seeds quickly; I think they should let you upgrade to a "real" seed storers, where all the seeds of one kind can be put in a "drawer", and you can always keep a couple on hand. Ideally, labeled.

So, do we get all the magic plants by crossbreeding, or what? Is it chance? Is there something I should be doing?
 
 
 posted in Plant Tycoon on Jun 1, 11 7:22 PM
That's my greatest current problem too (just started this week.) some of the plants just need that spray, but I'm having fun hybridizing, and an awful lot of those attract bugs which kill w/in a second. They're usually the more interesting (ie possibly magical?) plants, like "rare maple" and "mystic bamboo." Does anyone know if the bugs let up later, or if it's going to be a down-to-the-wire finish to get the magical plants?
 
 
 posted in Hidden Mysteries: The Fateful Voyage - Titanic on May 14, 11 9:05 PM
I have that problem too -- and did everything right. I think I'll make a new post just to be clear this is a real glitch, not gamer error! (Well, maybe it's gamer error, but I can't imagine what.)
 
 
 posted in Hidden Mysteries: The Fateful Voyage - Titanic on May 14, 11 9:04 PM
I have done everything I'm supposed to, including getting the crank in, raising the box, getting the task from George (sitting in the car) etc. I checked the walkthrough after I couldn't cut it just to be sure.

She keeps saying "that won't work" in various forms, and it's driving me CRAZY. I don't know what else to do, so I'm stuck here.
 
 
 posted in Hidden Mysteries: The Fateful Voyage - Titanic on May 14, 11 4:08 PM
Just wanted to say -- "me too" -- not about the crankshaft, but my rope won't cut. I have tried EVERYTHING pixel by pixel....

My experience is this game is incredibly picky about where you put the piece. I did the crankshaft (finally) by putting the bottom of the shaft just above the hole for it. I tried a second game (hoping there just was a glitch the first time) and got it instead by putting the bottom of the whole thing, including the label, into that place. So I'm totally stymied myself exactly what's going on. This game is really annoying.
 
 
 posted in Hidden Mysteries: The Fateful Voyage - Titanic on May 12, 11 7:53 PM
I'm stuck right at the beginning; every time I try to use the utility knife to cut the rope she says that won't work. I'm beginning to think it's a technical glitch, because I used the hints and finally the walkthrough and it's hopeless. I've clicked on every blasted inch of space on the rope. Should I reload the game, or what?
 
 
 posted in Farm Tribe on Apr 28, 11 3:07 PM
I've read a lot of posts looking for the answer, but all I've got are clues I'm missing something! The early directions (feeding, teaching, etc) are fine. However, my villagers are at the point where they need new tech, to build new huts ( the first one just presents itself to you) and to... well, become more interesting than they are.

How do I open the new tech things and things to buy? They are all locked, which is fine, but I have about $35,000 and several thousand tech points ( I think; definitely more than a thousand). Do I just not have enough yet to start on the building part? There are absolutely no instructions in the game which I could find for unlocking anything -- just pictures of locks and a greyed out "buy" button.

I asked on another forum here, but no one's answered, so trying a direct approach. Sorry for whining. I've got the full collection except for three -- do I have to find those before anything else opens? I've been looking, believe me!
 
 
 posted in Farm Tribe on Apr 16, 11 1:38 PM
My problem is much more beginnery than others on the list. I have been through the tutorial -- have 10 characters, sufficient food, etc. I have all but 2 items for my collection. But NOTHING IS HAPPENING other than that. The islanders go and stare at things and ponder. I have experienced builders, farmers, and a scientist. But all they do is wander around collecting and eating things; I have two recipes (fries and jam) and 1 place for them to live.

I read questions about totems and rocks and stuff and have no idea what anyone's talking about. I have no idea what to do next. The game is really boring at the moment. Can I have just a few HINTS about how to move it forward? I'm sure they're eventually going to reach the bananas, etc, but how do I start moving them there, unlocking things like building another hut, etc.?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator