Posts created by Brandyco

 
 
 posted in Sherlock Holmes VS Jack the Ripper on Dec 15, 12 11:41 AM
I can't seem to start the gas puzzle. It won't let me pick up the gauge. Just says "I need something". I've got the tanner's mask. Can anyone help with figure out what I missed?
 
 
 posted in Sherlock Holmes VS Jack the Ripper on Dec 15, 12 11:38 AM
You probably don't want to hear this. I had same problem. I had to restart.
 
 
 posted in Sherlock Holmes VS Jack the Ripper on Dec 15, 12 11:36 AM
Not sure if this will help. You just need to look at the clock on one of the towers of the church.
 
 
 posted in Adelantado Trilogy: Book One on Sep 23, 12 9:14 AM
I got the dead tree but still missing one. I've got these so far:
-dead tree
-staglatite
-message beneath bush

???
 
 
 posted in Sherlock Holmes and the Hound of the Baskervilles on May 31, 12 9:18 PM
Let me know if you figured it out. I have similar problem. Painting is clean but sponge still there. I've been at it for 15 minutes clicking, can't exit out of puzzle because I can't even get to the exit button at top of screen. The walkthough doesn't help. I've read other postings and they said to wait until the sponge disappears but I've still got a sponge stuck to my hand.
 
 
 posted in Tesla's Tower: The Wardenclyffe Mystery on May 30, 12 5:08 PM
This probably won't feel very helpful. But you've got it right. The game is touchy in a few spots about getting just the right spot on screen. The cursor is large and the wax stick is off center. Point with the cursor instead of the wax stick.
 
 
 posted in Tesla's Tower: The Wardenclyffe Mystery on May 30, 12 5:04 PM
Really liked this game. Yes, there is a bit of dialogue. I like games that are like interactive books but can understand if others don't. If you don't like the level of dialogue in the demo, don't buy it. It does tapper off after the first part but not much. I thought that Tesla spoke up just the right amount and added to the atmosphere of the story immensely.

The puzzles are great. Not too hard but not random. (thank you developers) So many games just throw mini-games at you or tasks into a story that don't fit. The puzzles here were well thought out and all the solutions were logical. Also loved that it wasn't packed full of HOG scenes. I don't like HOGs at all and only after reading reviews decided to give this iHOG a chance. That and it wasn't a gothic romance story.

The only downsides I had were that some of the hot spots were hard to locate. I knew just what to do but couldn't get the cursor in the right spot. There are about three points in the game where this happened. Also at four different spots in the game, I had the solution, but not the piece of paper that helped with the solution so the game wouldn't advance. Wish it would advance even if I didn't pick up the paper with the combination/phone number.

Took my time and listened to all dialogue, read the whole journal and it took me about four hours.
 
 
 posted in Tesla's Tower: The Wardenclyffe Mystery on May 30, 12 12:27 PM
You have to get the combination into the inventory and then place it on the safe. This happens a few times in this game where you have to have take the piece of paper with you, even when it's a simple four digit code or diagram.

Hope this helps
 
 
 posted in Tesla's Tower: The Wardenclyffe Mystery on May 30, 12 11:42 AM
I had the same problem. It's a bit touchy where you click to wring out the sponge. I was at it for 6 minutes until I found the sweet spot.

If the icon changes to a hand, you've over shot the mark a bit. Don't aim with the sponge, aim with the cursor.

Hope this helps
 
 
 posted in Royal Envoy 2 Collector's Edition on Jan 5, 12 7:39 PM
While I appreciate the changes they made, I feel they made it a different game. It's almost as if RE2 is an iPad, tap game. It's no longer a strategy game, which is why I enjoyed the first one. In the original, I enjoyed working my way through levels and then going back to the ones I didn't get full score on and trying again. It isn't very challenging and I quickly bored of it. It seems strange to me that they had a strong game with a loyal following and then they went after a different target audience.
I didn't have any problems or glitches but after an hour of play I was bored, tried of clicking and didn't do the rest of the levels.
 
 
 posted in Nancy Drew: Secrets Can Kill Remastered on May 7, 11 9:19 PM
Not a fan of NiBuRu personally. If you lliked Siberia you may like Voyage.
 
 
 posted in Chronicles of Mystery: Tree of Life on Feb 13, 11 9:23 PM
Stuck here too. Got dry scarf. Asked for pot but didn't get one in inventory. Started game over twice. No luck.
 
 
 posted in Art of Murder: Cards of Destiny on Jan 1, 11 1:56 PM
Okay, after restarting that scene over. Getting her to say it's rusty isn't enought. Try the key with the padlock until she says "The key won't turn". Then talk to the bartender.
 
 
 posted in Art of Murder: Cards of Destiny on Jan 1, 11 1:50 PM
Help. Stuck at same spot. Got screwdriver, tried window, talked to Patti about story of the key and whiskey, got empty oil bottle. when I click on bartender, she says, don't want to talk now.
 
 
 posted in Art of Murder: Cards of Destiny on Jan 1, 11 11:04 AM
Thank you Big Fish. Haven't bought a game in 3 months because all the HOGs which I don't play. So happy to be able to find a new LF game!
 
 
 posted in Plants vs. Zombies on Dec 31, 10 11:17 AM
Happened to me too

1. Right click the shortcut to your game (if you don’t use a shortcut, right click the .exe file).

2. Click Properties.

3. Click the Compatibility tab.

4. Click the box marked “run this program as an Administrator.”

5. Click ok.

Hope this helps!

 
 
 posted in BugBits on Oct 19, 10 9:38 PM
Bug Bits 2??!!??? Too good to hope for. Love this game. Played it a while back and then came back to it. Still an outstanding game with lots of play in it. Fun to play as two player. Holding breath and waiting for another installment.
 
 
 posted in BugBits on Oct 10, 10 6:02 PM
Ditto here, great game!
 
 
 posted in BugBits on Oct 10, 10 6:00 PM
Hold off on sending out hero wasp & bomber bee until after you've killed off the tick's flying hero. Bombard with caterpiller and poisonpillar first, then attack with bomber and hero wasp.
 
 
 posted in Sherlock Holmes VS Arsene Lupin on Oct 5, 10 6:01 PM
Was hoping to find some help. Seems silly but I can't seem to figure out how to turn the dials counterclockwise. They all go clockwise and the puzzle doesn't reset when I back away.

Any suggestions?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator