Posts created by LULU5635

 
 
Thanks SeverineSnape. I never considered any but the uncharged unlock card for the window....doh!
 
 
Hi bfgFlounder. I'm playing Prisoners of Destiny. Good game, bit of a lag between scenes but I can live with it. However, I am stuck like Chuck, in a foyer with a woman/creature who asked me riddles. I can access only 2 rooms.1with a jug on a pedestal and 1 with a teapot that I need to put moss in. I have the scraper but where is the moss? I looked for a walkthrough and help in the forum, no luck. I can't progress without the moss. Save me, please!
 
 
 posted in Legacy Tales: Mercy of the Gallows Collector's Edition on May 12, 13 8:49 AM
Ah duh! If it was a snake, it would have bit me...
 
 
 posted in Legacy Tales: Mercy of the Gallows Collector's Edition on May 12, 13 8:39 AM
I can't find the last coin at the old well. Worse than that, I can't find the SG or a WT.
Can anyone spare me a clue?
 
 
 posted in Mysteries of the Undead on May 2, 13 1:35 PM
It worked frew, on the very tail end of the feather. Thanks again.
 
 
 posted in Mysteries of the Undead on May 2, 13 6:05 AM
Thanks frew52, I'll give it a try.
 
 
 posted in Mysteries of the Undead on May 1, 13 6:59 AM
Sorry you're stuck too Helleborus. The game is good but useless, if I can't finish it. I hope some kind soul out there will have a tip for us.
 
 
 posted in Mysteries of the Undead on Apr 30, 13 5:53 PM
I'm in a HO scene looking for the last of 3 feathers. I can see it, the hint indicates it, but I can't collect it. No matter where I click on it...nothing. Does anyone have a clue? I can't progress until I get it and of course the final item, after. It's so frustrating!
 
 
 posted in PuppetShow: Destiny Undone Collector's Edition on Mar 29, 13 12:21 PM
Try as I might, I can't set the clock hands to 10:10. I can't even grab on to them as the cursor doesn't change to a hand. I consulted the SG, it just tells me to do it, not how. Does anyone know how?
 
 
 posted in Azada: Elementa Collector's Edition on Mar 7, 13 12:41 PM
A walkthrough would be ever so nice. Soon, please.
 
 
So far, so good. I did contact Tech support but the problem righted itself before I got a reply. When I did, I let them know all was well and I wouldn't need assistance after all.
Scorpio, have you given the Warrior guard the Horse Badge? You have to do that before he'll accept the mended spear. Good luck.
PS, my sis started the game after I did. When she reached the fish statue and took the coin, the HOS appeared, no problem. I'm still confused as to why it didn't for me.
 
 
Update: Good news, I went back into the game to look around. I went to the water area, lo and behold...the HOS sparkles were there! I don't have a clue what changed, certainly nothing I did because all I did was complain. Big mystery. Not looking a gift horse (pun intended) in the mouth, I'm back to enjoying the game with my fingers crossed. Thanks all, for your effort and support.
 
 
Hi Scorpio, I'm also playing in casual mode. I ran into trouble after I mended the spear and took the fish badge. There should have been sparkles to indicate the HOS but weren't. No amount of mousing over the area had any effect. I will contact TS but I really want a fix or update, not a refund.
 
 
bfgBaikal, thank you for your quick response. I should have said in my 1st PM, I have consulted the SG. It shows me exactly where the HOS should be. I have moused all around that area but nothing happens. The hint button just directs me back to the Warrior guard. I was hoping to get an update on my GM.
 
 
I'm playing Enchantia: Wrath of the Phoenix Queen and have encountered a glitch in the Ruins. I have spoken to the Warrior guarding the Horse Lord, retrieved and mended the Silver Lance and gotten the object from the fish statue. At this point I'm supposed to be able to activate a HOS in a pile of rubble in the lower, right hand corner. I can see the rubble but cannot access the HOS at all. I've tried, over and over. I uninstalled/reinstalled to no avail. Has anyone else encountered this? Any helpful hints for me? The game ran smoothly up to this point, now I'm getting frustrated! Help?
 
 
 posted in Timeless: The Lost Castle on Feb 10, 13 5:51 AM
Thanks a lot. You all helped. I have no clue what I was doing wrong bur the box wouldn't open. Thx.
 
 
 posted in Timeless: The Lost Castle on Feb 9, 13 9:57 AM
I need to combine 2 items to open the door. The + sign is at a coil of wire and between pliers and tweezers. I can't make any combination. Clicking the + sign doesn't have any effect. Does anyone know?
 
 
 posted in Fallen: The Flowers of Evil on Jan 4, 13 4:31 PM
Hallelujah, I did it! I hated starting over but I uninstalled and reinstalled the game and played with another name. I was pretty easy since I'd already been there, done that.
When I got the drill, I went straight to the iron maiden, did everything else I could, before going to the shield, just in case. All 4 rivets came out, the drill disappeared and I proceeded to finish the game. No more glitches found.
 
 
 posted in Fallen: The Flowers of Evil on Jan 3, 13 6:42 AM
I'm in the same boat as you, WRD and Penguin. I got the 4th rivet, removed the shield but can't get out of the castle. I need the last mask and circle puzzle piece and have spiders. I found 1 shackle key and used it. Even the map is no help. I came here looking for a walk-thru.
 
 
Seems everyone is finding the same glitch in the pottery room. No matter what order you put the card suit tiles on the manikins chest, the last one you place, stalls the game. I had to use my task manager to get out...twice. I'll just wait for a fix to become available. Loved the game up to this point.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator