Posts created by Sablesshadow

 
 
 posted in Dracula Origin on Feb 18, 09 5:51 PM
Hi kw54, welcome to the forums.

Have you tried going to "All Game Forums" just between Forums Home and Chit-Chat Corner up above where the Big Fish logo is?

If you go there, and go to the game you need an answer to, you'll probably find it there.

If not, send me a PM (private message), found at the top right of your screen, and I'll try to help you.

Good luck and don't get discouraged. While you're going to All Games Forum, I'll try to find your answer.

Sablesshadow.
 
 
 posted in Haunted Hotel II: Believe the Lies on Feb 18, 09 5:24 PM
Welcome to the forums, PGNORTH,

Sorry you didn't like Haunted Hotel 2. I enjoyed it, but I don't have much experience with games. It certainly kept my attention. Hope you enjoy other games you play at .
 
 
 posted in Super Stamp on Feb 17, 09 10:21 AM
I don't know about a match 3 game w/o a timer, but have you demo'ed Gemsweeper.

I think it's an oldy but goody.

I tried the demo and bought it some time ago. Good luck
 
 
 posted in Dracula Origin on Feb 17, 09 10:07 AM
Rosie,

I was having trouble in the beginning until I found the walkthrough.

If you want info on how to get the walkthrough free, send me a PM.
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Feb 16, 09 8:34 PM
Hi, if you'd like to PM me, I can direct you to a walkthrough so you can see where you are and why you're not progressing.

This is a great game, but it is very complex (at least it was to me).

If you want to send me a private message, just hit the box on the top right of my response that's titled pm. That'll get to me.
 
 
 posted in Dracula Origin on Feb 16, 09 8:25 PM
really enjoy it, but would be hopeless without a walkthrough which I can reference now and then.

Honestly, more now than then
 
 
 posted in Dracula Origin on Feb 16, 09 6:51 PM
HoMake a key: Go down to the cellar below the kitchen.

Click on the vise on the worktable to get a close look at the items needed to make the key.

See that the file, nails, hammer and saw that were picked up earlier are on the right side. Below the measuring tape are dowels. The main constructing area is above the measuring tape.

Cut and fit the dowels: Take a dark brown dowel from bottom of screen.

Place-click dowel below the measuring tape.

Use the saw and cut the dowel to size 10 (one of the 4 measurements) taken from the secret passage. Do this by clicking the tip of the saw on the line below the correct number.

Take the 10 cm dowel and click the tip on the top right hole of the dowel above the tape.

Do this to cut 8, 12 and 5 cms dowels and fit them from top to bottom under the 10 cm fitted one.



Now the wide light colored dowel. Take the wide tan colored dowel below the tape and place it under the tape.

Use the saw on the tip of any number until Van Helsing cuts the dowel. My cut was done on 5 cm mark.

Place the wide dowel on the large hole on the left of the setup above the tape.

Trim the dowels: Take the file and click it on all the dowels to trim the ends.

Secure the dowels: Take nails and click on the opposite side of a dowel (see picture below).

Use the hammer on the nails to hold the dowels in place to get a makeshift wooden key. Now, will this work?


pe this works for you.
 
 
 posted in Cate West: The Vanishing Files on Feb 16, 09 4:13 PM
I'm playing the first 60 min. downplay. So far, so good. I will undoubtedly buy it. Thanks for the heads-up.
 
 
 posted in Dracula Origin on Feb 16, 09 8:55 AM
If you're at the Coptic, did he give you the host?

If so, take out the black sphinx and he will tell you to destroy it to get a secret.

From that point you should be able to go to the marketplace and heat some water.

Good luck. Post again if you need help, or pm me.
 
 
 posted in Dracula Origin on Feb 16, 09 8:52 AM
Hit the Esc (Escape) key at top left. This will bring you to the main menu wher you can SAVE the game. Good luck.
 
 
 posted in Dracula Origin on Feb 16, 09 8:46 AM
Did you show the Coptic Monk the black sphinx after he gives you the host? Then he asks you to smash it.?

After that you should be able to go back to the marketplace.

Write again if this doesn't work, or PM me.
 
 
 posted in Egypt III: The Fate of Ramses on Feb 13, 09 5:40 PM
I'd love 60 minutes of download before purchasing a LFG. At least it would give me an indication whether I could even get through the game (can you tell I'm not really good at them? Snicker at. myself; I should stop trying, but I'm addicted).

 
 
 posted in The Serpent of Isis ™ on Feb 11, 09 6:16 PM
I just want DC3 and I'll be happy forever. Or until I finish the game LOL.
 
 
 posted in Adventures of Robinson Crusoe on Feb 11, 09 3:11 PM
Michelle,

Have you contacted Technical Support. It may be a glitch they can fix quickly.

Look on the right of your screen for the green envelope.

Good luck.
 
 
 posted in Dream Chronicles ™ 2: The Eternal Maze on Feb 8, 09 6:40 PM
Hi lindeloo,

Let me be the first to welcome you to the game forum.

Try this:

Chess room: 1 white knight, 2 white rooks, 1 white pawn, 1 black king, 2 (?) black pawns, 2 black bishops.

Music room: 1 black pawn behind 4th chair (going left to right), 1 black queen by the steps.

Library: 1 white pawn on left side of floor, 1 white pawn under round table.

Once assembled, you can click on board to start play.

good luck ; need further advice, or how to get walkthrough, you can PM me.
 
 
 posted in Dream Chronicles ™ 2: The Eternal Maze on Feb 8, 09 6:02 PM
Stone,

Welcome to the games forum

there are no gems in the first chapter, you are correct.

There are two gems in the second chapter.

From then on in, there are many more gems in each chapter.

Good luck , need help, PM me.
 
 
 posted in Dream Chronicles on Feb 8, 09 5:53 PM
Roice,

If you've found all 7 pictures, and played the tunes all 7 pictures have, you should be able to just go to the door, click on it and it will open.

Good luck If I can be of further help, or you would like the walkthrought that shows you how to play the game, PM me and I can give you instructions how to get the walkthrough.

Welcome to the pond.
 
 
 posted in Natalie Brooks: The Treasures of the Lost Kingdom on Feb 8, 09 4:41 PM
Hi tnette13,

I hope I'm the first to welcome you to the forums.

If you're talking about the toilet, do the following:

click on top of toilet and the cover will come off.

click on handle inside tank and the water will flow out.

Retrieve the safe key.

Good luck and if you need more help, you can always PM me.
 
 
 posted in Dream Chronicles on Feb 7, 09 2:05 PM
Kay,

Regarding the wheels - one wheel is in the storage closet and the other wheel is under the bench on the right side of the room.

Hope this helps .

If not, send me a PM if you like and I'll try to help more.
 
 
 posted in Dream Chronicles on Feb 7, 09 1:12 PM
jenlew wrote:help. i am new to this computer game thing. am doing dream chronicles and have got to the library. found answers to opening drawer but it will not open. have followed all clues to the letter. someone please tell me where i am going wrong. thank you.


Hi Jenlew, I'm sending you a Private Message that I think will help.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator