Posts created by sapphire46

 posted in Mahjong Magic Islands on Apr 25, 18 1:14 AM
I agree with Pennmom36. This is going to cause a lot of problems to game players. I personally read reveiws on all games before buying. Especially to find out if certain games have a relaxed mode. If not I don't buy. I am very grateful to the reviewists, if this is a word, to provide me with information. Is Big Fish trying to get rid of us!! Some of us do not use the phone to play games. There are people who are housebound that rely on these games and the reviews people have kindly given. Especially the older generation that do not use their phones as extra digits like the younger generation. I think I will use my credits up then go, unless there is somewhere else I can read reviews.
Sorry this is not about this game but there is nowhere else to post this. The notice is locked....

 posted in The Forgotten Fairy Tales: Canvases of Time on Mar 25, 18 12:20 AM
re installed but didn't work so started again with a different name. Got through the problem with the gargoyle only to be stuck in the game of deciphers. Cannot skip or do anything. Fed up playing this now so will ask for money back.
 posted in The Forgotten Fairy Tales: Canvases of Time on Mar 24, 18 4:51 AM
Me too. same, stuck at gargoyle. Will try to re install to see if that works. reboot doesn't.
 posted in Lost Grimoires 2: Shard of Mystery Collector's Edition on Mar 19, 18 5:42 AM
This was written by jaxxgirl: I returned "Mr. Froggo" to his lady frog friend, and they hopped away. Now, the Hint sends me back to their log, telling me that she is missing something, but she's not there anymore, and there are no tools to be used on the sparkling area.
I too have this problem. The frogs have gone and there are nuts to collect in their place for the squirrel in the tree, to get the ring. Can't move forward until this is done!!
Has anyone got a solution?
This is in the bonus section by the way. Have not had any problems with potions etc.
 posted in Lost Grimoires 2: Shard of Mystery Collector's Edition on Mar 18, 18 6:18 PM
This has happened to me also. Is there a fix out there somewhere? Have we forgotten to do anything?
I have just played the game and had no problems. To get the buttons all I did was put the horns on and collected all lanterns to get code. From code I went to desk and entered the code under the shredder, which opens the drawer, got buttons from the draw, went to the window entered the other code (numbers), no problems at all. I run Windows 10 on a 32 bt.
 posted in Mystery Loss on Aug 21, 17 8:39 AM
Same here, no relaxed mode, no buy. Why don't these makers realise they are missing out on buyers by not doing this. They could sell so much more.
I am using Windows 10 . Had no problems loading and playing the game. Its just so frustrating waiting for the screen to load at every click!!! This is not the first game in this series that this is happening. It needs to be sorted out with the makers. Not that this would be any good saying, cos nothing seems to be done. Makes the game boring.... I forced myself to finish.
 posted in 5 Star Rio Resort on Aug 8, 17 3:29 AM
Well said Valdy. Same goes for me. That's the first thing I look for, if it's not relaxed I don't read any further.
I'm a bit peeved. I always play relaxed and usually get gold in the majority of other games, but it seems in this game you have to get gold in every level to get the bonus games. They are all unavailable to me, so that;s what I put it down to, not playing timed. I think that is bad to charge the price of a CE and not get all of the games. Think I have been fleeced....
You don't really need the Guide everything is straightforward.
Not a happy bunny!!!
 posted in Gnomes Garden: New home on Mar 23, 17 2:55 AM
I had the same trouble with the road not being able to fill in. I solved this by restarting the level again and made sure I mended the hole before lighting the lamp.
I am having trouble with level 37, the robber gets stuck on the outside of the screen, and the only thing that works is the fireman to get rid of robbers. Can't pick anything up completely stuck.
 posted in Incredible Dracula: Chasing Love Collector's Edition on Nov 5, 15 5:04 PM
I have just got past the problem by exiting the game and coming back in and playing the level again. This time leaving time in between chasing the Cyclops and opening the cave.
 posted in Incredible Dracula: Chasing Love Collector's Edition on Nov 5, 15 5:02 PM
I have just got past the cave. I came out of the game then went in again, played the level again and this time I left time between chasing the Cyclops away and opening the cave. I chased the Cyclops then went to collecting for the key. That way it worked..
 posted in Incredible Dracula: Chasing Love Collector's Edition on Nov 5, 15 4:33 PM
I've got the same problem. Still investigating a resolve.
 posted in Country Tales on Sep 29, 15 3:30 AM
Thank you Ivan for creating games with a relaxed mode. I and many more enjoy playing time management games for relaxation, not being rushed to get gold.
 posted in Sacred Almanac: Traces of Greed on Jul 27, 15 3:31 AM
I too miss the voice overs, I think we have got too used to them. This downloaded with no problems (windows 7, 36 bit, Home edition) I did find it a but jerky sometimes and took some time to change scenes. The puzzles so far, I found quite easy and I am not a puzzle person. It is an adventure game, didn't come across any hidden objects in the trial. Have bought it with a credit because it made a change.

Robilyn,I reinstalled the Game Manager and it worked, so it looks like I will be going that route now.
Tookat I did check, and it was all up to date. So there was no other option, uninstall and reinstall.

Again thanks
Hi Valdy
I know its the US that celebrate July 4th. I was just a bit frustrated. I can't find the problem, just leaving it to my son to hopefully sort, I'm not technically minded. Never have problems downloading, perhaps I have just been lucky. For some reason BF is closing down my protection software. Away from downloading, everything is working fine. So whether its something on the site that's causing it, I don't know. Good job I'm not waiting for games, I have loads to catch up on...
Can't get anything to download at the moment. Used the BOGOF, everything else worked, went through smoothly. Will try again later. I never have this trouble is it because it's July 4th and no one is around...... I use Windows 7.
 posted in Beyond the Invisible: Evening on Mar 10, 15 4:16 AM
[Removed by Moderator]
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator