Posts created by Meandy40

 
 
 posted in Demon Hunter 4: Riddles of Light Collector's Edition on Mar 6, 18 2:46 PM
Hint doesn't work for some reason at this point but from the guide which is an irritant in itself I understand that I have to somehow climb to the top of the bridge to leave this underground area. I am guessing from the walkthrough that I am supposed to have a brick and a stick of some kind. I have gone back over and over this and I have no stick but do have a brick. I don't like the way we have to access the SG and still can't figure out why the Hint did work but now it doesn't. I can't go anywhere else so I am desperate for help here. I am 77 years old and I really do not wish to end my days in this underground area. I don't want to have to uninstall and then install again but I just don't know what else to do.

Can anyone help a senior out here?

Meandy
 
 
It would be really great if I could leave a review but since I am stuck trying to figure out the stupid crossbow then I will probably remain in that room forever. The game has unusual HO and I don't like them, game is also jerky and has other quirks. Sorry I am stuck with it in that I was fool enough to buy it.

I think I will uninstall and try again.

Meandy
 
 
I am supposed to line up crosshairs? Are you serious? I am 77 years old and I am to do this in MY lifetime? Is there some secret to this because I have tried and tried. I can't skip either.

Meandy
 
 
 posted in Greed: Old Enemies Returning on Jan 10, 18 2:24 PM
Ok, I doubt if anyone else is as goofy as I am and will need help with the robot but I did figure it out. All I had to do was move my cursor just a little and it turned into a hand so I was able to pick up the tubing. Sigh.

Meandy
 
 
 posted in Greed: Old Enemies Returning on Jan 10, 18 2:20 PM
I sure cannot figure this one out. It tells me I need to borrow parts from the broken robot on the steps but which parts do I take and how do I get them? I have tried the screwdriver and the knife but still can't remove anything. Actually I even tried using the cupcake but I admit I was desperate. Flamethrower can't be used either nor the radiation gun. Any advice would be appreciated.

Meandy
 
 
 posted in Reincarnations: Awakening on Dec 7, 17 1:49 PM
I see I am not the only one having problems with this game. It flickers all the time, all movements are jerky, rarely does anything work correctly that is suggested, takes several clicks to navigate. This is a horrible game!


Meandy40
 
 
Map
I agree, have seen much better.

Meandy
 
 
 posted in Grim Facade: A Deadly Dowry Collector's Edition on Oct 1, 17 11:24 AM
This game will only play for maybe 3 minutes and then it stops and error message says it is a run time error. I have no idea what is going on other than I bought a game that I can't play. Have tried twice. Any suggestions?
 
 
 posted in Nick Chase and the Deadly Diamond on Apr 21, 17 5:11 AM
I caught the first mouse and now need to find water for the cement mixer. I have the empty bucket and am told to collect water dripping from the ceiling to add to the mixer but I cannot find the water. I have no more bullets for hints because I used all of them trying to find the water. Where is it dripping?

Meandy
 
 
 posted in Fantastic Creations: House of Brass on Mar 22, 17 5:06 AM
The bluepriint of the house is useless. And of course everything is locked up tight so here I am asking a question that won't be replied to as usual. How can I find the forge? Am not happy with this game anyway. Why can't a map be provided?

Meandy
 
 
 posted in Mystery Novel on Mar 9, 17 4:35 AM
The portal is supposed to be destroyed and we are to play a hidden object against the evil person but it just doesn't end. I keep losing and even though I click on Skip it just starts over. Is this really the way this game ends? BTW this was not all that much fun. Game was jerky in movement and difficult to follow. Has anyone truly finished this one?

Meandy
 
 
 posted in Redemption Cemetery: Curse of the Raven on Feb 12, 17 6:10 AM
I will answer my own question because I finally figured it out. I noticed others mentioned slicing the sausage so I backtracked to the kitchen and sliced the sausage and then was able to feed the fish. I am only babbling on here in the hopes that another lost soul might find comfort and help.

Meandy
 
 
 posted in Redemption Cemetery: Curse of the Raven on Feb 12, 17 5:56 AM
What am I doing wrong? I have the sausage but I can't get it into the tank so I can distract the fish so I can get the figure. I have tried everything but that is all the walk through says to do. Hint isn't even helping.
 
 
jcsgame, you saved my sanity! Maybe even my life! It worked! Thank you so much!

Meandy
 
 
Ok I will try this and see if it works for me.

Meandy
 
 
Thanks. I did check the Guide and have been working and working trying to get that same pattern. I will keep trying.

Meandy
 
 
I can't figure it out either. I can get the panels to slide for first three numbers of the code but that is all. The Guide doesn't help and the Hint just keeps telling me I need to slide the panels. Well duh, I already knew that. Has anyone else figure it out?

Meandy
 
 
 posted in PuppetShow: Bloody Rosie Collector's Edition on Nov 26, 16 7:05 AM
Well the man is going to drown if he is waiting for me to save him. I have tried everything, shut down several times but nothing works. Can't skip but can't get beyond this either. I don't understand what either horizontal bar or vertical bars have to do with anything nor even the crossbow. When the cross hairs turn green I can click and click at some vague face or something in the water but nothing happens. Waste of money and time on this game and at my old age of 76 the damn lake will dry up before I get the man out.

Meandy
 
 
 posted in Fear for Sale: The Dusk Wanderer on Nov 17, 16 2:04 PM
Has anyone else had problem with the Hint button quitting working? I know it worked at first but it no longer does.

Meandy
 
 
 posted in PuppetShow: Lost Town on Oct 15, 16 1:49 PM
Me again, the old frustrated and very ticked off senior. There was no corkscrew in the circled location. There was some kind of "think" way on the other side of the room and the "thing" was not a corkscrew, looked more like a shoe horn but I began clicking all over and was able to get out of that HOG. If anyone is still having problems try clicking on anything and everything that does NOT resemble a corkscrew and you should find it. Don't bother using the Hint button.

Meandy
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator