Posts created by Duetgirl

 
 
 posted in Ancient Quest of Saqqarah on May 22, 14 9:58 PM
Lizzie, u r brilliant to have taken screen shots!! I am currently in the far eastern frenzy. I saw where u r starting the monkey one. I'm totally stuck on the '6th Thot first level. Have u perchance played that one yet? I've prbly spent 3 hours on it. I'm so blonde. Thanks for any help u can give!!
 
 
 posted in Surface: The Soaring City on Oct 5, 13 9:07 PM
This is my 3rd Surface game-- and I absolutely loved it. Each game is completely separate from the others-- someone else also brought that up. The fact that these are stand-a-alone games makes it nice. Very unusual plot--- I loved that there were no monsters, etc. and it wasn't 'dark'.

I found the HOGS very crisp and clear-- I find it interesting that sometimes you can't finish one, as you need a part from your inventory that you've not found yet. I did the Advanced mode, and only used the Hint button occasionally.

I absolutely love the fact there is a map, and you can jump from location to location. Plus the map shows you if you have finished in that particular area.

It was a very long game (almost 6 hours for SE; I'm in no rush) and I thoroughly enjoyed it. If you like an interesting storyline; good vs. evil; lots of VERY unusual puzzles; and HOGs, then you will like this game.

It also had the morphing objects in the SE, which I find really fun. Great job Elephant!! Keep up the good work!
 
 
 posted in Surface: Mystery of Another World on Sep 24, 13 9:58 PM
Sea Anemone-- I too-- can go to the book and go to any other room, but cannot get into the Springs of Life itself. The entrance is flashing like I should go there, but won't let me. When I tried to exit out of the game, the menu came up but was very faint. I finally closed out and re-started my Ipad. Still unable to enter the room. I thought about uninstalling and reinstalling, but since I am at the VERY end of the game, if that means I have to start over, can't do that!! Very very frustrating!
 
 
 posted in Surface: Mystery of Another World on Sep 24, 13 9:54 PM
I loaded this game on my Ipad-loved it. Got to the end-- and I am stuck outside the springs of life room-- can't get in it thru any of the openings, and of course my wand is useless. The game literally freezes at this point. Help!! I want to finish the game.
 
 
 posted in The Veil of Mystery: Seven Little Gnomes on Aug 30, 13 8:51 PM
I too can't get past the bedroom. When I use Hint, it flashes a circle above the bed, and says 'play a HOG'-- but nothing happens. I can click all day. I've exited the game, re-entered, and same old same old. I have an updated computer, and Bigfish even did a Dr. Felx on another game-- but this one is for the birds. I'm done. I have bought a lot of games, but this one is toast. PLEASE fix these glitches before you release the games!!
 
 
 posted in Chronicles of Vida: The Story of the Missing Princess on Aug 23, 13 9:46 PM
Thanks to whoever mentioned this! I switched to Easy mode, used the sparkles, and was able to move on!! Now I'll switch back to hard mode. Thank you thank you!!
 
 
 posted in Chronicles of Vida: The Story of the Missing Princess on Aug 23, 13 9:33 PM
OK-- how do I find the last mirror piece-- shaped like a bird?? I have NO clue. Please help! If I can fix the mirror, maybe I can continue the game!!
 
 
 posted in Chronicles of Vida: The Story of the Missing Princess on Aug 23, 13 9:08 PM
Thanks Maddie13!! That worked! What an ingenious solution! I now cut the box!
 
 
 posted in Chronicles of Vida: The Story of the Missing Princess on Aug 23, 13 9:05 PM
I can't get the diamond to finish either. It has 2 more lines to go, but won't move. If I back out of the room and come back in, I can try again-- but still no go. Very frustrating. Also, so much random talking about nothing. Between all the nonsensical dialogue and black screens, the game moves very very very slowly. Otherwise it's ok. No problems on the HOGS (using custom cursor)

How do I continue the game if I can't get the diamond to finish cutting??
 
 
 posted in The Chronicles of Emerland Solitaire on Jul 2, 13 7:25 PM
Andrew- quick update on Chronicles of Emerland. Absolutely LOVE the game-- but the last level is HORRIBLE. I played it quite a few times-- several times with all 10 perfects, and was only able to collect 41 out of 60 shards. Very dis-heartening. I had all red shields w/yellow, and most levels were perfects with a few Xs here and there. I absolutely loved the game-- but the last level gave me fits. And there's no way to go back adn look at your scores from previous levels. I no longer care what happens to the Golem-- I understand he gets locked up! So I will move on to a different game. I would have liked ot have finished this one though-- very enjoyable game. Please just fix the end!!
 
 
 posted in The Chronicles of Emerland Solitaire on Jul 2, 13 7:21 PM
I have played the last level at least 4 times-- twice with 10 perfects, and this last time with 9 perfects & 1 w/1 card. And STILL only got 41 out of 60!! I did not buy every single amulet, so I am wondering if that is part of the catch. I even went back and played thru the beginning levels that I had a blue shield (not red w/yellow on it) and that gave me 4 extra shards. Most every level was all perfects, with a few red x's here and there. Now ALL my shields are red w/yellow. So all I can figure is the amulets. I'm glad you said what happened in the end-- because I've spent all the time I will spend on this game! This is a FABULOUS game-- but this last level is just beyond HORRIBLE. There should be some way to win without it being THIS difficult.
 
 
 posted in The Chronicles of Emerland Solitaire on Jul 2, 13 7:11 PM
Victor- maybe you can help. I have all gold shields, but I did not buy every amulet. Could it be that we are required to buy them all to win???
I just replayed the last level 9 perfects and 1 w/1 card, and only got 34 out of 60.
Very confused. Any help is appreciated!
 
 
 posted in The Chronicles of Emerland Solitaire on Jul 1, 13 11:27 AM
Think this is a glitch-- I am on the last volcano level, and played all 10 games perfectly, but only collected 41 out of 60 artifacts. How are you supposed to get more artifacts?!? No directions anywhere-- and I am thinking 10 perfects is about the best you are going to get! How do I finish the game?!?!? THanks-- this is a really really great game.
 
 
 posted in The Chronicles of Emerland Solitaire on Jul 1, 13 11:24 AM
I am stuck on the last level. I had 10 Perfect games, but only collected 41 out of 60 artifacts. HOw do I get the rest?!? Don't think you can get better than 10 perfects?!?!?
 
 
 posted in Seven Seas Solitaire on Jun 14, 13 12:39 AM
OK-- I know I'm blonde-- but WHERE are these upgrades?!? I sure don't see them!
 
 
 posted in Seven Seas Solitaire on Jun 14, 13 12:35 AM
I'm with you-- I have been playing this game for a while now, and have never seen anything like that! Does anyone know where they are hiding the upgrades?!?!/
Thanks!!
 
 
 posted in Seven Seas Solitaire on Jun 14, 13 12:34 AM
How do you buy an upgrade?!? You all mention mini-games and upgrades, and I'm on the (last)? chapter, and have somehow by-passed all these.
Help! Thanks!
 
 
 posted in Seven Seas Solitaire on Jun 14, 13 12:28 AM
I agree with Debzzzzy. This is a VERY addicting game. I have played it for hours on end, and still haven't been able to complete it! You have to decide if you're going for money or for perfect scores-- so you really have to 'guess' wisely. I am on (I think!) the last level. My only wish is that you could go back and replay some of the games within a chapter. As it is, once you accept your score for that hand, there's no going b ack. And after 10 hands, to lose by a mere 1000 points is very sad.
I had no clue there were mini-games or island-building, though-- I will have to go back and check that out!
 
 
 posted in Strimko on Apr 27, 13 10:30 PM
Spoiler Alert--
Didn't like this game at ALL. I tried the demo (adventure) and didn't even make it ten minutes. The 'wheel' that opened to give you the numbers was way too bright/ not only did it hurt my eyes, but it hid the grid. I think with different graphics it could be all right. but it wasn't worth a literal headache to me. I liked the challenge- but couldn't get past the graphics. Sorry fishies!!
 
 
 posted in Gardenscapes 2 on Apr 25, 13 8:13 PM
Another great Gardenscapes game! I now have all 3, and have thoroughly enjoyed each of them! This particular one includes his Mom & Dad, and you get to relive some of Austin's childhood. This one seemed like it ended a lot sooner than the others, but was thoroughly enjoyable. Reminded me a lot of Chronicles of Albian, the Magic Convention; and also Tales of Lagoona-- Orphans of the Ocean. I love the detective HOGS (especially Edgar Allen Poe ones)-- but this is such a nice break for when you just want something light. Music is nice (pretty much the same as the others), and just fun.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator