Posts created by Mauvina

 
 
 posted in Fear for Sale: The Dusk Wanderer Collector's Edition on Jan 20, 17 11:29 PM
It has been a month since I posted my issue; so far no reply or solution. This is not the first time I've been disappointed in the quality and performance of games on this site. What good does it do to have a tech forum when no one seems to be getting any relief from all the problems with this game. Maybe you should do more testing before releasing your games. I for one would like my money back and will probably be canceling the subscription I've had for 10 years. Why keep paying when games are available on other sites for free.
 
 
 posted in Fear for Sale: The Dusk Wanderer on Jan 15, 17 9:15 PM
ben's 50's room. Game won't let me place last piece of tile on box. tried reloading. I'm using windows 10 on pc.
 
 
 posted in Fear for Sale: The Dusk Wanderer on Jan 1, 17 2:16 AM
hop apparently has a glitch. It won't let me place the last piece on the box top
 
 
 posted in Fear for Sale: The Dusk Wanderer Collector's Edition on Dec 18, 16 9:57 PM
I'm in Ben's room. the hog won't let me place the last image on the box. I'm using windows 10. everything is up to date.
 
 
 posted in The Theatre of Shadows: As You Wish on Aug 14, 12 11:36 PM
I too am having the same problem with the edges of the screen in hos. I've tried changing the resolution to several different settings, thinking that I might do better in window mode. No go there either. I even quit the game and started over to avoid this same problem with another hos in this game. It worked, but here it is again! Come on BFG, help us out here!
 
 
 posted in Hexus on Mar 24, 12 11:28 PM
I'm having the same problem. I've tried ringing the padlocks with different colors, blowing away surrounding colors and using different numbers of colors. No luck. Anyone have any other ideas?
 
 
 posted in Mountain Crime: Requital on Dec 12, 11 2:28 AM
I am also having the same problem after buying this game. I even restarted my computer. How about it Big Fish techs; is there a fix for this ?
 
 
 posted in Youda Mystery: The Stanwick Legacy on Nov 17, 11 11:03 PM
Hold down left mouse and drag behind where lettering disappears in joray2 answer.
 
 
 posted in Silent Evil: Kate's Rescue on Jul 7, 11 2:38 AM
Again another game with a very bad english translation. Graphics are poor and dark. Almost no instruction. Difficult to navigate. There have to be better games being developed out there.
 
 
 posted in AGON: The Lost Sword of Toledo on Jun 7, 11 10:56 PM
The link does not work....fix it
 
 
 posted in Aspectus: Rinascimento Chronicles on Mar 28, 11 7:16 PM
Normally I enjoy adventure games, but this one (as is becoming usual of late) is a poorly made, badly translated, caricature of one. Doesn't anybody review the english and sentence structure of these games?! It rates a big W-H-A-T ??? for me.
 
 
 posted in The Island: Castaway on Oct 26, 10 1:16 AM
It's in the cave with green water. To the right, narrow passageway.
 
 
 posted in Aztec Tribe on Oct 23, 09 12:42 AM
I found the best thing to do at the higher levels is to get over 1000 of each resource before building any of the larger mines, mills, etc. Buy what you need from the traveling market at the beginning of the level. No way to stabilize buildings.
 
 
 posted in Aztec Tribe on Oct 23, 09 12:31 AM
I have the same problem. It closed itself 3 days in a row. Anybody having trouble with level 31?
 
 
 posted in Treasure Seekers: The Enchanted Canvases on May 30, 09 12:54 AM
There is something hanging outside the fisherman's cabin that you can carry the fire in.
 
 
 posted in Hidden Expedition: Amazon ™ on May 29, 09 10:51 PM
Thank you for the info. This is the first problem I've had finding anything.
 
 
 posted in Hidden Expedition: Amazon ™ on May 28, 09 2:59 PM
can't find the crowbar. Hint only gives where crowbar must be used.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator