Posts created by Zone244

 posted in Mystery Case Files®: Fate's Carnival on Feb 6, 14 5:49 PM
WilJul wrote:Hi pinkwitch12! You want to swap the buttons in the left row so they match the buttons on the right. There is a CE walkthrough that can be found here:

But keep in mind it is for the CE so will have extras in there, such as bobble heads, cards and old pounds, that won't pertain to the SE game, so just ignore those parts. Good luck!

My thanks as was maddening!
 posted in Cruel Collections: The Any Wish Hotel on Jan 23, 14 5:32 PM
Been having the same problem too with that stupid cupcake. I got the door from the room behind the piano room and used on the veranda to the left of the piano. Got the cat cage stuff, got the cat. I knew that case had to be opened in the piano room and after checking other comments, found out that OSCAR is the word for the case.

Received a ring, which I placed on that hand door (the veranda entrance left of the piano room). Now into a HOG and hopefully I'll get the plunger to clean up that sink and get rid of that stupid cupcake.

I haven't had as many problems with this game as other people have had, but it's just frustrating when the game is going along nicely and you get stuck.

My practice, like others I'm sure, is to play the demo for an hour and make a decision. Of course, it will work well in the first's when you get deeper into the game when problems occur. Extremely annoying and it's been happening too much lately.

Cheers, and on with the game!
 posted in Queen's Tales: The Beast and the Nightingale on Jan 7, 14 9:12 PM
Yes, me too. Re-installed...was a no go at the same spot. Re-started the whole game under a different profile...same thing. ERS is getting sloppy these days. Having all kinds of problems with Haunted Halls: Nightmare Dwellers too. Both enjoyable games but I think I want my money back or credits.
 posted in Queen's Tales: The Beast and the Nightingale on Dec 2, 13 7:35 PM
The game is cooking along very nicely - no problem. Get to the dungeon, use the pick axe on the rocks and everything freezes. The cursor is all over the place and cannot land where it should. Did a re-install and same thing. This is the first time this has happened to me (drivers, etc. are all fine.). All BF games work well for me except for this one and Maestro: Music from the Void. As I said, they cook along nicely, until they hit this "dead" zone which you can't get past.

Just thought I'd let you know that there might be some glitch.

 posted in Riddles of Fate: Wild Hunt Collector's Edition on Oct 25, 13 7:11 PM
Thank you! Was going batty trying to figure it out.
 posted in League of Light: Dark Omens on Sep 19, 13 9:41 PM
I cannot get the stick out because I cannot find the other half of the seal to open it. The walkthrough shows it's on top of the chest, but it is just not there. Cannot advance with out that second half. Any help would be appreciated! Thx.
 posted in League of Light: Dark Omens on Sep 17, 13 7:10 PM
I too reached the dungeon after using the dynamite to blow out the wall. The second puzzle I can't leave. It's still missing a piece which I don't have in my inventory. I try to leave the scene, but can't - the pointers has the gears going. Uninstalled, reinstalled, same thing. I'm really enjoying this and I guess I don't mind starting over with a different profile, but I don't want to reach this point again and not be able to advance.
Is it a glitch?
 posted in Maestro: Music from the Void Collector's Edition on May 15, 13 2:32 PM
woz729 wrote:I agree that it is getting old. And usually the fixes don't help. Also want to mention that this game lags badly. I don't recall the other 2 Maestro games lagging like this one. Maybe a "patch" for lag time? Gets annoying when waiting to get to next scene. Thanks.

Has this been fixed yet? There is nothing wrong with my system only this game; all others play fine.
yes, thanks very much for that! Was stuck too!
 posted in Hallowed Legends: Ship of Bones on Apr 20, 13 1:28 PM
layzeedaisy said it best. It was boring, but graphics were good. Not as good from these developers in the past. And, it was pretty much a chore to continue. Using the map is sometimes helpful, but I went to use it to get to another place where I needed to go it was non-functional., click....annoying.
 posted in Hallowed Legends: Ship of Bones on Apr 20, 13 1:22 PM
layzeedaisy wrote:Good quality as usual from this dev but nothing about the game really kept my interest.

There was too much of the going backwards and forwards between scenes and it appeared to be just for the sake of making the game longer.

From around two thirds of the way through the game, I just used the map to see where to go. For me, that's not a good way to play a game. I was getting very bored just collecting bits and pieces to use somewhere, wherever, later.

The story was there, but not much of a plot.
 posted in Maestro: Music from the Void Collector's Edition on Mar 15, 13 9:00 PM
I've been experiencing that lag time too and finally came here for answers. Guess I found it. THX! Haven't looked at the info yet to see if it works as I'm getting tired from waiting for scenes will try tomorrow.

As for problems downloading I contacted Tech Support (VERY helpful) as I was having problems too. As it turns out, it was my anti-virus software - ESET NOD32. This hasn't happened in the past, but I guess ESET upped their security. Anyway, I have to uninstall that software in order to try a demo. Once DL, I re-install NOD32. If I decide to purchase, for some reason I don't have to repeat that process. Sounds convoluted, but it's not. Downloading problems can be your anti-virus.

 posted in Dark Dimensions: City of Fog on Feb 4, 13 12:18 AM
I've been really enjoying this game up until the missing angel. Went through the whole walkthrough trying to find the one I missed and I can't find it. Hint button is of no use...'my investigation is done here'...well mine is too. Another day...
 posted in Dark Dimensions: City of Fog on Feb 3, 13 11:46 PM
Thanks very much! I was missing one angel and couldn't figure out where I missed one of those pesky things You are an angel for posting where I need to go THX
 posted in Nightfall Mysteries: Asylum Conspiracy on Jan 16, 13 11:14 PM
WooHoo! I had given up for the night, but it was still bugging me, so I fired it up once more. The ring of fire is gone and the rib cage moved! So much for getting to bed by midnight
 posted in Nightfall Mysteries: Asylum Conspiracy on Jan 16, 13 10:36 PM
I've got all the organs in the proper place but #6 (the rib cage) in the anatomy put together. It refuses to move and I can't skip it. I have been playing this all evening and just awhile ago I noticed a sort of circle of fire near the skip button. Is that causing the problem? Anyone else have this? Driving me crazy....I wanted to finish this tonight!
 posted in Twisted Lands: Shadow Town on Jan 15, 13 5:37 PM
madog12 wrote:I was having problems with this too. I can't see any numbers on the dials at all. I did finally open the cell - here's what I did: If you can see the faint arrows inside each dial, line those up first. I don't know if it's different on everyone's game - but I tried various combos. I put them all pointing at the four oclock position. Then, I clicked the top one five times, the middle one once, and the bottom one 8 times and it finally opened. The key is to get all the arrows pointing in the same direction to start with. Yours may be different - but try the four oclock position first and see if that works.

Yes, it depends on your badge number - mine was 942. Lined up all arrows (could finally see them; eyes were tired last night), then counted out accordingly to the badge #. Worked...just to get a key....
 posted in Twisted Lands: Shadow Town on Jan 14, 13 8:45 PM
I can't see jack on those dials and I am playing in a very dark room. There is nothing wrong with my monitor and I refuse to adjust my resolution for this game. Not really enjoying it, just wanting to complete it so I can get it off my hard drive.
 posted in Our Worst Fears: Stained Skin on Apr 12, 12 2:27 PM
I cannot pick up the octagonal tile (the scene with all the ribbons of light) to fit in the last door. Any clues? Also, how do I put out the smoke to get the lion head? I imagine once I can pick up the tile, everything will fall into place.

Thanks for any help!
 posted in Ghost Towns: The Cats of Ulthar on Mar 23, 12 7:42 PM
I just finished it myself and I loved it! However, all this back and forth walking is tiring. No wonder I'm tired in the morning! Very good game...will probably play it again in a couple of months - and probably get it confused with other games Good job BFG!
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator