Posts created by Jemby

 
 
 posted in Wanderland on Feb 24, 18 10:06 AM
Thanks for the tip, Fred_just_Fred; I looked at Midnight Castle but was not impressed with the graphics, and the atmosphere is too dark, grim, and "gothic" for me. But I appreciate the idea. I prefer something in between gruesome and cutesy-poo (can't take all those sparkles and big-eyed waifs, either).

Good luck to you, and enjoy your gaming!
 
 
 posted in Wanderland on Feb 23, 18 3:14 PM
Really want to like this game. Interesting design, good graphics, challenging quests. BUT. After finishing 22 levels, I have still made no progress. Played all the HOS multiple times in all modes. Played all the curses (mirror/reversed, fog/smoke, text anagrammed).

Here's my big problem: This should be labeled "Pay to Play", and not "Free to Play." The resources needed to play the game are (1) energy, (2) gold coins, and (3) rubies. The Wizard's Well gives you energy BUT every so often you have to spend gold coins to "upgrade" it - and you get no more energy until you do. The Golden Idol gives you gold coins, BUT every so often you have to spend rubies to "upgrade" it - and you get no more coins until you do. You can win Rubies by getting the Dragon, or by completing Collections, or Achievements; but you'll spend them buying energy, necessary tokens, and upgrades.

The cost of the "upgrades" keeps going up...and up...and up. And now I'm out of energy and coins, and it will take three more days to earn enough rubies to "upgrade" the Idol, and another several days to earn enough coins from the Idol to "upgrade" the Well, and there are now three locked zones that I should get into, but can't earn what's necessary unless I spend real money to buy my way in. And the three portals I opened back around level 4 have nothing playable because the Quests that unlock them aren't available yet...so I can't play any of those puzzles or mini-games; just endless repetition of the same HOS.

I played Elvenar for 2 years before finally admitting I was burned out on these so-called FTP games. I enjoyed the game but never spent any real money, and the requirements to move on finally became so onerous I closed down all my buildings and left. And that's what I will do with Wanderland; I've reached the tipping point where the only way to move on is to spend real money, on and on without end. I won't hand Artogon or Big Fish my checkbook to keep on drawing funds out of me, so there's nothing more I can do here. Really sad, because it could have been enjoyable. If they ever decide to simply sell the game and let people play it like any other without sticking their hands in my wallet, I might reconsider.

I will ask one thing of BFG: place all these games under a heading "Pay to Play", and don't mislead people using the term "Free to Play". At least you would be honest up-front and not waste people's time, and the money they probably cannot afford.
 
 
 posted in Wanderland on Feb 14, 18 11:59 AM
The game is interesting and well thought out; the graphics are fun and the HO games are relatively challenging, especially in night mode. But I agree with some earlier posts that it is too repetitive, and it takes too long to move onward. I'm at level 21 but have had to spend the rubies and coins I've earned to keep upgrading the Golden Idol (to get more coins) and the Wizard's Well (to get more energy); I can't afford the chests when I defeat an enemy, and I can't afford to buy required items to complete Quests or Collections. I've completed the first two portals with mini-games; the next three have been open for the last 18 levels, and I have achieved none of the requirements to enable the mini-games - haven't even seen a task or goal that relates to them. I've tried to add Friends as required to complete the treasure maps, but no replies from anyone. Bottom Line: the game is a time suck that only works well if you spend real money to buy the tokens (energy and rubies and coins). I spent 2 years on an F2P game (Elvenar) and swore I'd never get trapped in another. My bad for purchasing this one.
 
 
 posted in Hero of the Kingdom II on May 5, 15 9:15 AM
I also had Access Violation problems with both games. Found that by updating my graphics driver (AMD Radeon) it resolved the problem, and now I can play.
 
 
 posted in Elements on Jul 20, 14 4:26 PM
Can't believe I didn't see this when it first came out. However late to the party, I am enjoying it very much. Quite a challenge, and I like the background music. Very different type of game, as it tests your skill in observation and planning to achieve the best moves.

I'm playing Relaxed mode and made "Expert" score on several levels...will try the timed version next.

Thanks for another great game!
 
 
 posted in Rooms: The Main Building on Jul 20, 14 4:22 PM
Game does not display properly on Windows 8. I just reinstalled BFG Game Manager a week ago and am running all my games from it, rather than from desktop icons.

Just downloaded and installed 4 games yesterday, and this is the only one with a problem. The display opens in a space about 3" wide x 7" tall, and the text is so tiny I can't read it to try and select an Option for another resolution. I did click something (don't know what) that changed my screen resolution, but it still was not readable. Because the image is so small, I really can't tell what I'm doing, so I don't know what steps to take to resolve the problem.

Have not seen this issue posted, so thought I'd better add it in case others have the same problem.

BTW, my reinstall of Game Manager did not help the Hero of the Kingdom game - still can't load and play that.
 
 
 posted in Hero of the Kingdom on Jun 14, 14 12:09 PM
Running on WIndows 8 computer, all game software reinstalled, other games are working OK (The Promised Land, 12 Labours of Hercules), but Hero of the Kingdom won't open - error message:

Error: Access violation at 0x03690D50 (tried to read from 0xFFFFFFFF), program terminated

Searched Internet for the error code, no results.

Update 06 July - got an email from BF tech, tried the fix, still no joy! But they sent me a coupon for a free game, and that as nice. Will update again if I find a solution.
 
 
 posted in Virtual Villagers: The Tree of Life on Mar 9, 14 8:45 AM
Ratu (male) aged 95, Master Scientist
Could not get him to Scholar; he had all Master skills except Parenting, and he fathered most of two generations (at least 12 children) plus had multiple teaching at preschool and storytelling.

Manaka (female) aged 89, Master Farmer
 
 
 posted in 7 Grand Steps on Dec 6, 13 7:10 PM
I bought the game and am enjoying it. It does require planning and strategy, but the storyline is interesting with a lot of depth. At the lower levels you're pretty much doing routine tasks; however when you reach the ruling level you make decisions that affect your position (and your future family position). There are life-changing events (signified by the owl appearing) that are something like Chance cards in Monopoly. You can lose status and drop back to a lower level, then have to build back up. At each level you must choose from one of three kinds of achievements - hero, inventor, or ruler - you collect tokens to complete them, and the results of completing them help you advance in the game. I've played a lot of hours, many generations, but still not clear on how to finish. Will probably keep going a while with the line I have; but may start a new line just to improve on my first few generations, now that I've got the learning curve behind me. Worthwhile game buy for those who like something different and a mental challenge. Not recommended for a casual time fill-in, quick-click, or those who like eye-candy. Graphics are pleasing and well rendered, but use muted earth-tones and there isn't much change to the board.

 
 
 posted in Meridian: Age of Invention on Mar 20, 13 8:14 PM
Just can't get these after many tries with different strategies, although I got Level 36 which many seem to have had trouble with (don't ask me what I did, I truly don't remember). Tried the forum fix for Level 39, it didn't work for me.

Agree with other fishes' frustration and would appreciate some real HINTS as the ones provided just don't do the job. Hello, developers?
 
 
 posted in Meridian: Age of Invention on Feb 24, 13 3:10 PM
BFG guys, I just have to ask, after reading all these posts under "Technical Issues": why do all your responses here say "contact Tech Support"? What is the point of posting under Technical Issues if that is the only reply? Are we Beta-fish?

Why are there no definitive answers given in this thread on the many problems identified by many users? I've played through the whole game, and I have five levels I can't get gold, and I have awards that don't display properly...just like many of the other fish.

Overall, I like the game (after I turned the music off), but I don't think I've ever seen so many disappointed fish in one place before. Somebody needs to clean the aquarium here!
 
 
 posted in Hero of the Kingdom on Jan 29, 13 9:23 AM
FINALLY found all 300 mushrooms, and it wasn't easy! Had to use a magnifying lens and search every scene for the last one (it was in the lumber camp, all by itself). Third time playing all the way through; delightful game, still enjoy the challenges, love the graphics, and the storyline. So unusual to have a PC game where you gain points by helping other people throughout. Liked having the choice to buy or barter for goods and tools; and you can always get more resources if you just think a bit. You CAN get it all!
 
 
 posted in Patchworkz™ on Dec 16, 12 5:39 PM
Downloaded Trial version and ran .exe file - fatal error shut down my PC running Windows 7. It came back up and game manager said it could not locate a .dll file, and that the program was either incompatible with x86 version or had a corrupt file. I uninstalled and downloaded again: same error, only this time my computer didn't crash. Too bad - it looks like a good game. I downloaded a time management game yesterday and have played it clear through twice...no problems. This is the first BFG game I've had any problem with, and I've purchased plenty - clearly a programming issue! Back to the Beta Test, guys. My default / firewall / permissions / versions are not the problem here.
 
 
 posted in The Treasures of Mystery Island: The Ghost Ship on Oct 16, 12 8:21 PM
Sorry to say I'm disappointed in this game. I have several others from the same publisher that I like very much; but after playing for a couple of hours I'm not enjoying this one. Graphics are gorgeous, storyline is interesting, the puzzles I've solved were nicely done. I like the Morph objects. But the FROG objects are MUCH too tiny and obscured by the background detail. They are also not to scale, and not shown with the same colors or from the same perspective as the "Find" objects - example: one "Find" shiny silver bowl is shown from above looking inside; but the actual object is dull gray and inverted over an outdoor lamp...so is viewed from the bottom! Transitions are poor; it is not at all clear where to go next. I've had up to four scenes at one time with partially completed "Finds", with no idea how to complete any of them. If it weren't for the Hint system I couldn't play at all. Mostly I just click all over the scene at anything and everything; when I get tired of that I click on Hint. This game has such good potential but the bottom line is...it just isn't much fun. I'll probably play through to the end once, but I won't be re-playing this game as I do with so many others. No more FROGs for me!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator