Posts created by Cultistmum

 
 
 posted in Agatha Christie: The ABC Murders on Sep 20, 17 11:58 AM
I'm having similar issues with the cursor (running Windows 7, 64 bit), and the cut scenes are running really jerkily and slowly, and even blacking out periodically. I dropped the video setting to low but it hasn't helped at all. I thought it was because my system is not on Windows 10 but clearly that isn't the issue here. Shame, I love Agatha Christie and this is one of my favourite novels, but this is really unplayable.
 
 
 posted in Spear of Destiny: The Final Journey on Apr 3, 17 2:13 PM
I did buy this game on the DD offer, and at that price I wasn't terribly disappointed. I would have been if I had paid full price. I agree it has a lot of content, you get a good few hours play from it. The story isn't too bad either. But while I don't mind flights of fantasy I like a game to have some sense in the puzzles. I don't want to spoil it but I can say that there are a lot of quests and puzzles which involve retrieving a series of items in order to retrieve a specific thing which absolutely could not have got where it is in the first place - or which could have but no-one in their right mind would put it there. A lot of puzzles have no information given about how to work them, others have too little. Too many depend on you randomly clicking things till you work out what order they have to be clicked in - no clues anywhere as to that order. Some objects in the HOGs are very small and there are a lot of dark corners for them to hide in. Also, the graphics are ok but the voice acting is terrible. I really did like the collectibles, though, the War Room stuff was really well thought out.
 
 
 posted in Moai II: Path to Another World on May 21, 15 3:14 PM
I'm having a problem with lagging, game slowing down and some very weird pixellation on the active spots like fields - and that's just level 2!



 
 
 posted in My Singing Monsters on Dec 15, 14 5:20 AM
I was chuffed to bits when I read that you could now exchange shards for diamonds, but can someone please make the exchange rate fairer? It takes 30000 shards to get ONE diamond, but 50 diamonds can be exchanged for 100 shards. Seems a bit too unbalanced to me.
 
 
 posted in My Singing Monsters on Oct 25, 14 9:04 AM
Well mine aren't - dressed up for Halloween, but no new tune.
 
 
 posted in Word Explorer on Sep 27, 14 9:29 AM
I enjoyed the actual word game and collecting the photos on my trip, but I have found as time went on that there are some issues with it. First of all, a cartoon plane periodically comes trundling slowly across the screen trailing a banner behind it, advertising 'bargains' which when I have clicked on it turn out to be opportunities to spend my real, actual money to buy extra stuff like hints, photos and so on. Not extra time, which would be useful as by Level 8 on the British trip the time runs out so fast you have no chance of completing the level on gold. I wouldn't actually buy anything anyway, as I don't care for that kind of sneaky 'not actually free to play at all' caper. But some way to boost your time allowance would be nice.

Also I have found words are misspelled occasionally, and there are words and names used which I have never come across before. For instance it seems 'uhmm' is a sound indicating you are thinking about something or unsure. Not in my vocabulary, it isn't. This also helps your time to vanish as you can't get a word quickly if it is misspelled or non-existent. So though this game is free to play I can see myself discarding it pretty soon, the frustration just isn't worth what fun it provides.
 
 
 posted in Moai: Build Your Dream on Sep 27, 14 9:16 AM
I had sussed the need to upgrade one farm early (but only one, or you don't have enough mana to upgrade the hut and rebuild the temple), but still no joy - they don't build that wall fast enough for me to get gold.
 
 
 posted in My Singing Monsters on Aug 18, 14 9:27 AM
I agree - I hadn't realised how hooked I was on this game till I couldn't play it. Thanks to the people who gave up their weekend so I could 'shoop lally-la' again!
 
 
 posted in My Singing Monsters on Aug 16, 14 6:28 AM
Well, here's yet another who didn't read the thread about the update causing crashes before updating Plant Island castle - and I was getting the Cold Island goal glitch as well. Anybody got any idea how long it will be before we can get back into the game?
 
 
 posted in My Singing Monsters on Aug 16, 14 6:24 AM
Yet another victim of the castle upgrade - spent the diamonds to upgrade my extravagant castle on Plant Island and when I clicked to collect the EPs the game crashed and I haven't been able to get it to run since. Any word on fixing this issue yet?
 
 
 posted in Home Sweet Home on Aug 15, 14 11:49 AM
I've had trouble with character freeze - I had two days left to finish a room, and all that was left was for one character to go to the trash but he wouldn't, even when I clicked off him to another character and then back. I lost that one because of this glitch, and it is rather irritating, especially when it appears to be a known issue.
 
 
 posted in Mah Jong Quest III: Balance of Life on Jun 6, 14 11:31 AM
I'm stuck on Time Tunnel and I can see I'm not alone; I did it before, this is my second run through the quest, but this time I can't seem to get through. And I've noticed that when I try certain paths I get an automatic popup when I have run out of moves, but on others there's no response, it just says 0 in the moves available box and clicking hint gets nothing. Anyone know what to do?
 
 
 posted in Mystery Case Files®: Fate's Carnival on May 10, 14 10:02 AM
have got all the scarabs and started the puzzle to enter Madam Fate's trailer but while I soon worked out I needed a second eye to progress I couldn't get it at all. I finally checked the walkthrough and learned I had done what should have released the eye (on the constellation screen after you join the dots on the polar bear) but no eye appeared. I got the one on the other side without problems, but can't go on without that one from the star chart. I reset three times but still no good.
 
 
 posted in My Singing Monsters on Jan 26, 14 11:11 AM
Does anybody know why the first upgrade to the castle on Water Island costs so much? I mean, 6 and a half million seems excessive to me. And are the following upgrades equally pricey?
 
 
 posted in Westward III: Gold Rush on Oct 13, 13 11:53 AM
I got the quest when I had two chicken ranches.
 
 
 posted in Adelantado Trilogy: Book Two on Jun 29, 13 5:20 AM
Yes, I'm keen to know too!
 
 
 posted in Greek Goddesses of Solitaire on Jun 25, 13 11:50 AM
I've been playing the free trial and I have to say I'm in two minds about buying the full version. First off, I like the actual card games, though I thought there could have been more information given about how each level was played rather than leaving it to the player to go to Help to find out. And Scorpion was a pretty hard type to have so early in the game. But I don't like playing the shell game in ANY game, let alone in a solitaire game format where I expect to be playing SOLITAIRE. And as for the 'help' from Hermes - after ten minutes I was ready to throttle everyone involved in putting that irritating thing into the game. It doesn't help, it just really, really distracts and annoys. Something that occasionally hoots, mews or coughs discreetly to remind you it's there as an option is fine; something that swings across the screen like a vineless Tarzan repeating the same lame lines over and over, is not.
 
 
 posted in Weird Park: Scary Tales on Apr 20, 13 12:20 PM
I had a problem in the library with the maze game where you have to guide the red ball through; at one point the ball needed to move one step left, it should have been able to go, and it couldn't progress without going there - but it wouldn't move in any direction except back the way it came, so the maze couldn't be completed. I had to skip that one to get past.
 
 
 posted in Dreamscape on Apr 2, 13 11:38 AM
I admit, some of my disappointment at this game was because when I say RPG I'm thinking Call of Cthulhu, Vampire the Masquerade etc - not Legend of Zelda. But that aside, I wasn't happy with this at all. I know there's a fad for retro, but I haven't seen a game of this type since about 1990. The graphics, controls, action and content remind of the old 80s point and click games that were cool back then but are lame when set next to the likes of Mysterious Island or Syberia. The music is dull, but at least you can shut that off. There is very little information given to get you into the game or system: I played the tutorial and wound up very little wiser for it. The clunky chunks of dialogue delivered in boxes slowed the pace to a crawl. And then I found myself fighting butterflies in sequences that had all the drama of watching my laundry rotate in the machine. Seriously, after thirty minutes of play I was so bored I uninstalled it. Obviously other people have enjoyed the game, but it really did nothing for me except annoy me.
 
 
 posted in Christmas Mahjong on Jan 8, 13 9:16 AM
There should be six locations - my version has six, I'm pretty sure. It must not have installed properly for you, I should try a remove and reinstall.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator