Posts created by Sablesshadow

 
 
 posted in Agatha Christie: Evil Under the Sun on Feb 6, 09 8:40 PM
queendee1 wrote:stuck in act 3 cant find what to do in cutters pub.


I think this is right:

After you see Tom Cutter's ghost, use shadow icon on it.

Go down stairs in pub. Look closely at wet foot prints on cellar floor.

Look at dart target on the brick wall.

Exit pub and go back to hotel.

Good luck
 
 
 posted in Dream Chronicles on Feb 6, 09 2:48 PM
robiin754 wrote:thank you, I did all that and It still will not let me do it.


Robin, Hope this helps:CHAPTER 7: 8 GEMS TO FIND

FROM LEFT TO RIGHT:


purple-third bookcase middle row left side


3 gems -on the floor around circle/ 2 purple/ 1 green


purple- third bookcase, top shelf by the crystal ball


purple third bookcase middle shelf


purple- first bookcase top shelf


green- floor by first bookcase right side

1. Pick up all 7 books and click into inventory

2. Put the books in the following empty spots in the bookcase:

* "The powers of winds" - Natural forces

* "Red Hot Tips from time in a volcano"- Travel

* "Water, the mysterious friend" - Water

* "Nostrapakus" Past, present and future

* "Plants, Flowers and Humans"- Plant

* "Studies of Rocks Unaffected by water" Geology

* "Dreams and their darker interpretations" Brain and Imagination

3. Click on the globe that is on top of the first bookshelf, once it's in inventory

click on the middle shelf of the second bookcase.

4. Drawer will open, take the crystal that comes out.

5. Once all the books have been put into place, a black book will appear on the first bookcase titled "magic" section, click on that

6. Place that book on the middle of the floor

7. Click the book to open it

8. Place the crystal inside of the book to charge it.

9. Take charged crystal out of the book and place it on the crystal ball to open the secret passage

If not, PM me and I'll take another look. Good luck
 
 
 posted in Dream Chronicles on Feb 6, 09 2:39 PM
wellcrap wrote:Just finished Dream Chronicles 2. Liked them both, but they were too short , IMHO. I like games that take more than an evening or two to beat. Some puzzles were a little tough, but not impossible. Some were far too easy. Great graphics and no bugs. I'll get 3 when it comes out to finish the story. I hope they make it longer.


This was probably one of the first games I tried. I know they're short, but I love the graphics, the story and the puzzles. Looking forward to DC3.
 
 
 posted in Dream Chronicles on Feb 6, 09 2:36 PM
MsHeineken wrote:I have collected all that was required. Please tell me what to do next. Every time I click on something I get nothing, what I'm I dong wrong. Please help!!!!!!!!!


MsHeineken - love the name.

Dream Chronicles and DC2 are my favorite games. Did you find 5 gems?

There are 5 rocks shaped like bricks in middle of screen. Arrange them from left to right: up, up, down, up, up, then you'll see the base of the statue appear.

You have to find the nine pieces to put statue together. Once you do that, you should be finished with this chapter.

If you have problems, or I haven't explained clearly, you can PM me. Good luck
 
 
 posted in Dream Chronicles: The Chosen Child on Feb 6, 09 11:24 AM
Yippee! My very favorite games were the Dream Chronicles. Can't wait to get my fins (appendages?) on number 3.

Yay, whoopee, wonderful, yahoo!

Gimmee, gimmee, gimmee!
 
 
 posted in Adventure Chronicles: The Search for Lost Treasure on Feb 3, 09 7:10 PM
lolrizzo wrote:****w do i set the whell , in the lost tomb, lost pharaohs treasure,,


Lolrizzo, set the outer wheel to the cow. Move the middle wheel til you see the jar. Small wheel should have oval-shaped symbol.

When you have the wheel correct, get blue gem from ceiling and put in middle of circle. The sarcophagus will open automatically after a few seconds.

Good luck and enjoy the game
 
 
 posted in Natalie Brooks: The Treasures of the Lost Kingdom on Feb 2, 09 4:46 AM
I think you have to root around the construction mess to find a chisel. Place the chisel on the pop-up window of the brick and the bricks will move aside and show you a combination lock. The man will say he has the key, then he'll drop it in the drain. Click on the drain close to his foot and use your chisel to remove the grate.

I think this is the answer. Good luck
 
 
 posted in Adventure Chronicles: The Search for Lost Treasure on Feb 2, 09 4:12 AM
Hi Blueeyes,

Can you be more specific about which game you're playing? It seems the word "Treasure" seems to be popping up in a lot of the games. If you can respond with the name of the game, and perhaps which Chapter you're in, I'm sure you'll get a good answer.

Good luck with the game
 
 
 posted in Book of Legends on Feb 1, 09 12:36 PM
Hi frenchbeatle,

One should be on bottom left corner - just a little above where the map is. One is beside first candle from left at the base of figure with snake on leg. One is to that some figure's LEFT shoulder. One should be on the brown base in the middle of the room.

Good luck
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Jan 31, 09 3:41 PM
Hi Smangy,

Go into the kitchen and click on the cabinet under the window. The shears should be there.

Good luck with the game.
 
 
 posted in Natalie Brooks: The Treasures of the Lost Kingdom on Jan 31, 09 1:25 PM
moaner1 wrote:Hi every one, I am stuck on the sundial, cut up the paper etc but cannot work out the rest even pressed hint and nothing happens, help please.
Hi moaner1, try the following: After you've finished with the fish, click on the sundial to get a bigger picture. Insert key from inventory into sundial. Click on sundial, you will see beams of light that end up at arch on right side. Click on the mechanism that is behind the tourist, on the right side of the wall. Grab the "part" from inventory and stick it in empty space. Click it a couple of time or until it locks in place. You will see a sun/star shaped piece. Click on the sun/star and it will go into inventory. Find letter behind the sun, click on letter. Grab the sun/star piece and place it on bottom of sundial stand, on the symbol. Now a new puzzle should open up for you.

Hope this helps, and good luck
 
 
 posted in Natalie Brooks: The Treasures of the Lost Kingdom on Jan 30, 09 7:58 PM
Moon38 wrote:How do I get what's his name out of the pit? Im pretty sure it has something to do with the skelelton guy on the wall but I can't figure out what Im supposed to do. And how do I get the sword out of the stone as well? Thanks
Hi, hope this answers the question for all three of you: Click on dry torches on lower right. click on bottle @ lower center. Put bottle from inventory on large plate on right side of page. Clock on plate on right - you w/b asked to find the four plates. After that, click on large picture in back right. Put clay plates from inventory in niches. Click on rope on lower right of scene. Place rope on pillar base on left side of scene. Click on niche on right side of door, click on the key and kerosene lamp inside. Kerosene lamp will break in two; put the torches to base of lamp so they can get kerosene. Put torches on side of entryway to temple. Click on altar on right side of ground and put key in keyhole - mini game will appear.

I think somewhere in all this nonsense, the sword comes free. Might have to pull on it at some point; don't remember.

Good luck and hope this helps.
 
 
 posted in Natalie Brooks: The Treasures of the Lost Kingdom on Jan 30, 09 7:16 PM
hotwoolf wrote:I can't figure out how to get the keys to disarm the security alarm. I have the fishing pole and magnet but everytime I try to get the keys it tells me I can't fo it with that-help


Hi hotwoolf,

As I remember the game, you need to do the following: after you get fishing rod together, click on drawer under telephones; drawer opens, click on panel above. Put screwdriver on panel & click wires inside (w/go to inventory) Click on drawer in pop-up window. Click on security system panel behind Grandfather and click on cover to remove. Put wires from inventory on "damaged screen." Click on airduct on lower right side . Grab screwdriver and put on bolts that are on grill. Click on grill to take cover off, then click on top right side to get to hatch. Place FISHING ROD on grill. Magnet mini game will appear.

Hope this helps, and good luck with the game.
 
 
 posted in Nancy Drew: Ghost Dogs of Moon Lake on Jan 28, 09 1:18 PM
I've gotten out of the burning shed, but by the time I get to the filled water bucket and back, the fire is a raging blaze.

Can anyone help? Thanks in advance.
 
 
 posted in Dangerous High School Girls on Jan 27, 09 1:24 PM
Purplerabbit wrote:At least you tried it, Gee.


Sorry to give you the wrong impression. I did download the game and demo'd it. I consider it to be mean-spirited and despicable. I'm not saying has these characteristics, but I think the game sure does. I don't care what the description chanages to, It's still mean-spirited and snarky!
 
 
 posted in Dangerous High School Girls on Jan 27, 09 8:41 AM
Poodlebear wrote:
ladycholla wrote: For another negative opinion, add mine to the list. If BF is in a hurry to offer a new game every day and can't do better than a bullies one, then skip a couple of days. We didn't used to always get one everyday and we can live without one like this.

My daughter was bullied in junior high and it's not funny. When they threatened her with bodily harm, I got involved and put a stop to it. That was done with the promise of a lawsuit, money out of dad's pockets, and she even had to have a school guard accompany her to and from school, until the girls were transferred to another school.

That's how bad it can be, scary, let's keep this site away from this kind of stuff and if you want these type of games, buy and or play from another location. I want my grandson someday to be able to play games here without worrying about it. One of the reasons I like BF so much is how clean the games have been without killing and ugliness.

This is a fun gaming site, without all the bad stuff from the other types of gaming hardware. rules right now in the way they handle games, CS and attitude, would hate to see any of it change. Please don't do this. Some of us older ones have seen too much ugly in life and don't need any of it here

This is where I start to have a problem. You are *absolutely* entitled to your opinion. You can express your opinion by not buying, by saying you are not interested, by ranting all you want BUT when you start saying it should not be offered because YOU think it is bad that goes beyond voicing opionion, that is asking for censorship.

I LIKE this game. I think it has value. I would have missed it had it not been offered. I benefit from it. I have just as much right to have it as you have to decline it. You make that choice. I make that choice. It is not right for you to ask that choice be taken away from me because it offends you.

I was fat, crippled and poor in a Rich Kids Prep School in High School. Think I was treated well? This game has nothing to do with that or anything remotely about the reality of bullying in High School. Sheesh!


I agree with Poodlebear that censorship is bad, but I think Ladycholla has a valid point that had been until now a premier site. I was horrified that the taunting, etc. was so appalling. I like to play games for the amusement factor. For me, it's just not an enjoyable game. has slipped.
 
 
 posted in Natalie Brooks: The Treasures of the Lost Kingdom on Jan 24, 09 7:35 PM
Lelemax28333,
I think you have to find some scissors under the chair to the left of the sundial and one other object (I forget which). After you find the scissors, cut up the note that keeps showing up. The pieces will scatter about the tower and you have to find them. When put together, I think they give you a clue. Good luck
 
 
 posted in Natalie Brooks: The Treasures of the Lost Kingdom on Jan 24, 09 11:17 AM
KaroTP27 wrote:I like this game but I have come to a spot where the game hangs up and I can go no further. It is in the train depot where I have to fix shut off the water, fix the pipes. After putting the rag in the bucket, getting the funnel and keys it hangs up and I have to get task manager to end the game. If I start the game again, it hangs up again but won't let me get to task manager so I have to reboot the pc. Can this bug be fixed?
 
 
 posted in Natalie Brooks: The Treasures of the Lost Kingdom on Jan 24, 09 10:35 AM
Tea93:
In order to get the rest of the stairs, use the oil can ON THE STAIRS, not on the lever which one would assume. Good luck!
 
 
 posted in Natalie Brooks: The Treasures of the Lost Kingdom on Jan 24, 09 10:34 AM
Tea93 wrote:Hi everyone!

I'm enjoying the game so far and think i will buy it too....

how do you get the stairs to come down inside Big Ben?

thanks
Tea
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator