Posts created by clannan

 
 
 posted in Grim Facade: Broken Sacrament Collector's Edition on Apr 25, 18 4:22 PM
I had the same problem with the clock. After I got the sapphire I slowly brought the hour hand down a little past nine and the slowly brought it back up a tiny bit. That opened a hidden panel. Must be a glitch. Very frustrating! Hope that helps.
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Mar 4, 15 5:00 PM
Same problem….been playing for awhile and really don't want to start over. Will the update fix the problem or do I have to start a new game?
 
 
 posted in Midnight Castle on Jan 23, 15 5:54 PM
Thanks! Have tried that but it never lets me connect. Thought maybe there was some way to do it from facebook directly.
 
 
 posted in Midnight Castle on Jan 23, 15 3:31 PM
Still cannot connect to facebook! Please, any suggestions??? I would hate to lose my progress and would really like some friends. Every time I try it says, "connection failed."
 
 
 posted in Midnight Castle on Nov 3, 14 6:43 PM
How do you sign in with facebook? Every time I try it says, "connection failed," even though I have a strong connection. Please help. I would like to make some friends and be able to participate in tournaments. Playing on iphone 4, but also have a mac and pc.
 
 
 posted in Midnight Castle on Oct 25, 14 12:44 PM
Would like to find some friends but cannot sign in via facebook! Everytime I try it says connection error. Any suggestions? (playing on iphone 4)
 
 
 posted in Dark Manor: A Hidden Object Mystery on Oct 11, 13 7:35 PM
Hey there. For the past couple of days I have been unable to retrieve any types of gifts. I am currently up to 88 gifts I cannot claim. Whenever I click on the message link and then try and claim a gift, it freezes up or kicks me out. Anyone else having this problem?
 
 
 posted in Nightmare Realm: In the End... Collector's Edition on May 20, 13 7:40 PM
Hey there. Is there any way to get a profile back? I was about 3/4 of the way through the game and i had to log out to check my mail. I went to play again and the create profile box came on and my old profile was gone along with all my progress. Grrrr...tried starting game again but no luck. Any chance of getting it back or is back to the starting board? Thanks.
 
 
 posted in Mystery Trackers: Four Aces Collector's Edition on Oct 14, 12 7:13 PM
anyarose wrote:I've had the same issue as other posters regarding the black screen and flickering animated portions. I just finished chatting with customer support, and apparently there is an issue with the game and my video card. I've accepted the refund, and sincerely hope the developer's engineer a fix.

Even more disconcerting that nothing has been posted about this specific issue in the forums by BFG. I had already uninstalled/reinstalled, updated my Mac, and updated Shockwave and Flash before seeking help. It would've been nice to avoid the frustration by simply being informed about the potential problem in advance.

It's a real shame knowing that BFG would put out a game for Macs that will not play properly on a fairly new (less than a year old) computer.


I'm having the same issues and my macbook is brand new. I've had it with a few other games too. I can't understand it as mac is only a couple of weeks old and running with the latest versions of everything. Right from the start I get a black screen and can hear the voices but no animations. When it asks for my name I type it but can't see it...grrrrr....so frustrating as I really want to play.
 
 
 posted in The Stroke of Midnight on Feb 4, 11 3:23 PM
Same here on my mac...quits as soon as I start it.
 
 
 posted in Mystery of Mortlake Mansion on Jan 19, 11 7:00 PM
Same problem...game takes forever to load, if it even does and then it starts and stops and I'm looking at a blank screen. Spent the whole demo just trying to get it to play. Playing on a macbook and never had an issue before. I have to assume it's a problem with the game itself. Hopefully they'll fix it.
 
 
 posted in Tamara the 13th on Jan 3, 11 6:20 PM
I'd like to think I am decent at playing hidden object games, but i had to use the hint button more times in the demo than I usually use in a whole game. I like a challenge but the objects in this game are so hidden it was just frustrating. Maybe it's my eyes.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator