Posts created by Blooming_Lilac

 posted in The Three Musketeers: Queen Anne's Diamonds on Jul 17, 17 7:39 PM
Hi! You have to watch your opponent. When you see them start to sweat, click on them and your character will automatically jab them, doing considerable damage. Make sure to have plenty of ointment on hand. I usually buy 6 or 7 and keep an eye on my health bar in the top left corner. Just click on the ointment when you get wounded.

Buy the best weapons you can afford. When you hover over any item you can equip, you'll see green bars beside your stats in the top right if the item is better than what you already have equipped. You can equip any item by placing your cursor over it. You'll have the option to equip the item or drop it.

Hope that helps!
 posted in Finders on Mar 25, 17 10:43 AM
I forgot to mention that you have to click the dollar sign above the tents to collect the money.
 posted in Finders on Mar 25, 17 10:41 AM
The tents provide income, and you can upgrade them for more cash. You can also sell items from your storage. Click the button with the price on it. It's the second button below the item. The Use button is for refilling your food supply or using bonus items such as tea and soup.
 posted in Dragon Keeper 2 on Jan 25, 17 8:42 AM
I went back and deleted all five profiles and started a new game. I've just been able to finish my game without it freezing. This game is frustrating, but fun at the same time. The black dragon egg was in the 4th cave. Hopefully you'll see this post and try again with a new profile. Good luck!
 posted in Dragon Keeper 2 on Jan 23, 17 11:42 AM
Hi. Are you in the 3rd or 4th cave? I can't remember which cave the black dragon's in. It's been a while. My game's freezing on me in the 3rd cave today.

The dragon egg you found is uncovered by the imp in the upper left part of the cave. If a dragon is killed, it starts off as an egg the following day. In your case, rebooting probably restarted the day you were playing.

I'm having to quit the game via task manager. It looks like I'm not going to be able to play this game anymore. I'm going to try deleting all my profiles and starting a new game, but I think I'll play something else for now. The first game isn't as problematic as this one for me.

I hope you're able to get your game running. Reinstalling hasn't helped me so far. Happy gaming!
 posted in Farm Craft on Jul 25, 16 6:18 AM
Did you try to pick up the piglets with a crate? You have to use crates for the animal products. Hope this helps.
 posted in Dragon Keeper on Jul 21, 16 6:22 PM
Hi! Did you try clicking in the middle of the box? I had to do that today because it wouldn't allow me to type my name. Clicking in the center of the box should place your cursor there, although you may not see anything until you start typing. I've had quite a few glitches in my game today. Good luck!
I'm playing this game on another site. On the first few levels, there are some crystals and other obstacles left over even when I've revived all trees, completed with 3 stars, and found all H0S/puzzle pieces. Is this normal? The levels seem incomplete to me.

On one level, there are two purple crystals remaining which require 10 gold each to remove, but the gold mine gives one gold at a time. I don't see a way to get 3 stars if I wait around for the gold to replenish. Also, some of the scene doesn't turn green when I've watered all trees and completed objectives. Maybe I'm just too particular, but I don't like having partially revived land left over.

Thanks in advance for any replies.
 posted in Build-a-Lot: Mysteries 2 on May 27, 16 3:36 PM
I'd also love a Christmas theme for this series! I bought BAL: Mysteries over 2 years ago, but I didn't play it all the way through. Building games have never really held my interest until the last few days. I just bought the super pack on another site so I can switch back and forth between them. BAL: Fairy Tales is one of my favorites. It's such an enchanting game! Another fairy tale theme would be fun, too.
 posted in Build-a-Lot: Mysteries 2 on May 27, 16 3:06 PM
Hi! Try building two mausoleums and placing one of them near a house on the right (second row with two lots). Build houses in the zoned lots so that you can place structures along the bottom.

My memory's a little foggy, but I believe this was my strategy:

You start with 1800 materials, if I recall correctly. Try building a farmhouse and a manor in the zoned lots first. I sold the farmhouse and bought it back at the end of the level, then demolished it to build a mansion to sell. I had the 3 required mansions fully upgraded with lights, and on the right (in the second row), I had one of my structures (or a mausoleum) and a colonial with lights.

I tried more than once to get a ribbon on this level. My game closed while I was typing this reply. I'll check the level and edit if I made a mistake. I had the workshop so I could hire more workers, but I didn't use efficiency training so I'd have enough money to buy the farmhouse I built at the beginning. Hope that helps.
 posted in Aveyond 4: Shadow of the Mist on Feb 5, 16 9:43 PM
No, I don't think so. That's his specialty (stealing), along with biting, and he takes no damage because he's a minion. The cheese is really handy for healing. I'm enjoying this game thus far.
 posted in Aveyond 4: Shadow of the Mist on Feb 5, 16 2:03 PM
I wasn't able to figure out whether or not I needed access to those pumpkins, so I just moved on to the quest for Ingrid, hoping that I'd be able to get to them later. If anyone else knows how to get past the guard, please post here. Thanks in advance.
 posted in Aveyond 4: Shadow of the Mist on Feb 4, 16 10:35 AM
rosybaby8 wrote:I have tried to find my way out of first town you have to find tickets and i still cannot find them all to buy a gergoyle if you find anything let me know haven,t got an answer from the forum,

(Highlight to read spoiler.)

You have to smash some pumpkins to collect the rest of the tickets
Hi! I just played that level. You have to saw lumber for the two workbenches near the counter plus the two extra pieces of furniture beside the lumber piles, and chop wood on the block to complete that challenge. I believe the block holds up to six pieces of chopped wood. Hope that helps.
 posted in Westward IV: All Aboard on Dec 3, 15 3:37 AM
Thank you for replying! I don't log in here very often, so I didn't know you had. I'll try that. Thanks again! I'm going to start a new game now as it's been a while since I played.
 posted in Westward IV: All Aboard on Oct 1, 15 2:52 AM
I've destroyed countless trees, but I still can't find the treasure chest. I already got the key, and after a while, I moved the rat up by the train station. To make matters worse, a bandit came and killed him, so I probably won't be able to complete the quest.

The earthquakes and fires are about to drive me nuts. My town has 45 people, and I've played for hours. At this point, I don't want to start a new game just to get all the trophies. I'm playing as Henry, if that helps.

Can anyone tell me where it should be? I've already checked more than one walkthrough. I'm going to play something else in the meantime. Thanks in advance.
 posted in Wandering Willows on Aug 18, 15 5:51 PM
Wow, that's so strange! I bought WW a while back, too, and I've been playing it today. I'm downloading Gemini Lost to see if it works for me. Hope you get it worked out with CS. I'm going to watch this thread to see if you're missing any other games I may own as well. Best wishes!

P.S. I'll be contacting CS because I'm also having trouble downloading Gemini Lost. Hmmm...
 posted in The Island: Castaway 2 on Jul 26, 15 11:37 PM
If I'm not mistaken, I just found it in the Ancestors Wood. I was collecting Ancestors Flowers when I saw it. Hope this helps. I just exited the game, but sometimes I can get names mixed up. Good luck!
 posted in Delicious: Emily's Home Sweet Home Collector's Edition on Jun 28, 15 6:33 PM
badgerfann wrote:
Blooming_Lilac wrote:Oh, I hope the developers release a patch so you can play. It's a great game. I have all the others except Honeymoon Cruise. Not sure if I'm going to buy this one if I run into any trouble like you've experienced.

I can still play them...just need to wait until I am several levels past where they appear.

Yeah, I hope it's fixed so that you can play it without issues.

FairyonPegasus wrote:I have played it with several combinations of flowers and always get over 1400 and no diamond. So it definitely has to be a glitch.

Edit: BTW I've also tried it on different levels of difficulty as well.

My apologies for not using the quote function. I was trying to help Lizoz, as well, by suggesting the easy mode for this level.

Lizoz wrote:I can't even get this level, not even there a trick to it?...I'm about to give up on it. Anyone have any advice it will be very much appreciated.

 posted in Delicious: Emily's Home Sweet Home Collector's Edition on Jun 28, 15 11:36 AM
Oh, I hope the developers release a patch so you can play. It's a great game. I have all the others except Honeymoon Cruise. Not sure if I'm going to buy this one if I run into any trouble like you've experienced.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator