Posts created by TheMastercat

 
 
 posted in Rooms of Memory on Nov 3, 17 2:30 PM
I have hurt my wrist badly and will be off this game for some time. If you delete me I will not be upset but I do acknowledge so many of you that have helped me so much in this game. Thank you.
 
 
 posted in Rooms of Memory on Feb 11, 15 7:06 PM
Can't get mine to load at all. I keep getting the error message that " it is timing out". Cannot figure out why it should.
 
 
 posted in Bush Whacker 2 - Free to Play on Sep 12, 13 5:50 PM
Are we allowed to buy more than one of these deals?
 
 
 posted in The Fool on Apr 4, 12 1:52 PM
Am I the only one who put the seed in the Princess's pot and the quick grow to have the seed not grow into anything? How long am I supposed to wait? Do I redownload the game or start with another name to play the game? Or ???
 
 
 posted in Fix-It-Up: World Tour on Feb 8, 12 2:08 PM
Did anyone else have problems with the first Mexico part? When it came to the greening of autos it seems there the counter just does not count. I had over 50 greened autos and it still did not register the 5.
??
 
 
 posted in Farm Tribe on Nov 17, 11 1:39 PM
I bought this game last year and was very pleasantly surprised at how much detail there was to the game. Thoroughly enjoyed every part of it. It is not just a simple plant and sell produce game. Try it - I would be very surprised if you did not have trouble stop playing it
 
 
 posted in Skymist - The Lost Spirit Stones on Sep 20, 11 7:41 PM
I have never tried this game before but the demo would not let me play it because it says my time is up. Wonder whether I would have liked it. ??
 
 
 posted in Murder Island: Secret of Tantalus on Sep 7, 11 7:01 PM
BFG you always say to try demo before buying but if it won't let you play the demo what do you do? I have NEVER played this game before - I am sure of that but after downloading and trying to play it says time expired??? Anyone else have this problem??
 
 
 posted in Special Enquiry Detail: The Hand that Feeds on Jul 22, 11 6:43 PM
I can't get past the first crime scene. The hint button flashes like crazy. Can go only so far and the game keeps crashing. I do not need my video drivers updated or flash or anything else. There is something seriously wrong with this game!
 
 
 posted in The Tiny Bang Story on Jun 3, 11 1:46 PM
Refrenz wrote:Chapter 2 - collecting 24 balls. The game thinks there is one left to collect but there isn't (I've checked the locations listed in another part of the forum). The hint button does not work anywhere which also indicates there is nothing else to collect (it is fully charged), yet the game thinks I still need to find one more ball.

Result - game broken, can't progress. Can't be arsed to start again. Very annoyed. >:-(


I am having the exact same problem you are. I got the ball from the ship and don't think the game would have let me have that one ( with the triangle inside it) unless it also though I had already got all the balls.
 
 
 posted in The Heritage on May 21, 11 7:40 PM
Is Chapter 20 the end of the game? I finish the green area and the area above it with the angel? and unlock the door to move on and the game keeps restarting from there. Is that what it is supposed to do? Funny ending if it is.
 
 
 posted in Drawn: Dark Flight ® on May 9, 11 1:31 PM
Is anyone else having problems with the net? I have captured some objects with it but cannot catch the butterfly. Played the game and stopped for awhile. Cannot remember whether the things I did catch were in the picture or the four season display?? Any and all help appreciated. HELP!!!
Love the innovative game style.
 
 
 posted in Jack of All Tribes on Feb 21, 11 1:43 PM
A quick answer to your problem with this lv. The upper left cottage has to have the statue in the FRONT activated to be accepted as fully activated to 3 star. Build the bottom cottage last to avoid some of the nuisance of the ogre.
 
 
 posted in Cassandra's Journey 2: The Fifth Sun of Nostradamus on Jan 8, 11 6:17 PM
I thought I was not going to be able to play the game either but after waiting a very, very long time it finally loaded and then I could play it. After that, I found it took forever to load each new scene. Going to uninstall and redownload and hope that fixes the problem. Really liked the first game.
 
 
For those of us that tried the beta edition of this game with the survey attached, can someone tell me if we can buy and continue from where we left off?
 
 
 posted in My Kingdom for the Princess II on Nov 3, 10 3:20 PM
Love time management/puzzle/stratedgy games but this one is just about making me lose all my hair. WALKTHROUGH PLEASE!!!!! And oh so nice of you to offer to do this. Please let this person do it BF, PLEASE
 
 
 posted in Ice Blast on Sep 1, 10 5:11 PM
Do not care for games that want to write directly to my hard drive. That can be dangerous. I'll pass on this one.
 
 
 posted in Route 66 on Aug 28, 10 5:42 PM
It sounded interesting but when you only get to Needles and you keep hitting the flowers but the game does not recognize their own object it is pretty bad. Used a hint twice and was hitting the right place. Too bad the game did not register it. lol
 
 
 posted in Lost Secrets: Bermuda Triangle on Aug 23, 10 1:51 PM
Found this to be a very relaxing HOG and although the dialog was over long, thought I would buy it. After buying it, it started me from the very beginning. Didn't enjoy it that much.
 
 
 posted in Flower Shop - Big City Break on Aug 11, 10 10:39 PM
Although initially I had problems with this game also, I was able to get it to work by doing the following: I upgraded by video driver BUT I also had to delete my old video driver to make the game work. Hope this helps and if you have a different driver than me (Nvidia) perhaps you should check with your video driver website first for instructions.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator