Posts created by curlly62

 
 
I can't play the game due to "Access violation"....tried all the normal fixes and still can't play it....not happy about this...........
 
 
What would you say are your three favorite in this series and the three you like the least?

I also love this series, but I don't own all of them.

Also, I enjoy your reviews when I am making decisions on purchasing games.
Thank you
 
 
 posted in The Secret Order: Bloodline Collector's Edition on Jun 17, 17 8:13 AM
My operating system is Windows 10, 64 bit.....
 
 
 posted in The Secret Order: Bloodline Collector's Edition on Jun 17, 17 7:37 AM
I am getting the same error message when I try to open the game. I have loaded and unloaded it twice and still can't play it.
 
 
 posted in The Adventures of Perseus on Jun 9, 17 4:59 AM
What is up with this level? It's absolutely ridiculous. If anybody has gotten past this level, please tell us HOW??????
I am so angry with this game. I love playing this game, but am wishing now that I hadn't purchased because of this level. It's just not fair that I am not even half way through the game and cannot advance.

I feel like I wasted my money and that makes me very angry.
If you are going to make a level so difficult, you should atleast offer the option to skip the level.

HELP......
 
 
 posted in Mystery Tales: The Twilight World Collector's Edition on Feb 2, 15 12:05 PM
I cannot get the SKIP option to work for any of the puzzles. No matter where I put the cursor or which cursor I use, it doesn't work.

Does anybody else have this problem?
 
 
 posted in Monument Builders: Cathedral Rising on Jan 31, 15 5:57 PM
I have uninstalled and reinstalled this game twice and never get a screen with an option for game mode (i.e relaxed, timed) also, when I start playing, no screen pops up asking me to choose for specialized workers, faster production or auto transport. It shows the rubies at the top of the page, but it never lets me choose to use them because it never shows the pop up screen.

I have never had this problem with any of the Monument Builders games and I own all of them.

I will be very disappointed if this problem cannot be resolved.
 
 
 posted in Mystery Tales: The Twilight World Collector's Edition on Jan 24, 15 9:39 AM
Looks like a great game, BUT nothing seems to work right. Cannot pull up the strategy guide and the SKIP feature doesn't work. I really hope this problems can be fixed. I would love to play this game. But for now, I will uninstall it. I just got my hard drive "cleaned up" and I don't need a game to "dirty" it up again.
 
 
 posted in The Musketeers: Victoria's Quest on Jan 18, 15 9:09 AM
I can't even get the game to finish loading to play. It freezes up right after it shows the developer name on the screen.

Love TM games, but I guess I may not even get to try this one out.
 
 
 posted in Rescue Team 4 on Nov 26, 14 9:45 AM
I was stuck on that one too and I finally figured out you have to "turn off" the generator so it doesn't use up all of your fuel. I turned it on and as soon as I saw the plane coming in, I turned it off. You pick up a few rescues at a time. Make three different landings, turning the generator on and off each time to save your fuel.

Now I am stuck on level 58...this game is driving me crazy....!!!!!!
 
 
 posted in The Tiny Tale on Jun 13, 14 11:34 AM
Can you please tell me how to complete level 33? Have tried over and over. Cannot get the amount of gold required to complete it no matter what I do.

PLEASE HELP!!!!!!!!
 
 
 posted in The Tiny Tale on Jun 12, 14 9:40 PM
Please help!!!!! I have tried and tried to get through level 33. Cannot collect enough gold no matter what I do or don't do. Cannot figure out how to come up with the correct amount. I have tried not building the houses or any of the buildings. Just collecting the gold without spending any of it, still does not give you the correct amount.

Can someone please, please tell me how to get through Level 33?????

I really love this game, but am getting very frustrated to get this far and not be able to continue.

Thank you
 
 
 posted in Christmas Stories: A Christmas Carol on Dec 22, 13 12:52 PM
Have been trying to get the tiny tim amulet's limbs into the right position. No matter where or how I position them, nothing seems to work. Has anybody else had this same problem? And if so, do you have any suggestions?
 
 
 posted in Viking Saga on Jun 18, 13 2:46 PM
I am really enjoying this game...have gotten to the levels with all the snow and it is very frustrating, trying to keep the fires lit so the houses keep producing silver. Taking me forever to get through this level. Could really use a walkthrough. Any idea when there might be one available??
 
 
 posted in Namariel Legends: Iron Lord on Jun 16, 13 7:55 AM
I really like this game, but unfortunately while playing the trial game, it keeps locking up on me and then get a blank screen. And if I try to go back and play again, it starts all over and then does the same thing. I am hoping BFG gets an update to this game so maybe I can purchase. I was having a blast playing this game.
 
 
 posted in Princess Isabella: Return of the Curse on Jun 3, 13 12:11 AM
Can someone please, please tell me how to solve the puzzle that you have to change all the colors to one color in less than 25. I have tried and tried. I went to the walkthrough (which is the WORST walkthrough I have ever seen). I am about to just delete this game and forget about it. One of the most frustrating games I have ever played other than Green Moon (never did finish that one).

PLEASE GIVE ME THE ANSWER!!!!!!!!!!

Thank you
 
 
 posted in Bluebeard's Castle on Nov 24, 11 7:32 AM
like the game....but scenes load way, way too slow....wish I had not wasted the $$ on this one...........
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator