Posts created by rebahanna

 posted in Gnomes Garden 2 on Dec 30, 15 2:27 PM
Me too. I've tried 4 times but can't make the 3 stars on this one. Anyone have any suggestions?
Ok, got it:

* # of banners: XIII
* Times the number XI appears: III (the claw slash)
* The Thieves Guild symbol: the door knocker
* Head & tail, no body: Coin
* Grows when eats, dies when drinks: Fire
I must be doing something wrong. I can't get past the doorman. Every question he asks I've answered with literally every symbol on that door, but he just keeps asking the same ones over and over. The guide says the answers are random (no help). I really don't like to skip a mini game, but this one is driving me crazy!
 posted in Mystika 2: The Sanctuary on Jul 4, 15 4:34 PM
Twinkerbell26 wrote:I got this game the other day, it was playing fine that day, but now today (Friday, 5/16/2014) the game will not open on my PC. When trying to open I am getting a few small "alert" boxes, not sure of what they all say, there are 23 such boxes, but the gist is " 'X' is not found".
I tried uninstalling and re-installing before coming here. I just wanted to see if anyone else is having an issue.

Same thing. I downloaded it, bought it, played it a couple of times, now I can't get back into it. About 20 alert boxes pop up "Image not found: _____". I've uninstalled and reinstalled. Still won't work.
 posted in Dreampath: The Two Kingdoms on Jan 18, 15 4:24 PM
Great Game.

I bought this game on "all games half off" day. I scored. You get a whole lot of fun for just a few bucks. I normally don't buy hidden object games anymore because they are pretty much all the same, but I really enjoyed this one. The graphics were great, the story was beautiful, and I'm a sucker for cats. Did anyone notice that the kitty sound bytes were the same ones from the Super Granny games? Cute.
 posted in Crafting Story on Jan 17, 15 2:25 PM
When none of the buttons are marked, how do you know that you're selecting "start this level over" or "next"? I was only able to get through the first level by following all of the spoiler alerts (I didn't have the patience to methodically select every single combo there could possibly be). Apparently this is not the game for me.

Hmm. Who knew sand and metal mixed together make gold.
 posted in Crafting Story on Jan 17, 15 1:35 PM
Wow, not one good review? Now I'll have to try it to see what all the fuss is about.
 posted in Happy Empire on Dec 9, 14 10:23 PM
Probably great for super beginners (little kids), but way too easy for even mid-level Time-Management gamers. No challenge at all. Not even close. Finished the whole thing within an hour.
 posted in The Tiny Tale on Oct 7, 13 6:55 PM
Ok, I think I've got it. As soon as you hear the first set of spiders coming, send your ogre to cast the Mother Nature Aid Spell, then send him to kill all 3. Now, as soon as the second set start coming DON'T send him after them. Wait until the spell tree starts sparkling, then send him directly to cast the spell again. It'll be close, but that will stop them before they can reach the tree house, then the ogre can kill them.
Hope that helps...
 posted in The Tiny Tale on Oct 7, 13 6:54 PM
I've beat the developer's time on 6 different levels so far. There are a few of them that are easy to do that on - others, I cannot figure out how on earth you could!

Now I'm stuck on level 23; can't seem to get the key to beating it within expert time. Anyone have any ideas? That second set of spiders keeps getting me. Drat!
 posted in The Snow on Aug 31, 13 1:23 PM
The same problem for me: frozen cursor from the beginning. Had to give up on this one. Every once in awhile BFG comes out with a game that I just can't play. I've been an exclusive customer for 6 years now and love BFG, but if I can get this game on a different sight, I guess I'll try.
 posted in Farm Up on May 20, 13 12:45 PM
The same thing happened to me. I spent at least $12-$15 on this game, and now it's all gone, won't let me continue. I want my money back.
 posted in Gardens Inc.: From Rakes to Riches on Mar 25, 13 2:18 PM
Thanks a bunch. That helps me out a lot!
 posted in Gardens Inc.: From Rakes to Riches on Mar 24, 13 6:34 PM
Can anyone explain to me what these cryptic bonus hints mean? There must be a pattern, you know, like when it says "3,6,9,12"? I know it's talking about the flowers & what colors to plant, but I can't figure out the pattern. And what type of reward do you get? I thought that if you got it right, the flowers would pop up fully grown, no watering necessary. Am I right?
 posted in Dragon Crossroads on Dec 20, 12 4:44 AM
Yeah, I got to Level 43, the game stalled when the guys where digging a hole, so I started the level over. Now I can't even get the little guys to start the first task (I clicked on the food, it shows the green check mark on it but no workers are coming out). I'm so frustrated!
 posted in Ashes of Immortality on Nov 10, 12 6:11 PM
Yeah, I'm having a tough time with the big group, too. I can't keep them from paralyzing my party. Does anyone have any suggestions? Please?!
 posted in Ashes of Immortality on Nov 7, 12 4:36 AM
Thanks. I'm gettin' it.
 posted in Ashes of Immortality on Nov 7, 12 1:41 AM
I've got Orlok in my party now. What am I supposed to do? I'm just wandering around aimlessly...... Help?
 posted in Alchemy Mysteries: Prague Legends on Sep 10, 12 8:18 AM
Has anyone figured this one out yet? Plus, what's up with how to move the light sticks? It seems hit & miss when I can finally get the beam to move in the direction I want it to go. Help!
 posted in Inbetween Land on Aug 27, 12 12:12 AM
I have a brand new laptop. I get the "error" message when trying to open it. They need to fix the problem. I NEVER get this message on any other Big Fish game.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator