Posts created by Sablesshadow

 
 
 posted in Natalie Brooks: The Treasures of the Lost Kingdom on Jan 24, 09 10:27 AM
Robilyn:

You need the crowbar to break the barrier in front of the train. Use the brick to smash the window, use the rag because you don't want to cut yourself, and then I think you find the keys to open the locked locker. Inside is a crowbar, I believe, which you can use on the chain that hold the barrier in front of the train. Good luck and I hope my info is correct
 
 
 posted in Natalie Brooks: The Treasures of the Lost Kingdom on Jan 23, 09 6:07 PM
I've had the same problem, but only after I purchased the game. I'm now stuck in the Pisa Tower and am frozen there. Guess I'll try uninstalling and reinstalling. Grrrrrrr.
 
 
 posted in Nancy Drew: Ghost Dogs of Moon Lake on Jan 22, 09 3:48 PM
Timekeeper,

I messed up my public post to you. I'm in the same forest, with the map, which I can't understand. I hope you have a solution. Hope to get out of the forest before it starts getting farmed lol.
 
 
 posted in Nancy Drew: Ghost Dogs of Moon Lake on Jan 22, 09 3:41 PM
timekeeper wrote:I have the map of the woods but I dont understand how to follow it.For example the walkthrough I have says go into the woods and a couple of clicks will take you to the stump with the piece of wood you need on top.I did that and as they said it was there,but when I checked the map the stump was over by the cemetary I really tried to follow directions but now I am totally stuck because if I manage to get myself out of the woods I cant get to the cemetary where the other piece of wood I need is.

Timekeeper
 
 
 posted in Sherlock Holmes: The Mystery of the Persian Carpet on Jan 19, 09 3:17 PM
I've looked at the walkthroughs for this game, but can't find any to help solve the deduction table in Level 3. I have absolutely no idea how to get out of the deduction table. Can anyone help? I see there not many forum discussions about this particular game. Is it because it's just so frustrating? Should I ask for my money back? I've had to reinstall the game twice. If I could just get some direction regarding the deduction table I think I'd be (relatively) happy with the game.
 
 
 posted in Hidden Expedition: Amazon ™ on Jan 12, 09 1:28 PM
ceomom wrote:I give up. I have no inventory, but all 5 items to find that are blue. They are the rocket, comb,whisk broom, spade. Then there is the #2 gear as well. What is with the rope that the arrow turns blue at in the gear room? No inventory to use.I have all the animals lit except the whale. I have been all over the map and I can see the comb, spade, in a different room. Not in the room where they appear.
I started the game again and now I am stuck there as well. I can't find the page to the manuscript as everything else is found but the one that is hidden. This one is the second part in after the office.

I like hard puzzles but this is ridicules. I have been playing this one on and off for months. I think I will just delete it and stop torturing myself.

Sandi


Sandi, the items in blue (rocket, comb, whisk, broom, spade) are behind the wall in the picture with the gears. Once you get the gears working correctly (all turning) the wall will disappear and you will find the missing blue items. Also, look on gamezebo for hints. It's terrific! Good luck
 
 
 posted in Adventure Chronicles: The Search for Lost Treasure on Jan 8, 09 1:26 PM
Thank you so much, plrpldva. I used LizzieK's information and it worked like a charm!
 
 
 posted in Azada ™: Ancient Magic on Jan 8, 09 11:39 AM
Thank you, LizzieK. I went back to the four cards and found the last one on the young boy's left shoulder. Thanks for your help.
 
 
 posted in Azada ™: Ancient Magic on Jan 7, 09 5:03 PM
Help! After the Vampire Book, I got to the part where you have to find 10 symbols on the four cards, using the blue and purple magnifying glasses. I've looked until my eyes blurred, but I can come up with only 9 symbols. The page says I'm missing one, but I cannot find it anywhere. Has anyone else had this problem? I'd really appreciate an solution. Is there maybe a workaround without losing a hint, which I really need to keep.
 
 
 posted in Adventure Chronicles: The Search for Lost Treasure on Jan 6, 09 7:15 PM
Help, I'm lost trying to get the sand to descend through the maze. Can anyone help? Thanks in advance.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator