Posts created by leslie5270

 
 
 posted in Maestro: Dark Talent Collector's Edition on Sep 15, 14 11:35 AM
Thank you so much! I've gotten it figured out now. I'm pretty much moving right along.

Do you have a twin? Perhaps "Severus"
 
 
 posted in Maestro: Dark Talent Collector's Edition on Sep 14, 14 5:57 PM
I collected two sets of jewels to be used in the medallion for it's first use. They were listed 2/2 in the inventory in the same box. I clicked on them, held them over the medallion and the jewels seemed all to be used. The medallion did not light up. After clicking on the top part of the medallion a rear section opened out and there were to have been jewels put in there, too. The problem is that both sets of jewels seem to have been used for the front of the medallion. The medallion didn't light up and there doesn't seem to be any way to get the jewels that should have gone in the rear section. Can anyone help me with this?
 
 
 posted in Spirit of Revenge: Cursed Castle Collector's Edition on Aug 16, 14 4:15 PM
It's important to know that you have to left click on your keyboard while you're pulling on the rope, and you have to pull a few times. If you don't left click, the gauntlet won't grab the noose.
 
 
I've gotten almost all the way through the puzzle and am at the part where it's sending me all over the place to put clock hands on the clocks. The problem is that I don't have any clock hands. Where was I supposed to find them? I didn't see anything like them at the clock areas themselves.
 
 
 posted in Final Cut: Homage Collector's Edition on Apr 20, 14 9:16 PM
I found the way to get in and find the fifth piece.
 
 
 posted in Final Cut: Homage Collector's Edition on Apr 19, 14 9:00 AM
I have 4 of 5 pieces of the golden reel that opens the director's door in the cafeteria scene. I've looked everywhere according to the Guide and every place a piece may have been is locked now and I can't get to the possible spot. Can anyone help me find the piece? Is there any way to get into locked areas, for instance the trailer outside the studio? Thanks!
 
 
 posted in Maestro: Notes of Life Collector's Edition on Mar 20, 14 9:46 AM
I'm sorry. I thought both the pulley and the cable were needed, but only the cable was used. Thanks anyway!
 
 
 posted in Maestro: Notes of Life Collector's Edition on Mar 20, 14 9:29 AM
How can I put the cable on the pulley in the workshop? I've tried putting it on the spindle, and eventually every place on the lathe, but it keeps going back to the inventory. It's frustrating!
 
 
 posted in Mystery Trackers: Silent Hollow Collector's Edition on Jul 19, 13 7:59 PM
Thank you, gingergal. I think I'm on the right track now.
 
 
 posted in Mystery Trackers: Silent Hollow Collector's Edition on Jul 19, 13 9:46 AM
I've just started playing the demo. and the Strategy Guide has told me to pick up the jacket and the zipper pull on the floor ofthe bar. I had already gotten the zipper pull, but when I went back for the jacket and clicked on it no activity square appeared and I couldn't pick up the jacket. Any ideas? Thank you!
 
 
 posted in Living Legends: Frozen Beauty Collector's Edition on Jun 30, 13 12:17 PM
Thank you elijah5. I had thought it was enough to have the right time order. I looked at the Strategy Guide and just didn't realize that their line set up wasn't random and you needed to do more than put the objects in chronological order. I tried what you suggested and it worked just fine. I'm going to go finish the Bonus game now.
 
 
 posted in Living Legends: Frozen Beauty Collector's Edition on Jun 29, 13 2:43 PM
In order to get through a gate in the frozen castle courtyard I had to put four buttons on the "lock" and arrange them in chronological order. I did that correctly and then put the gear on the gate mechanism and pulled the lever. The game said that I had to "take care of the lock" first. I can't go any further and I need help! What do I need to do?
 
 
 posted in Living Legends: Frozen Beauty Collector's Edition on Jun 29, 13 9:38 AM
The set up for the game, play levels, etc. has already been done, so I'll just talk about whether I liked it or not. I really enjoyed this one. I don't need complicated games with mind bender puzzles all the time. This game is pretty easy but you have to pay attention. I missed a token at one point and had to go back several steps to find it.
The story is pretty bland and much like many other stories in this genre, that's true.
The graphics, however, are fantastic and extremely imaginative. I'll play the game again just to see those. I agree that the HOS are just junk piles and a little hazy. Also, some of the objects look nothing like their descriptions and are very hard to find. I found a few by clicking on something I thought was something else entirely.
I enjoyed the puzzles, mostly easy and common, but one that uses a stage device is very well done. All in all I think this is a fun HOG and I'd recommend it to anyone who is looking for a beautiful and detailed puzzle that is pleasant, fairly easy and fun to while away a quiet afternoon (or two).
 
 
 posted in Living Legends: Frozen Beauty Collector's Edition on Jun 27, 13 8:27 AM
I'm supposed to take the mirror shard from the hand of the statue early on in the story (after going straight up the stairs from the shore), but there is no shard there to take. Am I missing a step somehow? There's no point in continuing without a part, please help. Thanks!
 
 
Ive just finished both the game and the bonus section. I used to love ERS games, but the few I've played recently haven't been nearly as good as the first few. This was a pretty average game as far as plot line went, but the graphics were amazing and fun to watch. The puzzles were generally reasonably easy but there were two I had a little trouble with, particularly one in the bonus game that made no sense at all. I just worked on it blindly until I finally got all the "pie slices" lit. There were far too many HOGs and some items looked nothing like what they were supposed to be and I got them totally by lucky clicking. Maybe I need a magnifying glass or new contact lenses.

I wish there had been an interactive map since there was some running around among the different rooms and buildings. The SG, as far as I used it, was accurate and clearly written and stayed on the page you'd left so you could get right to your place if you needed it again.

The bonus game was okay but far too short; very disappointing. On the other hand, the graphics were great and it was worth playing just to see those.

One of these days someone is going to create a game where there are no locked doors or trunks, etc, requiring long hunts for keys; no items that can't be reached without going through several steps to find a ladder or crate; and no potions that require several different ingredients which are hiding in dark corners or in cabinets...locked of course. Surely there are other ideas or themes out there in development land that are fresh and new and don't have people searching yet again for the same foolish relatives who didn't learn their lessons in the first game of a series.
 
 
Did anyone else have Alan's Dreamcatcher left over after playing the whole game and the bonus game? It's still sitting in my inventory looking lonely.
 
 
 posted in Fear for Sale: Nightmare Cinema Collector's Edition on Apr 26, 13 6:33 AM
Thank you! I was thinking of the wrong source for the tears but eventually I got it and I'm almost finished. It's funny how such a small thing can throw you off entirely.
 
 
 posted in Fear for Sale: Nightmare Cinema Collector's Edition on Apr 25, 13 9:41 AM
I'm glad both of you found them, but I'm confused. I had the flask of tears from the gargoyle head at the bottom of the stairs, but now it's just an empty flask. Where can I get more tears? I went back to the crying head and there are no more tears. Help, please? Thank you!
 
 
 posted in Grim Tales: The Stone Queen Collector's Edition on Mar 22, 13 3:12 PM
There is a mini-game on a door in the king's sarcophagus room. I clicked on "Skip" and the door opened, but apparently I was supposed to have gotten some gold from the game board. I saw the stacks of gold on the game board, but didn't know that I was supposed to pick them up. When I clicked "Skip" the game ended and the door opened but I didn't get the gold then either. Will I need that gold in another part of the game? If so, how can I get it? Thanks!
 
 
 posted in Mystery Trackers: The Four Aces on Feb 7, 13 9:44 AM
Never mind. I forgot that they had been attached to another piece in my inventory.
Obviously my brain is going down hill fast. Sorry!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator