Posts created by swirVi

 
 
Thanks Brunicat, this worked!! So glad I didn't have to restart the game thanks for the great tip!
 
 
 posted in Haunted Legends: The Queen of Spades on Dec 29, 11 3:21 AM
Scratch that, I did get it, yay! I didn't look all the way in to the left of the staircase, but when my frustration subsided, i remembered a spot being there . Thanks heatherneeny
 
 
 posted in Haunted Legends: The Queen of Spades on Dec 29, 11 2:38 AM
I'm not getting the hidden object scene to the left of the staircase (or any staircase for that matter), and I've fixed the machine...
 
 
Hi Rebecca,

You must be playing the iPad version. The walkthrough is for the PC version so you can't follow it on the iPad. The butchers knife and wood is what I got and I used the butchers knife on the door to the left, just inside the mansion. Don't even bother with the walkthrough, but once you get intro that left door, you'll be fine the rest of the way through the game. That's what happened to me, although now I'm stuck at the very end trying to find a mirror frame!
 
 
ChesterPepper79 wrote:Welcome to the pond, DaneiLove!

It sounds like you're playing the Standard Version but following the Collector's Edition walkthrough. The Standard game doesn't include the chips (or the rabbit head, or morphing objects). The chips lead the player to a tangent bonus area and have nothing to do with properly finishing the game. You can simply skip this task and it will have no effect on the game.

Good luck!!!


I'm definitely playing the Collectors Edition and I don't have the potato chips. This is the second time I've re-started and this time I followed the walkthrough so I didn't miss anything but the HOG with the chips is still not coming up. Any help would be appreciated since I forked out the extra few dollars for the CE.
 
 
 posted in Mystic Diary: Lost Brother on Oct 16, 11 7:55 PM
Hi all, I logged this with tech support and there is a way to get the key to work! Make sure you align the middle of the key ith the lock. I just tried it and it worked first try! . If you're still having problems, contact support. They're really friendly and very helpful
 
 
 posted in Mystic Diary: Lost Brother on Oct 15, 11 12:56 AM
I don't think we've missed anything, it's a bug :/ I checked out the walk through just to make sure. The only thing left to do in the room is open the drawer to get the last piece of the picture.

Very frustrating paying for a game that can't be completed!
 
 
 posted in Mystic Diary: Lost Brother on Oct 14, 11 7:42 PM
In pages 13-14, the key does not open the white desk drawer. No matter where I try to put the key, it doesn't recognize it so I can't proceed.

I hope I've posted to the right forum, please let me know if I need to post elsewhere.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator