Posts created by rockydellrd

 
 
 posted in Parallels Cross on Jan 31, 16 3:21 AM
find the can and the shoe and take the lace, find the can opener in the drawer, the key is under the rug at the middle bottom of screen. Open the can, put under the oil and fill. Put the lace in the can along with the blue stuff you collected in the barn. Put on top of stairs and light with match.
 
 
 posted in The Emptiness on Feb 6, 15 7:13 PM
Go the this Russian website on Google and translate to English.

http://prohod-igr.ru/publ/prokhozhdenie_igry_pustota_the_emptiness_walkthrough/1-1-0-270
 
 
 posted in The Emptiness on Feb 4, 15 7:11 PM
Everyone has posted the U, X, but not the T. Where is the T for the word Atronux located? any help would be greatly appreciated.
 
 
I had the same problem, finally worked but could not pick up the gear, so I had to restart the game. Hope it doesn't happen again.
 
 
 posted in The Far Kingdoms: Elements on Dec 6, 14 3:47 PM
Put the green algae in the torch and then proceed to the dark cave.
 
 
 posted in Greed: The Mad Scientist on Dec 6, 14 7:43 AM
The hint button tells me to get the plastic tube in the case where there are ants. I must not have picked up the right tool to accomplish this, any suggestions.
 
 
 posted in The Far Kingdoms: Elements on Dec 5, 14 7:42 PM
The knife is located on the wrecked ship that is underwater, stuck on the railing on the right side of the screen.
 
 
 posted in Warlock: The Curse of the Shaman on Aug 14, 14 4:17 PM
d
 
 
 posted in Warlock: The Curse of the Shaman on Aug 14, 14 4:13 PM
crypsynight wrote:I have completed the grandfather doll, yet it keeps telling me i need to clothe it.
If i hit the hint it takes me away from the doll, and hint again just shows all possible arrows of places to go.
And if i hit hint a few times, it just locks up.
Clearly the hint button is also confused......
 
 
I can't solve the puzzle on the fridge. It seems that the far left middle spot needs two objects placed there. One to create what looks like the peak on a house and one to create a horizontal line in the middle left. Has anyone completed this puzzle. Help!
 
 
 posted in True Fear: Forsaken Souls Collector's Edition on Mar 3, 14 3:14 AM
I played the game in casual mode and it only went through Chapter 3 and then stated conclusion in Fall 2014. This is after receiving the 3rd tape for review. Once you review it a cut scene follows. In casual mode you cannot access the bonus chapter or anything else. Did I miss something stating you had to play in Expert mode to achieve all the extras.
 
 
 posted in True Fear: Forsaken Souls Collector's Edition on Mar 3, 14 2:53 AM
When you move the arrows North, East, West and Southwest, look at the compass and move the arrows according to the arrow on the compass. East would be on top, right angle to compass arrow, West would be below and right angle to compass arrow, North would be pointing same direction as compass arrow and Southeast would be on top of compass arrow pointing one notch past East direction.
 
 
 posted in Shadow Shelter on Feb 6, 14 2:35 AM
When I did the suggestion, my last two choices were middle right then middle left. Do not know why my game was different.
 
 
 posted in The Fool on May 13, 13 12:32 AM
Moving the cursor up and down works the best, I tried all suggestions and up and down did work.
 
 
 posted in Mushroom Age on Oct 31, 11 7:58 PM
Can not get the zodiac symbols to move in Chapter 3, Socrates games 3.3 and 3.4
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator