Posts created by Kiriel1066

 
 
 posted in Amulet of Time: Shadow of la Rochelle on Feb 5, 16 11:54 PM
I can't find the developers name in the credits and it isn't prominent in the opening screen. After the Big Fish screen it says GFI. Is that the developer?

Also, does anyone know if other games by this developer and/or similar games are available?

I really loved the mechanics of this game - multi-screen rooms. Objective lists that grow when you find a puzzle you have to solve. Inventory items being found in both the rooms and HO puzzles. It played so differently from the cookie cutter games we are now getting with the same running back and forth after you find one item....blah...

And the scenes were so beautiful. I never wanted to leave a location.

 
 
jedilady wrote:I have the nameplate in inventory, with 5 letters to put into place. The 5th letter (sigma) won't move and I can't progress any further. Any assistance, please? I have tried restarting both game and phone.

HTC M8, 5.0.1

Thanks!


I have this same issue. I also saw on a locked thread that someone was having trouble with the last letter - N. Did anyone have this problem and get it to start working?


Why are all these threads locked? None of them have any answers in it and people can't post that they too are having a problem. I am having trouble understanding what is the purpose for this forum if you can't do gameplay issues and posts like this about issues that may or may not be gameplay or technical are locked and supposed to be all posted here in one big massive thread. Other sites like Steam allow the community to answer posts indefinitely unless they get out of hand.

The issue I am having I am pretty sure is a technical issue but if we could post in a thread dedicated to a particular issue someone might answer me that it is a gameplay and I am missing something.
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Feb 23, 14 8:20 PM
That and those 3 books are the hidden chapters. I think you need to finish the bonus chapter to get to them.
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Feb 23, 14 8:19 PM
Same here.

Any word on this?
 
 
 posted in Awakening: The Sunhook Spire Collector's Edition on Feb 20, 14 11:56 PM
After you recharge the dragon from the lightning you use him on the door. Not the round thing in the hole. That thing you need to get another dragon so there are 4 little dragons on it. Then he can charge it normally.
 
 
 posted in Mystery Case Files®: Fate's Carnival on Feb 17, 14 12:34 PM
I tried number after number in the top right but they didn't work. I finally looked at the strategy guide. Now why was I supposed to put that code in for that order?

I think the order was top right, top left, bottom right, bottom left. Completely non-intuitive because most of us go from left to right and top to bottom.

Was there something in the puzzle that was telling me it was that order or was it supposed to be trial and error?
 
 
 posted in Tricks and Treats on Nov 7, 11 11:46 AM
In one of the early levels a message pops up that says a cameleon item can match to any item. And I just noticed one comes up on that level and it disappears because it matches as the boxes are filled.

I have NEVER seen this in the game. Not even with the rest of the items that come with the rockets.
 
 
 posted in Tricks and Treats on Nov 4, 11 7:14 PM
Hammer activates for no reason.

Edit: I also noticed it activates when a powerup, including the hammer, becomes available. So maybe it isn't when you use another powerup, just when a powerup becomes available or the next level of it powers up. Since the powerups seem to be at the same power you finished the last game level at it could be the first click of a new game level.

And I agree with next poster - ruins your strategy.

After you use another power-up the chances that the hammer will activate by itself on the next click is very high. Once it activates by itself it tends to activate again by itself when it powers back up. This behavior can last for up to about 6 or 7 hammer power-ups after it started.

Very irritating.

I really only noticed this after I got the fix because I didn't have the power-ups except the hammer working until after I installed the fix.
 
 
 posted in Tricks and Treats on Nov 3, 11 12:35 PM
Hammer is proccing for no reason. Usually happens after I use another power-up but I can't seem to get a concrete pattern.

Very annoying to attempt a match and have the hammer smash the block instead. Or try to move a rocket to another row and have it blow up instead. Especially annoying when I have been waiting for the hammer to build up and it keeps activating and I have to start waiting again.

And this isn't just a once in a while thing. It happens many times on a level. I find myself clicking on an item out of the way just to make sure the hammer won't activate and ruin what I planned on doing.

If it weren't for this - the gold block problem has been fixed with the update - the game would be perfect. This is ruining my game experience so that I get very irritated and quit playing.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator