Posts created by Oldgamer99

 
 
 posted in Kronville: Stolen Dreams on Sep 14, 15 9:32 AM
After showing him the film, nothing works! Am I missing something?
 
 
 posted in Kronville: Stolen Dreams on Sep 14, 15 5:03 AM
Another day, another super slow download. This is the worst of them yet. It's been downloading over an hour and I got a notice from Malware bytes that it's blocking a malicious site associated with yours.
 
 
 posted in Nevertales: Legends Collector's Edition on Sep 12, 15 1:56 AM
Two days in a row for TERRIBLE download time! Way too slow. The download is only at 70% and it's been running for 45 minutes. Running up to date Windows Vista on a 64 bit machine.
 
 
 posted in League of Light: Silent Mountain Collector's Edition on Sep 10, 15 12:58 AM
Download is awful!! It's been downloading for 40 minutes and I have high-speed internet and run Windows Vista. Never have I had a game take this long.
 
 
 posted in The Silent Age on Aug 17, 15 4:46 PM
This game is an amazing little jewel. For those of you who remember Space Quest / Zork / Kings Quest, this game is right up your alley. Very old school, very linear, and surprisingly very entertaining. This is not a puzzle game, really; it's pure adventure and will keep you entertained for hours. It's very logical. I recommend this game.
 
 
 posted in The Silent Age on Aug 17, 15 6:36 AM
I'm liking this game. It reminds me of the old Space Quest/Zork games.Definitely worth a PCC.
 
 
 posted in The Silent Age on Aug 17, 15 4:25 AM
Just curious.
 
 
 posted in Sea of Lies: Tide of Treachery Collector's Edition on Jul 30, 15 4:14 AM
Thanks to everyone for their input. I fixed it!!! I located a log file that said it had a bad stub message, so I uninstalled the game manager and rebooted. Then I reinstalled. The game is downloading now.
 
 
 posted in Sea of Lies: Tide of Treachery Collector's Edition on Jul 30, 15 1:39 AM
Game won't download. Is there a problem on the site?
 
 
 posted in Mythic Wonders: Child of Prophecy Collector's Edition on May 24, 15 1:22 AM
I am running Windows Vista and also having a problem (all updates to computer have been made). In the throne room, the cursor freezes when I try to place the object on the door. I cannot go any further.
 
 
 posted in Animism: The Book of Emissaries on Apr 23, 15 12:46 AM
I've gone over every inch of the screens. I can see the scroll in the library wall but I thought I already got that one. There's no hot spot on that wall, either, and nothing turns red. I got one in Jones' office and in the closeup on his bookcase, in the hall to his office, in the closeups in the storeroom, in the rubble to the library, in the library and outside.
 
 
 posted in Animism: The Book of Emissaries on Apr 22, 15 3:46 AM
I can't find all of the hidden pages. I've looked in the store room, the professor's office, and the library. I know there were pages in Declan's office, but that way seems to be blocked, or is it.
 
 
Having the same issue as Brenda519. I solved the colored filter puzzle and now only approximately 1/4 of the room shows. The rest of the screen is black. At first, I thought it was supposed to be that way. My heart just sinks as I read kathey12's post. So it's either start over or wait for an update. What a shame.
 
 
 posted in Taken Souls: Blood Ritual on Apr 5, 15 4:02 AM
I am running Vista and the game has crashed twice now with an Access Violation error. You CAN get out without completely restarting the computer: start your task manager (CTRL/ALT/DEL) and click on the program and then End Task. The game can then be restarted. So far I haven't lost much data and have been able to pick up pretty much where the game froze.
 
 
 posted in Warlock: The Curse of the Shaman on Aug 11, 14 7:49 AM
My clippers completely disappeared when I tried to use them. Now I'm stuck.
 
 
I have had the most extreme case of deja vu with this game. I don't think I demo'ed it, but I am just sure I have played it.
 
 
I think I've got it. First open the note and click on the X. This closes the window. Then open the ring again and you should have a hand to change the sigil and you should hear a 'ding' when you change it. Then open the note again and close it. THEN you should be able to click on the button and it 'takes'. What a mess.
 
 
 posted in Fear for Sale: Phantom Tide Collector's Edition on Apr 4, 14 4:38 AM
Man, wish I had checked this thread sooner! I am now stuck because I did not pick up the pulley first. I was going crazy. Even used the hint button, which circles the cabinet, but you can no longer access the cabinet.

Sounds like there are lots of glitches with this game. Too bad. I was really enjoying it.
 
 
 posted in Bluebeard's Castle: Son of the Heartless on Feb 12, 14 11:05 AM
I'm running Vista and everything is up to date. I froze the minute I opened the fire and ice vault but was able to close with Task Manager. When I restarted it completely froze and it looks like the opening shot of the castle is transparent and overlayed onto the vault door. Luckily I was able to shut it down again with task manager. I have reported it with yet another Dr. Felix file.

Too bad. It was a pleasant enough game up until this.
 
 
 posted in Shadow Shelter on Jan 20, 14 3:34 PM
I think something's wrong with mine. First of all, the only part of the screen that doesn't change to gears is the door and now I had to close down because the game froze.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator