Posts created by lorelei25

 
 
5 Ravenhearst games have taken us through the twisted maze of Emma Ravenhearst, Rose Sommerset, and the Dalimars; plus 3 other MCFs with strong tie ins:
* 13S-CE: Collected Cards imply Abigail was the daughter of Phineas Crown and 'Skull 13', ships nurse; who sent Abigail back to England to live with relatives. (first unsolved mystery)
* FC-CE: Madame Fate predicted her own death by Charles, and revealed 1 year earlier had imprisoned Alistair in the 'Ball of Fate'. (IMO, explains the gap from the Doctor who said Alistair 'died' one year before Charles was committed.)
* DG-SG-CE: Reveals Alistair had daughter "Lily" while with the Mistwalker's. "Lily" married outside the clan, had two sons who became separated. (second unsolved mystery)

1) First Unsolved Mystery:
Abigail Dalimar. A mystery in herself. Timelines match between 13S and DG-SG - she might have been placed in Dire Grove not too long after it's founding. Charles murdered her upon his escape. Implied she was an invalid from Charles POV. Interesting note- EFR soundFx in the "horror house" have both male and female voices.

2) Second Unsolved Mystery:
Lily. As a Mistwalker; it seems unlikely she could be a daughter of Alistair and Abigail. Or was she? If Mistwalkers extend their lives at need, was the reason they couldn't help with her curse/illness after she married outside the tribe - she was already much older in years, outside clan protections, making her easier to curse?

3) Other major Unsolved Mysteries:
At the end of (EFR); Emma, Rose, and the twins had been brought back to life in present game time.
Confirmed in EFR that Victor was Charles' son, born sometime after Rose was a captive in RTR, and not the father/husband who buried empty coffins after being unable to find his family. (articles in RTR).

In KtR/RU: After Alistair failed to use his other grandchildren (DG-SG) to extend his life and plans; he turned to his other kin - !Gwendolyn and Charlotte!
Which implies Charles knew, and had an affair with, Rose several years before she became Emma's nurse (R1)? Either Rose's husband thought the girls were his, or (unlikely) he married Rose and adopted the girls? What is Rose's real role in the twist: captive or accomplice?

Final question - there were clips of of Emma and Rose's hair found in KtR; and Alistair states he ended the Ravenhearst line in RU. What happened to Emma and Rose? How did Gwendolyn and Charlotte end up raised by Dalimars?

Ideas? Thoughts? Thanks!
 
 
Huh.
I'm going to have to go back and play both 'Prime Suspect' and 'Madame Fate'...
It's quite possible... - although I know I didn't notice this before you posted about it.



More soon... (ETA the weekend)
Thanks for spotting this!
lorelei25
 
 
Confirming the code provided above works:
(highlight for spoiler text at end of credits for those who are stuck)
"Search Townsend and use the code (mo. of founding), (# of canine figures + 2), (# of birds to break a branch + 1)"

(highlight for spoiler answer for those who are stuck)


*After* you have seen all the wolves and entered the other two register codes needed to open the drawers
Go to Pharmacy Register, enter the code 184, and pull the lever.
*poof!* Achievement Unlocked!

1 = Month of Founding
8 = # of Wolves/Canines + 2 (1 wolf at start, 2 at hotel, 2 at pharmacy, 1 dog = thunder; thankfully NOT counting all the 'ghost wolves' that appear and disappear!)
4 = # of Birds to break a branch + 1 (for the 3 birds in banshee lights super puzzle)


I wouldn't say getting the achievement is 'anti-climactic' - although IMO it is more along the lines of those extra tasks we figured out to collect the 10 extra gold cards in MCF:13th skull . ...only without the other 9 tasks we had to figure out along with it.
And not quite as much math involved as the phone number for the Dire Grove 1 puzzle

What can I say - I'm tickled they gave us a puzzle like this in the credits at all, it's been a while!!
Thank You!!!
 
 
It's been a year since BFG broke it with the update with the Casual Setting - I want to ask before I go through the mess of uninstalling and reinstalling this game (again):
Did they ever fix the last morphing journal object and the final pages of the diary?

When I first bought the game (pre casual setting) there was a morphing object game in the journal to play through - that led to two extra HOS drawings on the ground to work through that then became part of the diary at page 40. You could only get to those by re-entering the game and clicking on one final morphing object (in the tree behind the ladies) on page 39.

After they added the casual setting - the two drawings became page 39, no HOS.

Is this fixed yet?
 
 
“I See Dead People”
Bought it, was able to work through it (in casual mode). I should note, after the first - I skipped the memory block puzzles out of sheer frustration and annoyance.

It does look like they borrowed bits from ALL of the games that led up to this point; city maps from Huntsville, night goggles from Prime Suspects, objects you have to find and carry with you like RTR, in-game morphing objects like DG, 'winning' objects from the HOS's to take with you for later from RTR, DG, & 13S, end of chapter "Door Tokens" from EscapeFR... etc.

I'm with a lot of others- I thought the live action was overdone and unnecessary. I would have liked to see more of what made the games like Ravenhurst, RTR, MF, DG, and 13S so compelling: Plot and GAME PLAY.

Extra bits that make for an interesting time, even on replay. I know a lot of people reading this didn't like 13S - but the true CE bonus chapter with the ships, all the clues from the credits, the difficulty of the achievements, even the extra voices like 'Snarky' & 'Southern'... I was really impressed.

For what we got, I was really unimpressed with the sheer 1+ gig size of the game.
At least they did work out the bugs and kept them worked out - unlike EFR 1 year later (anyone else still have a broken last page to their diary?)

Do I recommend this game? Sure. Especially for die hard fans who have been with the games since Huntsville and keep hoping that MCF will get back to what made it great. Even with the simplicity of the first four games - the HOS and puzzles were outstanding. Then game play changed up a notch with RTR, DG, and 13S. These last two games have been disappointing.

Please, for the love of the fans stop with the “door tokens”
Debug before release.
After 4 games of looking through a clever journal; voice bubbles, disjointed tasks & lists aren't the same
A real integrated strategy guide is a plus - use DG as a model.
Go back to working puzzles between chapters - those 'floating memory blocks' were awful.
Give us extra's worth paying for.
Shadow Lake struck me as unfocused at times. Considering the name, I expected that location to be far more important.
But after EFR, I was not surprised at the blatantly occult sequences worked in.

I'm hoping chapter 10 will return to the beautiful streamlined graphics, puzzles, HOS's & clean story telling that doesn't try to rely on shock value. And please, if it's going to be 1+GB, give us more game to play - not more green screen?
 
 
lorelei25 wrote:
Mr_Russ wrote:All of that needs to go to CS via the green envelope, lorelei.



Belive me, it did.

But sadly- It looks like LOTS of folks are now tripping over the missing page in the case book.
I'm hoping they get all this fixed soon.

((Also keeping my fingers crossed they'll add a few more 'extras' into the next upgrade along with the fixes. And that they get the Mac version done for those folks too! ))

Happy 2012!



I'm admittedly skipping reading through the last several months of posts - and didn't see any 'root posts' by the moderators.
Did they ever fix all the bugs introduced with the Casual Difficulty setting?
If I uninstall / reinstall the game, does the last page of the journal work now along with all the other things I spotted that were broke (that I found, and -Yes, emailed tech support about back in December)?

Any information helpful- Thanks!
One Hopeful Little Fishie ~ Lorelei25
 
 
I sent in a trouble request (to the green envelope), posted around the forum, sent a follow up email... I haven't heard back.

Has anyone heard if any of these issues been dealt with:
- The broken morphing last journal page? (the last page of the journal with the swing)
- All the door tokens & activated tokens that lost their headings across the game?
- The babies in the crib headings? (and all the other objects with broken headings)

Lets start there, eh?

Thanks!
Lorelei
 
 
trenardy wrote:Not sure on this one.
So just how bad is bad?


I was going to respond on your initial thread, but by the time I got back, it was locked. Really not sure why.

Anyhoo...

Yes. This game is disturbing on many deep levels. Not gory, but often startling, and occasionally even shocking. I even can see why some folks would use the word 'disgusting'- but mostly I've read that in relation to some 'chores' that seemed as bad to me as cleaning latrines back in scout camp.
I'm not sure I'd put it on the same level of horror like the 'Silence of the Lambs' or even 'The Shining' (which I barely got though once)...
possibly more like 'The Cell' (which I did get through)?

Game does have SOME amusing bits, but not many. As I said in my own review "the developers where eating their 'sick and twisted' Wheaties for breakfast while working on this" There is a lot of 'anatomy of a serial killer' built into this game. And you are being walked though the life of a madman, from the madman’s point of view.
(A madman with what seems to be an infinite budget for seriously messed up mannequins...)

The game is divided up into different areas. Areas two through four (out of 6 total); a temperance hospital, childhood home, and Victorian sanitariam; are where the really creepy/spooky bits are, IMO. Though even 6... has more then a touch of it.

If you are prone towards nightmares, and you do get this game- I can already advise that this NOT be the last thing you look at before going to bed, and that you take breaks away from it if it gets overpowering. Visit the LOLcats site or something you find amusing for a bit instead. Some of the imagery from the game could stick with you.

One thing I will caution- if you are a survivor of any sort of abuse/childhood abuse,
bits of this game may potentially be triggering.

Its an interesting chapter for the MCF games. Not their best chapter, but an interesting one.

Hope this helps!
Lorelei
 
 
quilterill wrote:Have played all the Ravenhearst games and found this one very difficult because of the MOs. I too am having a problem with a missing page in the case book so am unable to finish the game...can anyone help...have gone through all the forums and did not find anything that would give a clue on how to find page 39. Do I need to play the game through again to get that page? Can someone please help?



The final journal page; (with the girls and the swing) seems to have gone missing in the recent upgrade. You may not have it if you downloaded/re-downloded the game with the casual setting.

If you have finished the game, but not the diary puzzle- (and are 1 short of finishing);
your page 39 will have two sketches and talk about heading back to the car.

This is the glitch. That's actually the 'bonus' page you should get AFTER you finish the HOS with those two sketches.

Doesn't matter if you're in 'casual' or 'advanced' setting; the glitch is in both places.

Sorry to be the bearer of bad news
 
 
shorenuf wrote:
bulldog2 wrote:Glad they said they were making MCFER a top priority for MAC users, I think the top priority was to get the PC side the SE version. I remember we had to wait for months for another MCF game but I can't remember which one - oh wait!! maybe all of them.


They apparently made updating the PC version to include an easier "Casual" experience their top priority. That release happened a month ago. Soooooo?

I find it so hard to believe they found a major issue with the Mac version of this game within hours of the November release. When I think about how we were duped it is so maddening. I just don't think about much anymore.


I keep watching this thread in case they do release the Mac version (so I can recommended it to a friend with a Mac)

Not sure you saw it on the other threads- but that release a month ago to add the 'Casual' setting was buggy as all get out. For the most part, I wish I hadn't re-downloaded the game with that addition.
I wonder if the reason they don't have it out for the Mac is they're debugging it/enhancing it at the same time they're working on fixing the PC version?

Don't know. I do hope Mac folks won't have the bugs the PC folks have had when it does release...

Keeping my fingers crossed.
 
 
cherrytwig wrote:No wonder they call this the asylum... Im going mad!!!!! I have tried 50 plus codes to charles' cell via security monitor.. first door. none of them work.. I know you need to be in the green to enter the code..and I have done it within 30 seconds..timed it.. Help!!


There are two codes, one for each door.
One you get from looking in the room off the courtyard (use the ladder);
the other from the security room monitor.

Watch the code until its just in the green- go try the code on the doors you need to open.

Hope this helps!
 
 
DebbiJ713 wrote:I'm not able to get the round door symbol for the Spankatron box to be accepted or light up when I set it over the Spankatron control and click. This is the last door symbol to be able to open up the door of Rose's water chamber thing. I checked the Strategy Guide and know I've got that symbol in the right place but the game won't accept it. Does this make sense? Anyone know how to fix this?


Is the arrow on the Spankatron unit lined up with setting #3
before you try to align the token?
 
 
mlcorsaro wrote:...
Now, with all that said, what does "SINK THE PLUNGE" mean?

Thank you for another great game and the opportunity to comment on it.

Big Fish crew...YOU ROCK!!!


SPOILER ALERT:

Its a hint on where to find one of the Gold Skulls;
when you have the plunger, go to the kitchen sink in the house and plunge it
Hope this helps!

 
 
Pirate_Sulaiman wrote:Hi,
Iam Sulaiman.
Pls Help Me...

I didn't recieve an objective after opening the hutch (Cabin which is on under the trap door)...

So, I deleted that player and created new player. And I played from the begining. Although I played again, I didn't receive any objectives after opening the hutch with the symbols which i found in the pound....

So. iam unable to continue anything there after .........

Pls Help me
Help me


Trying to understand this question;
you got under the cemetary, used the symbols from the fountain, found & plaecd all the goblets, and the hutch opened?
Were you able to climb the ladder into the cabin?

I'll keep watching this thread in case you write back...
 
 
chazbyron wrote:Hello! I'm stucked in the tavern bathroom. How did you do it since you've finished the game several times? Please help....I like the game a lot so I want to finish it. Thanks


Go to the managers office, there is a phone list on the wall;
call Leumont- he'll give you instructions something like put the plunger in the toilet; flush it x times, plunge it x times, then flush it x times. And that "will git 'er done"

(I can't remember if this is one of those things in the game that changes numbers from time to time.)

Hope this helps!
 
 
VLewis138 wrote:How do you activate the tokens? the Walkthrough indicates when you use the stork key, you will open the door to Dalimar house. I have the tokens but can't figure out how to activate and use them. Please explain in detail.
thanks


Line up the door token EXACTLY with the pic in the room.
Click and drag it around on the screen you'll see they are slightly transparent.
Like the first two tokens "Together" & "Again"
The tokens will have a peice of the background on them. Line them up- then click.
You'll know they're activated when they get all sparkly.

Some are harder then others as you go forward with this- I often found that if I lined up the background, the foreground of the image would align better.

Hope this helps!
 
 
MrsMJohnson wrote:I looked in the BFG walkthrough and it ends with freeing the girls. I don't see where it shows where to find the morphing objects in the journal?


The Stategy Guide & Walkthrough won't show you where to find those (like they did in Dire Grove); if you have the CE you have to delve for them yourself.
There are other posts on the forum that have lists if you get stuck.

Good luck!
 
 
Mr_Russ wrote:All of that needs to go to CS via the green envelope, lorelei.



Belive me, it did.

But sadly- It looks like LOTS of folks are now tripping over the missing page in the case book.
I'm hoping they get all this fixed soon.

((Also keeping my fingers crossed they'll add a few more 'extras' into the next upgrade along with the fixes. And that they get the Mac version done for those folks too! ))

Happy 2012!
 
 
Yes- hate to tell you this, but this may be a bug.
If you downloaded the game with the 'casual' setting, this is a problem that came up with that upgrade.

Another sign of the bug- is if your page 39 talks about heading back to the car and finding two sketches on the ground rather then being a photo of the ladies with a swing in the background.
 
 
random thought- (I mixed this up a couple of times by mistake);
Are the minute and hour hands reversed?

Good luck!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator