Posts created by Zenus

 
 
Same here. I used the map and it appears in the scene, but there are no markers and whichever way I go brings me back to the same place.
 
 
Found the ninth scroll piece!
 
 
I had the same problem. you not only have to pick up and open the diary, you have to read the Left page. That lets you pick up the pieces. However, I can only find 8 pieces, not nine. So I'm still stuck.
 
 
This puzzle is my first big complaint with a Big Fish game. It's hard to justify a puzzle that must be solved by random trial and error. Big Fish, if you're listening, if there was a clue somewhere, I would be interested in where.
 
 
As others have posted, I opened the grate in the tunnel before taking the wire for the cube charger, now the game will not allow me to go back and get it. I can see it, but I cannot take it. I'm stuck until this is fixed.
 
 
Reset worked for me.
 
 
To those of you who managed to solve this puzzle, my heartfelt congratulations. I found the instructions absolutely incomprehensible, and the Strategy Guide was no help whatsoever.
 
 
Totally clueless on the Scroll puzzle. I move one symbol to the right place, but others move with it. Then I wind up with the wrong symbols on the inner ring. At least I think they're wrong; I don't really understand what goes where. I don't understand the SG or the explanations on the forum.
 
 
Totally impossible. The resulting key matches the diagram, however the "proper" alignment of the cutters is random. The opposing cutters can't possibly make the imprints on the key. The SG is no help; had to use the hint button. There goes that achievement. First big disappointment with a Big Fish Game.
 
 
Where is the second coin? Got the one in the dash.
 
 
 posted in Sea of Lies: Nemesis Collector's Edition on Jul 6, 14 7:21 PM
Nope. Covered the whole area around the grate until my finger went to sleep. Not only do I get nothing, I can't even close the window to keep going. Uninstalling/reinstalling didn't help. Game is hung up.
 
 
 posted in Fierce Tales: Marcus' Memory Collector's Edition on Jul 12, 13 11:39 AM
Same here. My starting layout is completely different from the one shown in the SG. Need help! Don't want to skip it.
 
 
 posted in Mystery Trackers: Raincliff on Jan 25, 13 9:42 AM
Keep trying the sequence. If you have enough patience, it will eventually cycle back around to the solution. At least, it did for me.
 
 
Where's the gargoyle? I found the other 49 items, but I can't find the gargoyle, supposedly outside the library. Help!
 
 
 posted in The Secrets of Arcelia Island on Nov 2, 12 1:16 PM
Me too. Never noticed the one next to the gramophone. That was the last one.
 
 
 posted in Bluebeard's Castle on Dec 9, 11 10:20 AM
I too clicked on the ladder and it moved, but I couldn't get the book puzzle until I went back and actually picked up the paper with the clue. It appears that you must have the clue in inventory to get the puzzle to work. Also, you must actually click on each book in the pattern. Hope this helps.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator