Posts created by whimperx

 
 
Running Windows 8 and the magic mirror will not work to get the second lantern stone. I can't even put the mirror back. I have to shut the game down. I agree with other comments, too many glitches from this developer and we expect better quality control for what is charged.
 
 
I finished the game but was not ready to play the Bonus Chapter. Now I see no way to access it. Checked Extras, Options, Help. Strategy Guide works but no way to get to the end of the main game and continue to Bonus without starting the game over. Please help. Thanks
 
 
I get no "glow" but an x lights up but clicking there does not work. I have wasted at least an hour trying, five different times, and I give up. Ripped off I guess.
 
 
I am not a happy gamer with this one! I have tried, repeatedly, checked in the Forum for help, and still am unable to capture the bottle in the HOS. I take the fishing rod and try every possible angle and position and no luck. I can go no further without the axe that is the reward for this HOS. I used two game credits, which came after paying for many, many games, and it is wasted. Others have had the same problem, one finally succeeded. Please fix this glitch. There is no skip option and it is the last item to be collected.
 
 
Have tried and tried to retrieve the bottle with the fishing rod with no luck. The hint only shows the fishing rod and the bottle. I am stuck and can't go on with the game. I see no hammer or rock to smash the bottle. Please help, wasted game if I cannot move on. Thanks.
 
 
 posted in Paranormal Pursuit: The Gifted One Collector's Edition on Oct 14, 14 10:27 AM
Three times my laptop freezes when I try to close a "guide" window. The mouse will not activate to click on the "X" at upper right screen. I am using Windows 7. My mouse works on everything else, and the other games that are still available for play. I have to manually shut down and reboot. Last time it was in the foyer where I was supposed to place the ramp over the gap in the floor.
 
 
 posted in Whispered Secrets: Into the Wind Collector's Edition on Oct 8, 14 9:32 AM
This game has frozen four times when I tried to exit the game. I have to reboot my laptop. Now I cannot get the chest lid to open. I am running Windows 7 on a laptop.
 
 
 posted in Whispered Secrets: Into the Wind Collector's Edition on Oct 8, 14 9:28 AM
Please I need some help. The guide shows the combination but the chest has the symbols in a different order and nothing I have tried works. I have reversed the order, tried multiple sequences. The chest will not open. Was enjoying the game, even though I found the mini games very difficult.
 
 
 posted in Dreampath: The Two Kingdoms Collector's Edition on Jun 18, 14 3:13 AM
I have tried all the suggestions and counted the seconds. I cannot do this. My very adept son could not do it either. Very disappointing. I agree, that there should have been a skip option. So many of the other puzzles had that option and I didn't need them. Too many recent games have had problems. There must be a better game site!
 
 
 posted in Dreampath: The Two Kingdoms Collector's Edition on Jun 17, 14 3:17 AM
I enjoyed this game immensely, truly one of the most fun games in a while. However, I am stuck in the Bonus Game with the 7 orbs in the darkness. No skips, hint just points to the top orb. Disappointed, can"t continue the game. Hope someone can help.
 
 
 posted in Whispered Legends: Tales of Middleport on Jun 12, 14 5:09 AM
Was enjoying this game but cannot retrieve the metal boxes in the water. Fishing rod is in place, hunt points to the cane, but trying to use the cane with the rod or elsewhere does not work. I cannot get past this scene, so the game is done! Very disappointed and would like a refund!
 
 
 posted in Dark Dimensions: Somber Song Collector's Edition on May 8, 14 8:00 AM
Putting the mirror back together seems to be impossible. The pieces will not move out of the way to place the correct pieces. So I am stopped in my tracks. Not a happy camper!
 
 
Game crashed trying to put the reeds on the tennis racket. Using pc, Windows 7, flash player updated. Windows finds no solution. Great game but I feel ripped off now! $14 wasted,
 
 
 posted in Sable Maze: Sullivan River Collector's Edition on Sep 7, 13 2:09 PM
I was loving this game but cannot capture the firefiles with the butterfly net so I cannot advance. My son, who plays "expert" level tried and concluded it was a glitch and not possible. So money wasted on this game!
 
 
Same problem the locks will not open. Another wasted purchase!
 
 
 posted in Gothic Fiction: Dark Saga Collector's Edition on Sep 4, 12 6:23 AM
I have restarted this game three times with different profiles. Every time I get to replacing the missing photo pieces - I have all five and I retraced just to make sure. I get the orb but no hand and the pieces in the center will not move, and I cannot place any of the pieces I uncovered on the painting. Please help!
 
 
 posted in Mystic Legacy: The Great Ring on Sep 2, 12 8:56 AM
I was enjoying this game, about ready to purchase when I could not get the water filled bottle to go into the holder on the device to get the fertilizer. I tried for 15 minutes to no avail! So I am glad I did not purchase this game.
 
 
 posted in Twisted Lands: Insomniac Collector's Edition on Aug 6, 12 3:58 AM
Twice I have run into glitches that will not allow me to continue the game. I have started from the beginning with a new player name. Now I cannot start the fire in the operating room. The tank will not turn on, so the chemical compound will not pour, and the lighter will not ignite.
Waste of my money!
 
 
I skipped a step in one scene. Seems to be no way to go back and correct it. Do I have to start over with a new player name?
 
 
Trying to give the address to the tour guide. She disappears when I click on the address informaton for the Dr.. I cannot advance and cannot give her the address that is in my inventory.. Glitch?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator