Posts created by moondances

 
 
 posted in Ramses: Rise Of Empire Collector's Edition on Mar 20, 18 2:44 PM
I really enjoyed this game except for the constant repairing-Has anyone gotten far enough in the game to tell if there is a way to stop this? Some games do have insurance in later levels but I wasn't able to get that far in the demo-TYIA
 
 
 posted in Shadowplay: The Forsaken Island Collector's Edition on Feb 1, 18 1:53 PM
Wow!!! It has been a long time since a game has grabbed me and not only held my interest, but made me want more now-I just finished the demo and will def be buying-I'm not good at reviews, but will try-I found the mini-games novel & fun & not too easy/too many-They made me think but not to the point of frustration-The story flowed along in an order that made sense, rather like reading an engrossing novel- And, a biggie for me, the objects that I 'found' were not the same-o same-o (no missing zipper pull so far) and were used rather quickly and sensibly-There is a bit of unexpected humor upon finding the money clip, but it doesn't dispell the ominous story mood-I hope you enjoy as much as I have
Big shout out to Mad Head for a fab new adventure!!!
 
 
 posted in Viking Brothers 3 on Jan 18, 18 10:49 AM
Winnie 11, same thing is happening to me-I am so upset-I like this series and was anticipating an enjoyable day of play-I run Windows 10 with a new graphics card so I know my pc is not the problem
 
 
 posted in Santa's Workshop Mosaics on Dec 5, 17 10:43 AM
Game froze on player profile-Had to CAD to exit-Unable to play
 
 
 posted in Cursed House 4 on Sep 12, 17 4:21 PM
Luv it Luv it Luv it I especially like the music-I have the other CH games and will sometimes play one just to listen to the soothing sounds-TY, Devs
 
 
 posted in Rescue Quest Gold on Aug 17, 17 10:15 AM
When I try to open/play, I can hear music, but my screen is blank-I must CAD to close-This is the 2nd game recently that will download but not open-Frustrating
 
 
 posted in Heaven & Hell 2 on Aug 16, 17 5:04 PM
Game will not even open/start
 
 
 posted in Glass Masquerade on Jul 4, 17 2:06 PM
Just throwing in my 2 cents worth-Same issue as others-First puzzle, about half-way , cursor gone, had to CAD out-This is the second game today that I am unable to play due to tech issues
 
 
 posted in Rescue Quest Gold Collector's Edition on Jul 4, 17 1:51 PM
When I click play, I get music and nothing!!! If I click anywhere on the screen, the music stops and still nothing- When I say screen, I mean my regular screen, not the game-I can't even see the game-I must CAD just to get out-Have deleted and re-installed to no avail-Very disappointing
 
 
 posted in Big City Adventure: Rome on May 2, 17 7:33 PM
When I try to play this game, I get a Direct X error-Anyone else have this issue??? Any solutions???
 
 
 posted in Ominous Tales: The Forsaken Isle on Apr 12, 17 11:34 AM
Game played ok except for shaky cursor until I tried to place the handle on the bucket-Game froze and I had to CAD to task mgr to get out of game
 
 
 posted in Rat and Louie: Cook from the Heart on Feb 1, 17 7:42 PM
Yet another game I cannot play
 
 
 posted in Clutter VI: Leigh's Story on Nov 8, 16 7:42 PM
I played approximately 15 minutes fine, but when I tried to change to a different game, the screen began jerking-I had no response clicking different buttons-I finally started clicking all over the screen and I was suddenly out of the game-I don't know what happened or what I clicked to get out-Plz fix this (Win10 gaming PC)
 
 
 posted in Maze: The Broken Tower on Nov 7, 16 1:39 PM
I just wanted to post a quick warning to those fishies who may have problems with pulsating/flashing lights-There were several places where the lights bothered me and I don't usually have issues with this sort of thing-Interesting game, but I now have a headache after just the demo so be warned
 
 
 posted in Dawn of Hope: Skyline Adventure Collector's Edition on Nov 6, 16 12:11 PM
Unfortunately, I must agree with the previous reviewer-I quit the demo after 15 minutes, something I rarely do-I believe in giving every game a full chance, but I was so annoyed with spinning my wheels in the same spot while forced to gather & cook food, gather & construct a ladder, and oops, my grappling hook broke so now I must, yes, you guessed it, gather & devise a new one-There just wasn't enough action/story to hold my attention-I've always enjoyed this developer in the past so perhaps it's just me having an off day-Plz try for yourself, but I am out of here-Sorry devs
 
 
 posted in Haunted Hotel: Silent Waters on Oct 17, 16 11:47 AM
The game is good, not outstanding for me-I especially liked how you find an obviously expensive necklace, pry the fist-sized diamond out of the setting, use diamond to cut a circle in a piece of glass you could easily break, then toss the diamond while asserting that you will find a way out-I have my doubts about this character
 
 
 posted in Epistory: Typing Chronicles on Oct 4, 16 10:06 AM
I'm having the same problem as others-I pick an area, hear birds chirping, and the game freezes-I must cad to escape-I seldom have problems with games as my son built my pc especially for game play so when an issue arises, it is a game tech error, not pc
 
 
I 'think' they were laborday and weekend-No, I haven't tried any
 
 
 posted in Doodle God Fantasy World of Magic on Sep 6, 16 4:36 PM
I can't get past the 2nd page-No instructions-Nothing
 
 
 posted in Vacation Adventures: Cruise Director 3 on Aug 21, 16 8:07 PM
I love this series so immediately downloaded trial-Had to CAD to get out-No pic, just sound-After reading all the tech posts, deleted game-That was 3 days ago-I assumed the game was fixed by now so downloaded again-Same thing-No pic, only sound, unable to do anything except CAD again-Very disappointing
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator