Posts created by Readwritelove

 
 
Same issues with crashing. I need to feed the fish to get the orb and game keeps crashing. Won't even let me leave room, loads and crashes. Tried all the tricks. Very disappointing.
 
 
 posted in Sacra Terra: Angelic Night Collector's Edition on Jul 28, 13 9:48 AM
Glad to know its not just me but wished this was fixed in update.
 
 
 posted in Sacra Terra: Angelic Night Collector's Edition on Jul 28, 13 9:47 AM
It worked at 9:30
 
 
 posted in Sacra Terra: Angelic Night Collector's Edition on Jul 28, 13 9:41 AM
Having the same issue on iPad. It keeps telling me the generator is missing a switch, even after I installed it.

Scrolled down a bit and found another thread addressing issue. Common problem. Just keep tapping!!!
 
 
 posted in Clairvoyant: The Magician Mystery on Apr 20, 13 9:27 AM
Just figured it out!!! Put the wire in the keyhole and the key pops out.
 
 
 posted in Clairvoyant: The Magician Mystery on Apr 20, 13 9:15 AM
I put the newspaper under the door. It says ifi push the key should fall. I push and nothing happens. How do I get the key?
 
 
 posted in Cruel Games: Red Riding Hood on Feb 8, 13 5:42 PM
I too was confused by the ending. The cut scene went too fast. I think it's something the developers should revisit with an update.
 
 
Did you follow the guide to make sure you did everything before? The safe won't open out of order. Make sure you hear the click before you turn.
 
 
I love ERS games on the Computer, but I will no longer buy them for my iPad. The lag time between scenes is unforgivable. You literally cannot do anything, sometimes in the same scene, without a 10 second delay.

On this title, the developers seemed particularly lazy. Why can a heavy media game like mystery tracker trackers black isle, run smoothly but this one drag?

 
 
 posted in Cruel Games: Red Riding Hood on Feb 3, 13 4:20 PM
Really enjoyed this game. I was a bit nervous, since I prefer buying games with built in strategy guides(collectors edition ) but hints were perfect and the game level fairly easy.

My only complaint was it was a bit short, I finished in approx 2 hours. I thought the storyline was clever but could have been pushed further. It reminded me of brink of consciousness Dorian grey (although Dorian was far superior).

Additionally, the ending was quite abrupt. I understand the idea of a surprise ending but it was too short for the player to really absorb what happened. I had to come here to get some perspectives.

Glad I got the sale price, looking forward to cruel games 2!
 
 
I feel so silly! This worked perfectly.

I guess I am so clued to seeing it as a support button that when the game makers do something creative I can't see it.

Thank you! I"m off to finish the bonus game and then download the undertaker!
 
 
judimose wrote:Well, I finally finished the game (after going back twice to locate two missing crystals). Then I got ready to play the bonus game - only to find there isn't one - at least not that I can find. I've clicked on every clickable thing on the screen and can't find any bonus game. What am I missing?


Any update? This just happened to me. Very perplexed! I have never had a bonus game missing before!
 
 
 posted in Grim Tales: The Legacy Collector's Edition on Jul 16, 12 5:18 PM
Really disappointed with this game on iPad. The transitions (between scenes and games) are slow. Also, being given an object in chapter one but not using it until chapter four was off putting. This was my first time trying the Grim series and it will be my last.
 
 
 posted in Bluebeard's Castle on Feb 28, 12 1:54 PM
Restarted the game and the pot came back. Seems like a glitch
 
 
 posted in Bluebeard's Castle on Feb 27, 12 3:54 PM
I'm still playing but I am relying on the walkthrough. Many of the actions (or the sequence required) just doesn't make sense. One minute I am in the kitchen, the next in the library. Without the walkthrough I wouldn't know where to go.

I get that a challenge can be enjoyable but there really is no way to predict this. It destroys a lot of the enjoyment from a HOG.
 
 
 posted in Bluebeard's Castle on Feb 27, 12 3:51 PM
In chapter two, I picked up the pot in the kitchen yard. Now, in chapter three, I need to put it on the cauldron to make the potion. Only it is not in the inventory and it is not in the yard.

Is there a different pot? Has anyone else encountered anything similar?

Thanks!
 
 
 posted in Mystery Legends: The Phantom of the Opera on Jan 31, 12 3:01 PM
If you visit the ce forums people who bought hard copies like at wal mart are reporting missing strategy guides and bonus scenes. You may want to check in there or try customer service.
 
 
 posted in Mystery Legends: The Phantom of the Opera on Jan 31, 12 2:59 PM
Bought this during the 5 for 5 sale and so glad. Really enjoyed it. I'm usually on the fence about the collectors editions vs standard but in this case the free blog walkthrough got me through it.
 
 
 posted in Adventure Chronicles: The Search for Lost Treasure on Jan 28, 12 11:40 AM
Heard back from big fish. Game has to be reinstalled and progress lost. Really leaves me with a bad taste in my mouth. Will try to avoid games by this developer in future.
 
 
 posted in Hidden in Time: Mirror Mirror on Jan 26, 12 5:36 PM
With games like dark parable and puppetville, which require strategy and **** skills, I'm very spoiled. This was a yawner...a real throw back to the old **** games. You are limited in hints and the graphics didn't even fill the screen. The storyline was so bland it's not even worth mentioning. Skip it
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator