Posts created by Arcanemuse

 
 
 posted in 1 Moment of Time: Silentville on Apr 24, 18 12:30 AM
I don't have the chain and anchor. It never got added to inventory somehow. I can't get the nest and so I am stuck. Any fix for this or just delete profile and start all over
 
 
 posted in Mystery Case Files: Prime Suspects ™ on Mar 19, 16 10:42 PM
Sadly, I think you are right. I can't play mine either on El Capitan. I thought that they had weeded out all of the old PowerPC games. 10.6 had rosetta, which allowed backward compatibility for PowerPC architecture. Lion on got rid of it. Apple moved on and much like the 68K processors before the PowerPc, they have gone the way of the dinosaur. I think that they should at least tell people that this is a very very old game or rewrite the code so that it will work on Intel.
 
 
 posted in European Mystery: Scent of Desire Collector's Edition on Dec 25, 15 12:09 AM
Several have asked the same question and never got an answer. You get the house key from the guy and the pin from the note in the bushes. You go in the house and attempt to open the desk. No pin. Going outside again starts you all over again with no key. Hopefully somebody has a fix for this. Running iOS 9 on air 2
 
 
On Mavericks the game crashes on load on two machines: A Macbook Air and an Imac .. both 2011 mid year. I have yet to try on the 17 inch Macbook pro early 2006 model. Any ideas? Maybe it is kinder to Snow Leopard?
 
 
Solved. I put the treasure map on the boat and bang, it worked.
 
 
 posted in Beyond the Unknown: A Matter of Time on Aug 12, 14 5:51 AM
I have the same problem. I can't proceed because the crowbar won't work on the boat to get the boot. If anyone knows how to fix this, please share
 
 
 posted in The Chronicles of Emerland Solitaire on Nov 21, 12 2:21 AM
I was hoping for a cheat code or something as this game is RIGGED. It is IMPOSSIBLE to get through this last level. I just barely made it through the rest of them with four red x's. Already have four in this one. Oh well. I guess this was a waste of time and money.. to the bit bucket it goes.
 
 
 posted in Criminal Minds on Oct 9, 12 1:29 AM
I had to play the game windowed in Mac Mountain Lion. Works fine windowed but in full screen you end up with two bars on either side of the game that are garbled up pixelated versions of what was on the desktop before starting the app. I already played it but was wondering if anyone else might have found a solution to this. It's a shame it would not go full screen... makes it harder to see things. I attempted to reduce my resolution from 1920 down to something ridiculously huge ... 1024x768 and it had no effect on the problem.
 
 
 posted in Echo: Secret of the Lost Cavern on Apr 4, 12 1:08 AM
This thing is a nightmare. Even with the walkthrough, I can't get through this second part. I was doing OK and bought it and then I hit this. I have to use walkthroughs on every game as I always miss things and get lost. This thing has no clues no hints, no instructions, nothing. There is no object to this, you just stumble around and hope you can guess what somebody came up with for you to do. Unless you have an IQ well over 180, pass on this thing.
 
 
 posted in Jewel Quest Mysteries: The Seventh Gate on Jan 2, 12 9:12 AM
I hadn't realized that this was going to be one of those high stress timed games. I avoid those like the plague. Now that I am stuck on this nasty jewel board with no jewels and no way to buy any helps, is there any way to get around this or do I just have to start the game all over again? I've tried probably 20 times to clear this thing and this stupid timer kills me every time. I get close but I can't get it. I don't think it is possible unless somebody knows some way to cheat the system. Is there any way to get around this one or do I have to chuck it all and start all over? This is the jewel board that you have to use the pearls to open the bottom two rows up. It is an absolute nightmare.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator