Posts created by rdhowell71

 
 
Ok I am at a loss here in the game. I guess I shouldn't have placed the first moon piece. I have talked to the spirit and he wants me to take the object in his hand. Only problem I keep getting is that when I move the cursor onto his hand I get the gears icon and the message "looks like something is missing from this slot". I have about had it as I have spent a good 30 minutes trying to grab the object. I am going off the computer for the night.
 
 
I am stuck in the game at the point where I have collected 2 of 4 bells. When I clicked the hint button the game kept highlighting the tower were I put the 2 bells I already have. I also have the sail and no way to put holes in the fabric. Any help will be greatly appreciated.
 
 
Just in case someone has already read my original post, I solved the gem puzzle. Not sure what I did really. I went back in and moved two or three gems and it all seemed to fall in place. Thought I was going to be stuck for a long time.
 
 
Ok wondering if anyone had any ideas how to solve this. The second time the dumbwaiter is accessed there is a final gem puzzle on the body of what looks like a stuffed lion toy. I believe this gives you the piece needed to open the suitcase in the room with the plants. I know there's a solution in the strategy guide. But I had already started moving the pieces and I had tried for about fifteen minutes trying to get the gems in the right places. I went over to the guide but it's no good as it seems like the gem puzzle doesn't reset as I can't move the gems in the order the guide tells me to. Any suggestions?
 
 
You know I really don't want to sound like I am ungrateful or being hateful but it seems like Big Fish has one of two standard responses. Either update all of your drivers, files, etc or either delete your profile. I am sorry but when I have updated everything as far as I can go, deleting my profile is not an option. I mean I am way into the game and Big Fish expects me to start back at the beginning. Sorry but I don't think so. Why can't someone just say there is a possible bug in the software. Come on people it happens. Computer code is written by Humans. We can and always will make a mistake somewhere. It's a fact of life. Or it's just the fact there are so many different configurations of computers and operating systems there really is no way to tell if a game will act properly or not.
 
 
WilJul wrote:Ha! I just posted this in another thread. Bloody Mary was a kid's game that you would do to scare yourself. You turn off all the lights in a room, look in a mirror and chant "Bloody Mary" 13 times. Then she's supposed to appear in the mirror or jump out of the mirror or something. Ooooooooo, scary! Am I the only one who remembers this? I know I am not the oldest person on this forum! Lol!

No I am sure you are not the oldest person in this thread. I too remember the Bloody Mary game and I do remember her being a female pirate as well.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator