Posts created by read61

 
 
 posted in Shattered Minds: Encore on Jul 7, 12 9:03 AM
I cannot even download the demo, error code 772, never had that before
Will try later but not very optimistic........
 
 
not a fast player, like to take my time and look around, did not use hints or SG and kept forgetting about map. 5.5 hours for main game and 20 minutes for bonus
wonderful game but if I knew how short bonus was I would have waited for SE
 
 
 posted in Amazing Adventures Riddle of the Two Knights ™ on Jun 1, 12 2:59 AM
If you have played one, you have played them all - same format every time.
Enjoyable if all you want is HO after HO after HO....not very challenging but a nice change of pace with very little effort on your part. The kind of game you can leave and then go back to whenever you are tired of the more *thinking* type of game.
The last one in this series I played took me over three months to get through, playing every now and then - certainly no pressure involved! The match 3 at the end of each level makes a nice change of pace. A very relaxing but not challenging game.
 
 
fire has been lit but the dumb waiter is still stuck upstairs
both call buttons are in but it will not go down to the room with the fire
any suggestions, really not in the mood to start all over again
 
 
 posted in Pathfinders: Lost at Sea on May 16, 12 6:39 PM
One HOG scene straight after another, fairly straightforward and rather boring.
No real challenge other than some very small items. I think it would be good for a beginner but not an experienced player, just not enough interaction.
 
 
 posted in Living Legends: Ice Rose Collector's Edition on May 12, 12 1:59 PM
Cannot get the tree on the box to line up properly, even though it looks the same as in the SG. Even did everything Margie said to do and still no luck. Guess I will not be able to finish this game....this make the third game I cannot finish! Wish the developers had given us a skip for it.
 
 
 posted in Living Legends: Ice Rose Collector's Edition on May 9, 12 1:13 PM
Also stuck on tree puzzle, surprised there is no skip. So far this is the only glitch but it also means I cannot finish game. Checked SG, did what Margie suggested, still no go. Guess old whats his name will have to stay the way he is!
 
 
 posted in Abandoned: Chestnut Lodge Asylum on May 8, 12 4:06 AM
I also cannot spraypaint the duck or get the nail and I really do not want to start all over again - getting a little tired of games with glitches. Perhaps I should just stop buying new games until they have been out for a month or so and have had the problems sorted out....It would be nice if the developers would fix these things or even (gasp) test their games properly before rushing to release them....
 
 
 posted in Natural Threat: Ominous Shores on May 7, 12 3:31 PM
Played the game as far as the end of The Chapel, then exited. Went back in a few days later to continue and had to start over at the beginning. I thought they fixed this problem but apparently not - I really am not ready to play it over again. Oh well, maybe one of the games I got in the sale this weekend will be bug-free, for a change.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator