Posts created by jillybabe

 
 
After a normal opening, with the usual outline of the plot, once I press play the top of the screen flickers. I uninstalled it but the same thing happened. This is the first time any game from BF has done this.
 
 
 posted in Christmas Stories: A Little Prince Collector's Edition on Dec 19, 17 11:01 PM
Thanks, worked it out.
 
 
 posted in Christmas Stories: A Little Prince Collector's Edition on Dec 19, 17 10:58 PM
You need to comb her hair.
 
 
 posted in Christmas Stories: A Little Prince Collector's Edition on Dec 19, 17 10:56 PM
I can't find Pisces, I can see the two fish swimming in opposite directions but can't click on them.
 
 
 posted in Dreampath: Guardian of the Forest Collector's Edition on Dec 12, 17 10:35 PM
I'm using a PC with windows 10. This is weird, but the cursor doesn't work on the bottom right hand corner of the game. Which means I can't close it down properly, and have to use task manager to shut it down.
In the last scene of the forest where I have to match symbols, I was unable to do this because some of the symbols were in the affected area.

This is an update. I put some upgrades on the computer and the problem fixed itself. The problem wasn't apparent so it was good that it showed up on the game. Thanks
 
 
I need to click on the remote control to put the batteries in, but nothing happens.
 
 
 posted in Danse Macabre: Florentine Elegy Collector's Edition on May 3, 17 12:26 AM
This is the second problem I've had with this game, This time I can't complete the list that compares composers to compositions in the venue museum.

The final item won't let me check them off. This is getting very frustrating.
 
 
 posted in Danse Macabre: Florentine Elegy Collector's Edition on May 3, 17 12:21 AM
I left the game in frustration, and when I went back to it, I was informed there was a problem with the game and to start over again, where I managed to get the pottery tool. I now have another problem and will start another thread.
 
 
 posted in Danse Macabre: Florentine Elegy Collector's Edition on May 1, 17 1:18 AM
I can't find the pottery tool. I missed it first time around when I had to pick up up the red cover, and when I went back it wasn't there.

Jill
 
 
 posted in Vermillion Watch: Fleshbound on Feb 12, 17 6:17 PM
Hi, there's two posts in the forum asking how to access the extra game content. Can you please look at this and give us an answer. Thank you.
 
 
 posted in Vermillion Watch: Fleshbound on Feb 11, 17 10:07 PM
I'm having the same problem, where is the extra content button?
 
 
 posted in Phantasmat: Reign of Shadows Collector's Edition on Jan 16, 17 10:42 PM
I've tried every combination mentioned in the posts - no luck. This is the second time I've had a go at this game, and will once again have to give up. I simply can't see if the different parts of the game have been highlighted. I tried to follow the guide, no luck again. I can clearly see what sections should be selected by what's on the computer - sight, hearing and breathing. This section should have included either a reset button or a skip button.
 
 
 posted in Maze: The Broken Tower on Dec 11, 16 10:12 PM
What a relief to play a game without the usual gimmicks - no diamonds to break the window, no oil/lemon to take the rust away etc. Just a very different and challenging game. I couldn't do all the games, but will play it again in a few months and try again.
Well done.
 
 
 posted in Vermillion Watch: Moorgate Accord on Jul 29, 16 11:51 PM
The mouse arrow disappears on the 'continue' screen. I've uninstalled the game and re-installed it but the same thing happened again. I'm using a PC with windows 10.
Jill
 
 
 posted in Mystery of the Ancients: Mud Water Creek on May 22, 16 12:50 AM
I can't get the boatman to take me to the cemetery. Every time I try to give him the cemetery clue, it just jumps to the map, where I can see Dead Island, but clicking on the map doesn't go anything.

Jill
 
 
 posted in PuppetShow: The Face of Humanity Collector's Edition on Jan 31, 16 1:29 AM
I agree with all the comments on the quality of this latest Puppet Show. I loved the first few games, but they have strayed too far from the original concept. Far fewer 'puppets', and the story line fell into the same traps as other games available now, that is the 'story within a story', the compartmentalised way most games are set up these days. In the first Puppet show, it required quite a lot of remembering what happened at the beginning as this played a part later on in the game. Now all we have to do is remember what happened now that have moved into a new scene.

We don't want a quick game, we want something that stretches our thinking skills and our imagination. Stop rushing these games out, surviving on the success of the original game. We are prepared to wait for a good quality, long game.

Jill
 
 
 posted in Echoes of the Past: The Revenge of the Witch on Sep 21, 15 12:13 AM
Hi,

I'm going back over games played years ago, and really enjoying this, but I've come a bit unstuck re how to get rid of the owl in the tree. I've downloaded the walkthrough, which says to 'note the owl guarding the tree', but that's the only reference to the owl. Later on the 'hint' directs me to the tree, to get the small sword but using the insecticide on the insects. But going very carefully through the walkthrough, no mention of what to give the owl to eat. I'm assuming this has something to do with getting some cheese to get the mouse to come out, but no cheese either. Help!
 
 
 posted in Mystery Tales: Alaskan Wild Collector's Edition on Sep 8, 15 12:55 AM
I've got the same problem, but after reading all about the failed updates, I think, and I'm not happy about this, we have to uninstall the game, make sure we get the updates, and start again. As one gamer said, this sucks.

 
 
 posted in Subliminal Realms: The Masterpiece Collector's Edition on Aug 3, 15 12:53 AM
Hi, I've tried twice but each time the jack in the box wasn't in Iris' wardrobe, what am I doing wrong?

 
 
 posted in Awakening: The Sunhook Spire Collector's Edition on Mar 15, 15 6:29 PM
I can't work out the Gate of Reflections at all. I don't understand the instructions and found this all the way through the main game. The instruction box doesn't stay up long enough and I often had to click on it three or four times to find out what I had to do.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator