Posts created by szeb

 
 
 posted in Otherworld: Omens of Summer Collector's Edition on Apr 21, 17 7:57 AM
I have no idea if this will ever reach BoomZap, but please continue this series. It was beautiful, fun, and even after all these years I keep looking that maybe, just maybe, the final chapter will be released. I would buy it in a heartbeat. So please, Big Fish and BoomZap, continue this wonderful series. It has remained one of my favorites to this day. It was really that good.
 
 
 posted in Queen's Quest III: End of Dawn Collector's Edition on Apr 2, 17 5:21 PM
Same exact reason I came here. I tried everything, too, and nothing works. I know the solution just can't get it to work. Makes me hesitant to buy the game. Hoping I'm just not getting something because the game looks promising.
 
 
 posted in Lost Lands: The Golden Curse Collector's Edition on Dec 28, 15 2:47 PM
So, still no fix for the bonus game tea puzzle I guess. Too bad. Really such a great game, only to be ruined because I'm unable to finish. Third game something like this has happened with these past few months...getting annoying. I don't have the time to replay these games. I'm sure Big Fish would refund my money as customer service has always been excellent, but I would much rather have patches for these games. Unfortunately those rarely seem to come.
 
 
 posted in Lost Lands: The Golden Curse Collector's Edition on Dec 28, 15 2:40 PM
I had the same problem, had hoped there would be some type of fix by now, but no. And I agree this is definitely a glitch because you should NOT have to replay a whole entire game in order to continue. In other games, when order was important, you either can't add the ingredient or when you are done they tell you that something went wrong, try again and the ingredients reset so you can try again. A definite glitch and there is no way I'm going to replay a whole entire game for the last few minutes. I wish I had the extra hours to spare for that but I don't, and when you play a game in the little free time you do have to relax, and can't finish it because of a glitch like this, it's really frustrating and disappointing. This is the third game I've had the same problem with these last few months and it's starting to get annoying.
 
 
 posted in Rite of Passage: Hide and Seek Collector's Edition on Jun 22, 14 3:52 PM
Love this game (all the games in this series) but this puzzle made me batty!! I was getting so frustrated and almost skipped. I was trying to logic it out and it kept just slipping past alignment. Finally took the advice on here, spun the wheel randomly, then when I saw the parts near each other (I focused on the one with the dots since that was easy to differentiate), I just turned each wheel slightly to try to align...then lo and behold they did when I was sure they wouldn't. I don't mind hard puzzles, but I consider these just aggravating. Thanks for the help guys, otherwise I would have just skipped.
 
 
 posted in Haunted Train: Spirits of Charon Collector's Edition on Jan 13, 14 4:15 AM
I was unable to pick up the pages in Prague, as well. After picking up the gin, the scene panned out and even though the map showed an action available and the hint button highlighted the statue I was unable to zoom in. I thought the game just didn't register that I already had the gin, but now, on the train with no way back to Prague, I have no book pages. I'm trying a reinstall, though I doubt that will fix anything. I also don't want to replay the game with a new profile (it was fun but it didn't blow my mind) especially since this problem could occur again.

Other glitches I had were being thrown out of the game (around 3 times) and the diary pages were added in the wrong order in the beginning (an earlier page was added when I was almost done with the chapter in Paris and then I couldn't access the later pages which I had already received). The diary was not really an issue as I usually only check it out because the developers take the time to make one and when I need it for clues. In this case I didn't lose access to any needed clues, so I'm just making a note of it. When I got thrown out of the game I didn't lose any progress so it was only a minor annoyance. However, this diary pages issue is a rather annoying problem since I hate to leave anything unfinished. I must say I'm disappointed.

PS: As I thought, uninstall/reinstall did not fix the diary issue.
 
 
 posted in Haunted Train: Spirits of Charon Collector's Edition on Jan 13, 14 3:48 AM
Same problem for me. The game did not let me zoom in to pick them up. Others have had this problem and there seems to be no fix. I would suggest contacting tech support which is what I'm going to do.
 
 
 posted in Haunted Train: Spirits of Charon Collector's Edition on Jan 13, 14 3:37 AM
The same thing just happened to me. After I got something out of the stone book it zoomed out then I couldn't zoom back even though the map showed there was an action available. The hint highlighted the statue but I couldn't zoom back in on it. I finished Prague, I'm on the train and no pages. I was hoping there was a fix, but tech support it is.
 
 
 posted in Awakening: The Sunhook Spire Collector's Edition on Aug 17, 13 4:04 PM
Ooops, just saw that there are achievements, and one of them is not using skip. *sigh*
 
 
 posted in Awakening: The Sunhook Spire Collector's Edition on Aug 17, 13 4:01 PM
I had trouble with the ladybug and leaf puzzle (chapter 2). I clicked the correct leaves, nothing happened. Re-tried, again nothing. Tried again, same. Checked strategy guide 5 times, made sure I clicked them in order, checked them leaf by leaf...still did not register that the puzzle was solved. Is there something extra to do or is it a glitch? Finally had to skip puzzle (and I hate doing that...silly matter of pride, I know, especially in a game with no achievements) to continue. Just mentioning it in case someone else has a similar problem. Otherwise, loving the game!
 
 
 posted in Off the Record: Linden Shades Collector's Edition on Jun 10, 13 4:17 AM
I'm a PC Win 7 user and have had a problem with items disappearing in HOS, then reappearing. This especially occurs after the interactive items. Nothing has disappeared for good, but I haven't gotten far into the game. I'm playing in high performance and my PC more than meets the minimum requirements. I just came on here to see if others have had similar problems and they have. So far it hasn't decreased my enjoyment of the game, but just letting the BFG know that there does appear to be a glitch.
 
 
 posted in Spirit Seasons: Little Ghost Story on May 29, 13 5:11 AM
Well, I know this game is a few years old already, but I'm trying to get through my game backlog, and I realized I had never played it. It was cute, a bit too many HOS for me, but then again games have changed quite a bit since this came out. What drew me in was the story, and I would like to know the alternate ending, but I know I will never play this game again just for that. So, I thought maybe someone could post what would have happened if I would have given the doll to Jacob? I gave the doll to Agatha (I could write that ending if anyone wishes). Thanks!
 
 
 posted in 2 Tasty Too on Feb 19, 13 4:02 AM
I can't get the last two items, either...I hope someone will have an answer. The recipes sound rather tasty.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator