Posts created by anangelseyes4me2

 
 
 posted in Frankenstein: The Village on Aug 12, 16 10:59 PM
I can generally find something 'good' to say about a game even if it isn't my cup-o-tea.
Sadly - I can't find anything good to say about this game. There are footprints that tell you where to go... so you end up going in circles. Nothing is open. It's slower than a slug on sleeping pills and Janet has nothing good to say. On top of that, when Brad gets back to the car, Janet is mysteriously missing, yet nothing in the story indicates she has left, been kidnapped, etc. I think it would even bore my youngest grandchildren at 8 yrs and 11 yrs old.

If there were ANY testers that allowed this game to be put through for customer enjoyment, they must have been created by Dr. Frankenstein and programmed hit and miss by a 2 yr old.

Such a waste of good time.
 
 
 posted in Nevertales: Legends Collector's Edition on Jun 28, 16 10:21 PM
I played the one of the silver wings (that goes in the lab cabinet) in the cabinet and I can't get it back. I now find that I'm supposed to use it to play a HOP with the book from the statue in the Palace hall. Is there anything I can do to "go back"? and do it in the correct order?

Thanks
anangelseyes4me2c
 
 
 posted in Green Moon 2 on Jun 14, 16 9:03 PM
I am on the Moon and found the Alter of Fire. Then it said I was running out of oxygen. I pressed on the green heart, but it hadn't filled up completely. So I left the moon and when I went back - same problem. The circle hadn't finished filling up. HOW do I get more oxygen? I have gotten "GAME OVER" six times and I'm ready to chuck this game. Please advise. THANKS!
 
 
 posted in The Promised Land on Oct 18, 14 1:24 PM
I have now spent 90+ minutes trying to figure out this game. Plus losing game minutes (I'm have 42 minutes left.) It looks fun, but I can't get the workers to stop working. They say they are hungry so I pick them up and after FINALLY finding the table, drop them there. They turn around and go back o collecting food. There are no instructions, (i.e., how to get them to start working and then to stop working and do another task or eating and so forth.)

I know it sounds crazy to ask for a walk-through for such a simple game, but I'm at my wit's end. Is there one out in the vast air known as the Internet?

anangelseyes24me2
Thanks!
 
 
 posted in The Promised Land on Oct 18, 14 12:57 PM
bookwriter wrote:Played for awhile but couldn't figure out how to build a house for the survivor that appeared. Tutorial is lacking greatly. Graphics are really cute and music is nice, but game play was nonexistent for me because of lack of direction. I tried everything I knew to do with no advancement, so it is a definite no buy for me today, which is a shame because it really is a cute game.
PS I did go to the forums for direction but what concerns me is if I am having trouble this little into the game, what am I going to face later on?
 
 
 posted in Awakening Kingdoms on Jul 22, 14 11:41 PM
To: drkgordon and Japan85

You both referenced the following: Japan85 wrote:
I also had the same problem. But the solution was simple. Start the game with disabled network connection, then minimize it, enable the connection, and game should You log in without any problems.

My head is spinning. I've tried over and over to uninstall and re-install, etc. My granddaughter in the next room is playing AK and I also get stuck at 1.81 - connecting...

But... Start the game with disabled network connection, then minimize it, enable the connection, and game should You log in without any problems. I read this and my head spins faster. I have absolutely no idea what this means or how to do it. Do you have more specific instructions or a step-by-step walkthrough? Please let me know. Any assistance is greatly appreciated.
 
 
 posted in Elementary My Dear Majesty on Dec 14, 13 7:22 PM
Also forgot to mention... I'm down to 47 minutes of play left and I've never even opened the game.

And a lot of wasted time.
 
 
 posted in Elementary My Dear Majesty on Dec 14, 13 7:18 PM
I'm having the same problem as Crystal. The game opens so large (and in B/W) that I have to CTL/ALT/DEL to get out. I go back in and it's now in color, but the info to open the game is to the far right and I am unable to access anything to get the game opened. I have a new touch screen computer all up dated,, etc. Have never had this problem before. Any suggestions/help?? Thanks in advance.

T
 
 
Where would I find the Walkthrough for this game??

Thanks!
 
 
Please disregard former post - my MENOPAUSE brain is working overtime today. I have the SE version and will go find the walkthrough.

Oy Vey! After age 50 I am no longer responsible for my words or actions! hahah
 
 
I've been trying to find a walkthrough, then realized that I had purchased the CE version. So, I clicked on Strategy Guide and a page popped up saying I can download the trial version and use it for five minutes. What's going on???

Please help!

Thanks!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator