Posts created by Carol21950

 
 
Add me to the list of people who cannot get the candle! Sword? What sword?
 
 
I am playing the tree house HOP and have lighted the candle in the anvil. However, when I try to take the candle, I get a message saying the sword needs to go there. What sword? How can I get the candle?

Will also post under Technical Difficulties.

Thanks.
 
 
I couldn't get that mini-game to work, either. I was doing everything correctly, but the last part would not work. Finally had to just skip it.
 
 
I successfully completed the main game and began the bonus chapter. About 84% of the way through that. I'm playing a HOS and am supposed to use the scissors to cut a paper garland. Picked up the scissors and they vanished. Can't finish the HOS so I can't finish the game.

If I want to try again, I will have to replay the entire game from the beginning so I can access the bonus chapter.

NOT GOOD AT ALL!
 
 
 posted in Otherworld: Spring of Shadows Collector's Edition on Jul 10, 14 6:13 PM
The map is a scroll in the top right corner of your screen.
 
 
 posted in Grim Facade: Mystery of Venice Collector's Edition on May 23, 14 7:47 AM
You'll need the magnet to get the piece out of the water.

Can't remember about the cheese... Kitchen?
 
 
 posted in Grim Facade: Mystery of Venice Collector's Edition on May 23, 14 7:39 AM
I've got exactly the same problem! I have dragged the drumstick over to the drum 50 times with no result.
 
 
I had a problem losing the hammer after forging the sickle. Once I got to the glass case with the pet in it, I couldn't break the case open.

I backtracked to the smithy, but couldn't enter. I certainly didn't drop the hammer someplace!

Tried uninstalling and reinstalling, but still cannot get the hammer back.

Must I restart the whole game?
 
 
 posted in Lost Lands: Dark Overlord Collector's Edition on Mar 8, 14 12:12 PM
I got it! Admittedly, I skipped this puzzle, finished the game, then went back and solved it in the Extras. But I did get it.

First of all, notice that the center ring does not move. This is important.

Second, there are two "parking spaces", one on either side of the game. Each parking space holds one piece of the outer ring and one of the middle ring.

Now, here's how to solve the puzzle. Pick an arbitrary spot on the inner (immoveable) ring. I selected center right, which is a branch with 5 leaves on it. Now, move the outer ring (OR) piece on that side into the parking space. On the left side of the puzzle, move that outer ring piece into its parking space. These pieces will not move until you get the middle ring (MR) done.

Whatever MR piece is next to the target piece on the inner ring, move it into the parking space on the right. This frees up the space for the correct piece.

Rotate the MR so that the correct piece is next to the left-hand parking space, and move it into that parking space. You now have two empty spaces on the MR.

Rotate the MR so that the other empty space is next to the left-hand parking space, and move the correct piece into it. Rotate the MR back so that the piece in the right-hand parking space can move into it. Rotate the ring again, and the correct piece will now be next to the matching inner ring piece.

The next piece on the inner ring, below the one you just fixed, is a 5-pointed leaf. Look for its mate in the MR. There are a couple of similar leaves, so make sure you're getting the right one.

Again, rotate the MR so that the piece that has been next to the target leaf on the inner ring gets to the right-hand parking spot. Rotate the MR so the correct leaf is next to the left-hand parking spot, and move it out. Rotate the MR to put the correct leaf into the other empty space, rotate to put it in the right spot, rotate again to put the leaf in the right-hand parking spot into the empty slot, and rotate back.

Keep doing this, remembering that the inner ring doesn't move, and you will have to compensate when you move the middle ring. Once you finish the middle ring, it will be easy to do the outer ring.

I hope that's clear enough.
 
 
Add me to the list! Maybe if I had found the brush before I looked in the hole, this would work. I hate to re-start!
 
 
 posted in Mystery Trackers: Four Aces Collector's Edition on Sep 20, 13 7:19 AM
Elf is in the trap, I need to call James, the phone is missing one battery. The game thinks I have it, but I don't.

I post about this months ago and NO RESPONSE!!!!!
 
 
 posted in Mystery Trackers: Four Aces Collector's Edition on Sep 20, 13 7:18 AM
No reply from BFG. Can't anyone help?
 
 
 posted in Mystery Trackers: Four Aces Collector's Edition on Aug 23, 13 12:06 PM
Elf went into the trap to retrieve the last battery. I am to call the Beast to free Elf, but the phone won't work with just three batteries. The fourth battery is outside, but there is no way to get it.

I posted weeks ago with no reply yet. HELP!!!!
 
 
 posted in Mystery Trackers: Four Aces Collector's Edition on Aug 4, 13 7:43 AM
I'm playing on an iPad, and have reached the point at which Elf is trapped in the cage in the museum. I am supposed to call James for help on the video phone, but need 4 new batteries to make the phone work, and I only have 3 of them. There is a battery in a broken street lamp outside, but I have no way to reach it.

The SG is no help at all, since it thinks that last battery came out of the cage when Elf went in.

So, now what do I do?
 
 
 posted in A Gypsy's Tale: The Tower of Secrets on Feb 16, 13 6:35 PM
I have all the ingredients for the rain potion, but when I try to add the clouds to the boiling water, I get a message saying, "You have no need to add this ingredient for this potion." Well, actually, I do! Can't add the fireflies, either.

Now what doI do?
 
 
I am having the same problem with being unable to play the bonus section. I finished the game and opened the bonus section, yet when I click on/tap Rupert, nothing happens.

I tried shutting off my iPad and the. Restarting it, but that doesn't help.

I think I will call the Help line on Monday. This is annoying.
 
 
Me three! Very annoying. I, too, have tried shutting down and rebooting.
 
 
I was playing with no problems until I needed to create the carousel ticket. It was late at night and I needed to sleep, so I used the menu to quit the game.

When I started the game the next time, it opened at the ticket place, but I cannot get the square buttons to pop out of the slot on the right. I've tapped and pushed and used every motion I can think of, but can't get it to work. I've tried maneuvering to other areas of the game and then returning to the ticket booth, to no avail.

This is for the third child, which means I've gotten most of the way through the game. I sure don't want to have to start all over again.

Any ideas?
 
 
 posted in Grim Tales: The Bride on Oct 9, 12 10:07 AM
I used the dropper to mix the colors in the three flasks on Father's table. The colors were correct, but the drawer still wouldn't open. I tried again with no luck. Saw there was no mention of this in the technical issues area. Ended up hitting SKIP.
 
 
 posted in Witch Hunters: Stolen Beauty on Sep 27, 12 12:15 PM
I cannot get the puppet to turn over for the key insertion. I read elsewhere that the puppet's parts have to be installed in a certain order. Of course, I had no way of knowing this at the time. So I cannot progress any further with the game.

Perhaps the game could be fixed with an update that would prevent a puppet part from being installed unless it was in the proper order?

Anyway, what do you suggest? Must I start the game all over again?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator