Posts created by melrat

 
 
 posted in Grim Tales: The Stone Queen Collector's Edition on Jan 7, 13 6:17 PM
Bought it with out trying it as I have played all the others in this series. This stood up to that experience. Very enjoyable. One of those games you can sit back relax and take your time with. HOG parts were very easy but in a good way. The puzzles throughout the game made you think and kept you going.

Graphics were lovely as was the sounds (although I didn't really like the goblin like fellows, but you can just click through and not listen to them).

 
 
 posted in Shop It Up! on Dec 18, 12 4:35 PM
To be honest when I first tried the game I thought nah this isn't going to be for me. But then I found myself getting involved more to the point that when my trial ran out I had to buy it because I wanted to continue . Its very addictive. graphics are OK as are the sounds. I like that you don't have to go to far into the campaign mode to open up casual mode.
Quirky little game but well worth a try
 
 
 posted in The Game of Life ® on Oct 24, 12 6:11 PM
[Removed by Moderator]
 
 
 posted in Jigsaw World on Jul 4, 12 3:07 AM
I cannot get the game started at all. Just sits on a black screen with the hourglass
I have checked my compatibility and the tech issues pages but cannot find anything that will help. I have also seen others say the same thing but they have no replies either. If there is anyone who knows the solution to this issue please let me know.

P.s I also re downloaded and installed to no avail. And I am running Windows 7 OS
 
 
 posted in Glow Fish on Feb 23, 12 3:56 PM
This is actually an entertaining game. Very easy going, something you can play when you have to fill time or just want to relax. The graphics are fun and the game mechanics are very well put together.

8/10
 
 
Yay! I have been waitinf or this game since doing the beta version. I loved it then and have been itching for it to come out. This is a really good game. Good puzzles (not to hard not to easy) great finding scenes and fantastic story. A++ for this one.
 
 
 posted in Wild Tribe on Aug 20, 10 10:12 PM
Oh and I can not pick anyone up to move them so now the village has been attacked and lost all their food etc.
 
 
 posted in Wild Tribe on Aug 20, 10 10:11 PM
I paused my game overnight as i had just about won it, and when i started it again in the morning all my people had illnesses and were going to die! Argghh anyon else have this? If this fails I am not going to bother starting a whole new tribe.
 
 
 posted in Wild Tribe on Aug 20, 10 3:01 AM
UPDATE

I made a mistake during the first tribe becuase I didnt leave enough to reproduce . I have started a new village and this time prgress is much faster .

so far 7/10
 
 
 posted in Wild Tribe on Aug 20, 10 2:27 AM
GAME SPEED k, so far I have found this game to be a bit slow. You can change the game speed from slow, norm or fast but fast is not fast enough. You can pause also if you need to go as this game is the same as VV (virtual Villages)and continues even if you are not on.

HINTS:There is a hint button that re sets after a few minutes, but so far the hints are not very helpful.

PROGRESS: I have 2 builders, 2 defenders and 1 doctor at the moment. I have not been able to get a gatherer as the building crew are still (slowly) working on the first building. Not sure if this is going to be a place for gatherers to store food or not.

SOUNDS:The music stops and starts between different tunes which I found annoying so I switched it off.

I will add more after I play further.... so far I would give it a 3/10
 
 
 posted in Nostradamus: The Last Prophecy on Mar 21, 09 9:12 PM
Yep have added everything else first but still does not work. I added cypress wood ,orris and aloe then a spoon of clove then pipette of rose petal juice and musk. According to the recipe thats all then add Ambergris.
 
 
 posted in Nostradamus: The Last Prophecy on Mar 21, 09 5:17 PM
I am also stuck here. She keeps telling me that you need to know exactly what I'm doing with the Ambergris. I have even gone through walkthroughs done exactly what they say but still have the same problem. Arghhhh Help!
 
 
 posted in Totem Tribe on Jan 30, 09 8:19 PM
the fishing line is in the top left hand corner. you need to use the idol to clear the black fog. when you have all the fishing items together it will turn into a fishing rod. on the top left corner of the island you will see little circles in the water. use the rod there and you will catch a fish. take the fish to the hut with the penguins, the guy will give you a map to the iceberg.
 
 
 posted in Mystery Chronicles: Murder Among Friends on Sep 18, 08 8:15 PM
dpascoe8692 wrote:We are stuck at the safe it says puzzled but can't open the safe and it says paused.

I had the same trouble, so I left the game at that spot and kept checking it. For some reason after about 2 days the little arrows appeared above the numbers to change them. Dont understand how or why it happened this way, but I can finally go on.
 
 
 posted in Mystery Chronicles: Murder Among Friends on Sep 14, 08 6:35 PM
dpascoe8692 wrote:We are stuck at the safe it says puzzled but can't open the safe and it says paused.


I am also stuck at this puzzle. I have solved the suduko and the diary states 'puzzle solved closed diary to continue'. When I close the diary the game is paused and a small screen has appeared with the safe combination on it. I have tried everything.
Please help!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator